Napp It- vmtools running but "unsupported" should I do anything?

epicurean

Active Member
Sep 29, 2014
660
41
28
checking the summary of the Napp It VM in my esxi 6.0, I see that it says that its running but "unsupported?

Should I update it? if so, how?

sorry for the noob question
 

epicurean

Active Member
Sep 29, 2014
660
41
28
Thanks Gea.
I tried to update via the instructions on the napp-in-one.pdf. It hangs at the "Guest Memory Manager:" on the screen, right after stopping VMware tools services in the virtual machine.

If I download the appliance VM, how do i update my current napp It VM? will I lose my data?
 

gea

Well-Known Member
Dec 31, 2010
2,502
842
113
DE
If you use another OmniOS VM installation, y0u simply need

- enable pass-through (switch HBA, optionally)
- to reimport your pool
and your data is available

If you want to keep napp-it settings like groups, jobs or keys
save/ restore /var/web-gui/_log

optionally
- update OmniOS with a pkg update (console as root, reboot required)
- update napp-it via menu About > update
 

T_Minus

Build. Break. Fix. Repeat
Feb 15, 2015
7,029
1,578
113
CA
If you update ESXi you should update the vmware tools on guests.
You can now either

- download the current appliance VM from napp-it.org
as it includes tools for ESXi 6

- update vmware tools on OmniOS,
see http://www.napp-it.org/doc/downloads/napp-in-one.pdf page 9 (Chapter 5.3)

download: napp-it_15d_ova_for_ESXi_5.5u2-6.0. (Sep 18,2015)

That's the one I saw on your site where's the ESXI 6.0 one?

EDIT: Nevermind, I think the file name means 5.5 u2 --> 6.0 -- right ?
 

epicurean

Active Member
Sep 29, 2014
660
41
28
Hi Gea,

I did the update via Napp it Menu.. Same ..still unsupported error after a successful update
 

gea

Well-Known Member
Dec 31, 2010
2,502
842
113
DE
For newer tools, you must either install them from the ESXi iso at console or download and import the new VM.

Updates of the napp-it UI do not include system/OS updates
 

epicurean

Active Member
Sep 29, 2014
660
41
28
HI Gea,
So I just export my data pools, shut down. install the latest 15d ova and import the pools again, that should work right?
 

gea

Well-Known Member
Dec 31, 2010
2,502
842
113
DE
Yes, correct.
For pass-through you must remoce the adapter from the old VM and add it to the new one.
A reboot of ESXi itself may be needed then.
 
  • Like
Reactions: epicurean