LSI 9440-8i Boot config menu

Discussion in 'RAID Controllers and Host Bus Adapters' started by Anthony A, Jun 8, 2018.

  1. Anthony A

    Anthony A New Member

    Joined:
    Apr 12, 2018
    Messages:
    9
    Likes Received:
    1
    Hi,

    So i got myself a 9440-8i Card. I slap it into a machine and when it boots i get no "CTRL-..."

    I have no idea how to access to menu to configure raids. I looked up online and it says to active EUFI boot in the bios and the menu will apear in the bios... I put it in a Lenovo TS440, No such menu appears.

    Any Ideas, I will try it in another machine on monday...
     
    #1
    nthu9280 likes this.
  2. Rand__

    Rand__ Well-Known Member

    Joined:
    Mar 6, 2014
    Messages:
    2,280
    Likes Received:
    271
    You have set the boot option to DUAL or UEFI and also the slot the card is placed in?
     
    #2
  3. Anthony A

    Anthony A New Member

    Joined:
    Apr 12, 2018
    Messages:
    9
    Likes Received:
    1
    I tried 2 slots, the card "posts".
    The card posts at bootup, I see the Model, disks attached and it run through some kind of initialisation process. but no option to enter config.
    I did set the bios to dual. but instructions says it would apear in bios? (nothing appears) - also updated bios to latest version.
     
    #3
  4. Rand__

    Rand__ Well-Known Member

    Joined:
    Mar 6, 2014
    Messages:
    2,280
    Likes Received:
    271
    Bios integrated usually only works if card and main board are from the same vendor if at all.

    I'd look at a hotkey to enter the bios of the card. Or maybe it has no bios flashed?
     
    #4
  5. Anthony A

    Anthony A New Member

    Joined:
    Apr 12, 2018
    Messages:
    9
    Likes Received:
    1
    It has a Bios or we could not boot from it. (i can boot with a "win10 to go", then with the avago software configure the card)

    It would be a shame is LSI created a card (lsi-9440) that only works on a few devices... seems unlikely. (in case of a issue its always piratical to have access to card without having to boot off a usb-key)

    I had the same problem with the Lenovo 530-8i, so i figured, ok, they only work with Lenovo latest gen servers, I can see Lenovo doing that as the card is 100$ less than the original...

    But a Mega Raid branded card, now i'm surprised. i will try to choose it as "boot device" i found a thread that mentioned that. but it will wait until Monday, hardware is at my office.
     
    #5
  6. Rand__

    Rand__ Well-Known Member

    Joined:
    Mar 6, 2014
    Messages:
    2,280
    Likes Received:
    271
    Are you actually booting from it or can you boot with it in place and then configure from Windows?

    If you can boot from it then you most likely have a bios and you could just try to identify/press the hotkey.
    And you didnt mention it explicitly, you set the Bios Boot options for Dual, and also the individual slot? At least on Supermicro Boards there are two different locations in the Bios to do that.
     
    #6
  7. Anthony A

    Anthony A New Member

    Joined:
    Apr 12, 2018
    Messages:
    9
    Likes Received:
    1
    Yes the Card boots, we tested that. if i boot to windows and then configure the raid, i can do everything like a normal raid card. I just can't figure out how to get into the "bios menu" on boot up.

    I tried both x16 slots on the board. (its a lenovo e3 based server) - I also tried the card in a S2600cp2, but back then i had not figured out that i needed to set the bios to UEFI.

    Like I mentioned on the first post. the card list itself on after bios splash screen (like all previous gen lsi cards we sold) does an init, then shows drives and raid and then finally "boots" up windows. but no mention of CTRL-R or A or maybe another combination.

    The instructions state, to use HII to configure card (from within bios)

    i will try to update Bios on LSI9440... maybe that is the issue.

    MegaRAID 9440-8i Tri-Mode Storage Adapter Quick Installation Guide (229 KB)
     
    #7
  8. Anthony A

    Anthony A New Member

    Joined:
    Apr 12, 2018
    Messages:
    9
    Likes Received:
    1
    Follow up.

    So looks likes the only way to access the Card is through "HII" interface, StorCli or windows APP.

    Beware if you buy a 9440 or 9460 card you will run into issues to configure card on older Hardware.
    I tested the card in two different machines and nothing.
    Looks like you need more than UEFI bios, you need one that supports "HII" (meaning 2.1+)
    I am a bit short on time to do more testing. its possible to boot of a usbkey with StorCLI and manage the card that way. not as "easy" but it will have to do, i need to deliver the machines that we sold!
     
    #8
  9. Rand__

    Rand__ Well-Known Member

    Joined:
    Mar 6, 2014
    Messages:
    2,280
    Likes Received:
    271
    Hm interesting, never heard of that.
    But 2.1 is quite old actually so should be on most boards nowadays...

    Version 2.1 of the UEFI specification was released on 7 January 2007. It added cryptography, network authentication and the User Interface Architecture (Human Interface Infrastructure in UEFI). The latest UEFI specification, version 2.7, was approved in May 2017. (wikipedia)
     
    #9
  10. Anthony A

    Anthony A New Member

    Joined:
    Apr 12, 2018
    Messages:
    9
    Likes Received:
    1
    I found no documentation on LSI(broadcom/avago) website about whats compatible and whats required.
    I tested the card in a LEnovo TS440 server (around 3 years old) and nothing is added in the bios.

    I also tested a New Desktop computer... nothing either.
    I am about to try it in a TD350 server (+/-2yrs) today (let see...)

    Yeah i am aware about uefi being around for a while... but like lots of things, its only on cut-off date that we are pushed into new standards...
     
    #10
Similar Threads: 9440-8i Boot
Forum Title Date
RAID Controllers and Host Bus Adapters flash a Lenovo 530-8i to a 9440-8i Apr 12, 2018
RAID Controllers and Host Bus Adapters LSI 9266-8i won't boot with CacheVault module installed Oct 8, 2017
RAID Controllers and Host Bus Adapters AMD Threadripper Bootable RAID Oct 2, 2017
RAID Controllers and Host Bus Adapters Highpoint bootable SSD7110 driver works on SSD7101 Sep 5, 2017
RAID Controllers and Host Bus Adapters SAS2flsh stuck at "Performing Host Boot" Jul 12, 2017

Share This Page