HP T730 Thin Client low perf on Proxmox

fossxplorer

Active Member
Mar 17, 2016
467
74
28
Oslo, Norway
Anyone ever got the turbo speed to be triggered? I've done various tests to trigger it on PVE, no luck so far with turbostat and just watching /proc/cpuinfo. Also got a Windows guest running, it seems to cap at 2.69Ghz.
current CPU frequency: 2.70 GHz (asserted by call to hardware)
boost state support:
Supported: yes
Active: yes
Boost States: 3
Total States: 8
Pstate-Pb0: 3600MHz (boost state)
Pstate-Pb1: 3200MHz (boost state)
Pstate-Pb2: 3000MHz (boost state)
Pstate-P0: 2700MHz
Pstate-P1: 2500MHz
Pstate-P2: 2200MHz
Pstate-P3: 1800MHz
Pstate-P4: 1400MHz

So i'm eager to see Pstate-Pb{0,1,2} states :)

EDIT1: i'm getting terrible performance with Geekbench & CPUMark in my Win10 guest. Using VirtIO drivers for storage, network and memory (balloon). QEMU Standard PC (i440FX + PIIX, 1996) - Geekbench Browser
Anyone tested performance on their Windows KVM guest? The perf of T730 is on the level T620 Plus :(

EDIT2: i see the same level of performance on the PVE host itself: HP HP t730 Thin Client - Geekbench Browser. So it seems not to be related to Windows being virtualized at least. It's PVE + AMD, not doing the frequency scaling right way. I have some other Intel PVE hosts using pstate and they seem to be doing well.

EDIT3: Just found this interesting entry in proc which isn't to be seen on my other PVE hosts with Intel CPU:
root@pve3:~# cat /sys/devices/system/cpu/cpufreq/policy0/bios_limit
2700000

EDIT3: just installed CentOS 7 on another M.2 SATA i had laying and the result is what it should be with PVE as well:HP HP t730 Thin Client - Geekbench Browser
SO it all points to PVE kernel!
 
Last edited:

arglebargle

H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈
Jul 15, 2018
656
233
43
Add "radeon.bapm=1" to your kernel boot command line and install either the "cpufrequtils" or "linux-cpupower" packages. "linux-cpupower" is newer, cpufrequtils should apparently be used for ~core2 era processors.

How to enable AMD Turbo Core on Ubuntu 14.04?

Cpufreq or Cpupower? / Newbie Corner / Arch Linux Forums

Code:
root@rufus:~# cpupower frequency-info
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 4.0 us
  hardware limits: 1.40 GHz - 2.70 GHz
  available frequency steps:  2.70 GHz, 2.50 GHz, 2.20 GHz, 1.80 GHz, 1.40 GHz
  available cpufreq governors: conservative ondemand userspace powersave performance schedutil
  current policy: frequency should be within 1.40 GHz and 2.70 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency: 1.80 GHz (asserted by call to hardware)
  boost state support:
    Supported: yes
    Active: yes
    Boost States: 3
    Total States: 8
    Pstate-Pb0: 3600MHz (boost state)
    Pstate-Pb1: 3200MHz (boost state)
    Pstate-Pb2: 3000MHz (boost state)
    Pstate-P0:  2700MHz
    Pstate-P1:  2500MHz
    Pstate-P2:  2200MHz
    Pstate-P3:  1800MHz
    Pstate-P4:  1400MHz
root@rufus:~#
Code:
root@rufus:~# cat /etc/default/grub | grep CMDLINE
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX="root=ZFS=rpool/ROOT/pve-1 boot=zfs video=1920x1200 radeon.bapm=1 amd_iommu=on iommu=pt/g"
root@rufus:~#
 

arglebargle

H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈
Jul 15, 2018
656
233
43
Also check which governor the system is running. When I had cpufrequtils installed my machine was using ondemand and never seemed to scale into the boost states, with cpupower installed proxmox is using the performance governor and I'm seeing it scale to >3GHz.

Here's what I'm seeing with radeon.bapm=1 and cpufrequtils uninstalled on my DFI RX-427BB box:
Code:
root@rufus:~# cpupower frequency-info
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 4.0 us
  hardware limits: 1.40 GHz - 2.70 GHz
  available frequency steps:  2.70 GHz, 2.50 GHz, 2.20 GHz, 1.80 GHz, 1.40 GHz
  available cpufreq governors: conservative ondemand userspace powersave performance schedutil
  current policy: frequency should be within 1.40 GHz and 2.70 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency: 2.70 GHz (asserted by call to hardware)
  boost state support:
    Supported: yes
    Active: yes
    Boost States: 3
    Total States: 8
    Pstate-Pb0: 3600MHz (boost state)
    Pstate-Pb1: 3200MHz (boost state)
    Pstate-Pb2: 3000MHz (boost state)
    Pstate-P0:  2700MHz
    Pstate-P1:  2500MHz
    Pstate-P2:  2200MHz
    Pstate-P3:  1800MHz
    Pstate-P4:  1400MHz
root@rufus:~# grep MHz /proc/cpuinfo
cpu MHz         : 2892.005
cpu MHz         : 3133.258
cpu MHz         : 2535.954
cpu MHz         : 3038.403
If I run `stress -c 1` I can see the APU boosting to 3.4GHz on one core. Two or more threads seems to cap around 2.9GHz.
 
Last edited:

fossxplorer

Active Member
Mar 17, 2016
467
74
28
Oslo, Norway
Thx a lot for your replies! I found out that i had cpufreqd, cpufrequtils and cpupower installed. Removed all but cpufrequtils made the DVFS work at least and i started to get more "normal" bench results both on host and inside guest.
This was prior to reading your post about using cpupower which is more "modern". Using cpupower, i can't get DVFS to work at all, and the freq stays below 1.4GHz all the time:
root@pve3:~# grep MHz /proc/cpuinfo
cpu MHz : 1387.003
cpu MHz : 1396.482
cpu MHz : 1395.935
cpu MHz : 1383.888

And i already had radeon.bapm=1 in Grub (with Active: yes), and still i could not get the turbo to work.
Since your observed turbo is from DFI and not HP T730, can you see if you got the following in DFI: /sys/devices/system/cpu/cpufreq/policy0/bios_limit?
EDIT1: And what's the output of cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies on DFI?

EDIT2: And /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq?

I suspect there is a BIOS limitation of turbo speed on T730s. WRONG, turbo boost speed works, but not straight forward to get it working!
 
Last edited:

arglebargle

H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈
Jul 15, 2018
656
233
43
I actually own a pair of T730s too, let me plug one of those in and check this out today.

Can you dump the output of cpupower frequency-info as well?
 
Last edited:

fossxplorer

Active Member
Mar 17, 2016
467
74
28
Oslo, Norway
Thanks a lot! As i (tried) to indicate, the turbo boost speeds are working. Initially i thought it was only with cpufrequtils, not with cpupower, but later i discovered that the performance governor is making trouble, DVFS isn't working at all, it's stuck at right below 1400Mhz. So switching to ondemand seems to get everything working, including the turbo boost.

This issue made me curious about couple of AMD Opeteron 6376 servers i got running CentOS6 and CentOS 7. Quick check on the latter, there is no turbo at all in the picture, but the DVFS works, e.g by changing to ondemand.

EDIT1: On the CentOS 7 server with Opteron 6376, i see the following:
[root@node02 data]# lsmod | egrep '(cpufreq|fam15)'
fam15h_power 16384 0
acpi_cpufreq 20480 1

while on the T730:
root@pve3:~# lsmod | egrep '(cpufreq|fam15)'
fam15h_power 16384 0

So the cpufreq driver module isn't loaded and in an attempt i tried to install pve-headers-4.15.18-10-pve, still no acpi-cpufreq to see/load.

Another interesting observation is the fact that the turbo boost never exceeds 3.2GHz while this SoC should be able to reach 3.6GHz. Strange, but could be related to the fact that when 1 core is loaded, there is always 2 cores being bumped up, so these cores have some "dependencies" wrt. turboing up and down pair wise.
As such, the turboboost would be lower than for a single core, perhaps..


root@pve3:~# cpupower frequency-info
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 4.0 us
hardware limits: 1.40 GHz - 2.70 GHz
available frequency steps: 2.70 GHz, 2.50 GHz, 2.20 GHz, 1.80 GHz, 1.40 GHz
available cpufreq governors: conservative ondemand userspace powersave performance schedutil
current policy: frequency should be within 1.40 GHz and 2.70 GHz.
The governor "ondemand" may decide which speed to use
within this range.
current CPU frequency: 1.40 GHz (asserted by call to hardware)
boost state support:
Supported: yes
Active: yes
Boost States: 3
Total States: 8
Pstate-Pb0: 3600MHz (boost state)
Pstate-Pb1: 3200MHz (boost state)
Pstate-Pb2: 3000MHz (boost state)
Pstate-P0: 2700MHz
Pstate-P1: 2500MHz
Pstate-P2: 2200MHz
Pstate-P3: 1800MHz
Pstate-P4: 1400MHz
 
Last edited:

arglebargle

H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈
Jul 15, 2018
656
233
43
That's actually a little weird, I'm scaling into boost and idle states perfectly with the performance governor. Apparently the Radeon driver takes care of scaling clock speeds/p-states automatically now and you shouldn't need to load an extra module or run daemons/utilities.

I'm seeing this from the kernel at boot, so I think acpi_cpufreq is at least partly built into the pve kernel:
Code:
[    1.315237] acpi_cpufreq: overriding BIOS provided _PSD data
Note: Reading from /proc/cpuinfo doesn't give accurate clock speeds, apparently turbostat and "cpupower monitor" are the way to get clock speeds these days.

I think if anything the boost clocks on these chips are just a bit disappointing, I don't see much boosting going on when there's more than a single heavy load thread going. I don't know if that's down to the scheduler, the radeon driver, the TDP calculation in the chip's internal boost logic or what.

Also, both Performance and Ondemand are working fine for me w.r.t. scaling, Ondemand idles around 1.4GHz while Performance doesn't drop below around 2.0GHz.

I'd sweep everything relating to cpufreq* and any related modules or config changes and see how the machine runs, I'm pretty sure all you need is radeon.bapm=1 on the command line and boost/idle will perform as optimally as they can. The cpufrequtils stuff comes from an earlier era when the clock rates needed to be controlled by software and I think mixing the two is what's causing some of the weirdness you're seeing.

Edit: I'm boosting above 3.4GHz for very short periods of time when there's a load on one core, I think the boost code for these chips is just extremely conservative with its TDP calculations. I just saw 3.55GHz for about 2 seconds while running stress on one core before it dropped to 3.4GHz and sat there for the duration of the process.

Edit: Run "cpupower frequency-set -g ondemand" and watch the output from "watch -n1 cpupower monitor" while running "stress -c 1" and have a look at the boost clocks. Then do the same thing after switching to the performance governor with "cpupower frequency-set -g performance". I'm pretty sure you'll see peak boost rates using performance.

I've seen drastically different performance/clock rates depending on which scaling governor I'm using while benching my collection of arm SBCs -- performance is pretty much always optimal for raw speed so you'll almost always want to use it while bench testing.

Edit: I've edited this post like a dozen times to correct/clarify what I was saying, sorry.

Whew. No more edits.
 
Last edited:
  • Like
Reactions: fossxplorer

arglebargle

H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈
Jul 15, 2018
656
233
43
One final note - I've been monitoring power consumption with a kill-a-watt while playing around with ondemand vs performance governor and there's no measurable difference, not even 0.1W.

I don't think it's even worth setting ondemand to reduce power draw on these machines, the radeon driver and internal p-state/boost logic manages shutting cores off and clocking them down at idle well enough now that I'm just going to leave my machines on the default "performance" governor.
 
  • Like
Reactions: fossxplorer

Mikepop

New Member
Feb 10, 2018
4
0
1
46
Hello, I've seen this too on my t730, however I see boost as not active :

root@kasa:~# cpupower frequency-info
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 4.0 us
hardware limits: 1.40 GHz - 2.70 GHz
available frequency steps: 2.70 GHz, 2.50 GHz, 2.20 GHz, 1.80 GHz, 1.40 GHz
available cpufreq governors: conservative ondemand userspace powersave performance schedutil
current policy: frequency should be within 1.40 GHz and 2.70 GHz.
The governor "performance" may decide which speed to use
within this range.
current CPU frequency: 2.70 GHz (asserted by call to hardware)
boost state support:
Supported: yes
Active: no
Boost States: 3
Total States: 8
Pstate-Pb0: 3600MHz (boost state)
Pstate-Pb1: 3200MHz (boost state)
Pstate-Pb2: 3000MHz (boost state)
Pstate-P0: 2700MHz
Pstate-P1: 2500MHz
Pstate-P2: 2200MHz
Pstate-P3: 1800MHz
Pstate-P4: 1400MHz

root@kasa:~# cat /sys/devices/system/cpu/cpufreq/boost
1
root@kasa:~# cat /etc/default/grub | grep CMDLINE
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="radeon.bapm=1 amd_iommu=on iommu=pt/g nomodeset video=1920x1080"

Am I missing something? Bios it's the lates one available, 1.15

Thanks
 

Mikepop

New Member
Feb 10, 2018
4
0
1
46
Thanks, it was that, now shows it as active, however I cannot see any boost:

root@kasa:~# cpupower frequency-info
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 4.0 us
hardware limits: 1.40 GHz - 2.70 GHz
available frequency steps: 2.70 GHz, 2.50 GHz, 2.20 GHz, 1.80 GHz, 1.40 GHz
available cpufreq governors: conservative ondemand userspace powersave performance schedutil
current policy: frequency should be within 1.40 GHz and 2.70 GHz.
The governor "performance" may decide which speed to use
within this range.
current CPU frequency: 2.70 GHz (asserted by call to hardware)
boost state support:
Supported: yes
Active: yes
Boost States: 3
Total States: 8
Pstate-Pb0: 3600MHz (boost state)
Pstate-Pb1: 3200MHz (boost state)
Pstate-Pb2: 3000MHz (boost state)
Pstate-P0: 2700MHz
Pstate-P1: 2500MHz
Pstate-P2: 2200MHz
Pstate-P3: 1800MHz
Pstate-P4: 1400MHz
root@kasa:~# cat /proc/cpuinfo | grep "MHz"
cpu MHz : 1396.761
cpu MHz : 1396.997
cpu MHz : 1397.291
cpu MHz : 1395.742
root@kasa:~# cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.0.15-1-pve root=/dev/mapper/pve-root ro radeon.bapm=1 amd_iommu=on iommu=pt/g video=1920x1080 quiet
root@kasa:~# cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=debian
HOME_URL="Debian -- The Universal Operating System"
SUPPORT_URL="Debian -- Support"
BUG_REPORT_URL="Debian bug tracking system"

root@kasa:~# watch -n1 cpupower monitor

Every 1.0s: cpupower monitor kasa: Mon Aug 26 08:39:36 2019

| Mperf || Idle_Stats
CPU| C0 | Cx | Freq || POLL | C1 | C2
0| 0.57| 99.43| 1389|| 0.00| 0.00| 99.67
1| 0.91| 99.09| 1396|| 0.00| 0.00| 99.20
2| 99.98| 0.02| 1396|| 0.00| 0.00| 0.00
3| 0.32| 99.68| 1395|| 0.00| 1.09| 98.77




Regards
 

Mikepop

New Member
Feb 10, 2018
4
0
1
46
Mmm, it seems it's working now only with:

root@kasa:~# cat /etc/default/grub | grep CMDLINE
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="radeon.bapm=1 amd_iommu=on iommu=pt/g"

Every 1.0s: cpupower monitor kasa: Mon Aug 26 09:29:27 2019

| Mperf
CPU| C0 | Cx | Freq
0| 3.84| 96.16| 3191
1| 0.96| 99.04| 3190
2| 4.54| 95.46| 3191
3| 2.32| 97.68| 3189

root@kasa:~# cat /proc/cpuinfo | grep "MHz"
cpu MHz : 3192.432
cpu MHz : 3193.122
cpu MHz : 3193.130
cpu MHz : 3192.345

Thanks!
Regards
 

TheJaguar

New Member
Jan 19, 2020
18
1
3
I am seeing a bit of a strange behavior - by default my CPU was set to "performance" and CPU frequency never went about 1.4 ghz (cpupower monitor) when running stress, but I switched the CPU mode to "ondemand" and the frequency went up to 3 to 3.2 ghz range. I switched it back to "performance" to test how this will affect performance and now the frequency goes up to 3 to 3.2 ghz!

I find it really strange that when the system was in "performance" at first, the frequency was limited to 1.4 ghz and after flipping it back and forth, it's now at 3.2 ghz...

UPDATE: I restarted proxmox and pfsense and it's still behaving as described above. As soon as I switch over to "ondemand", the CPU freq goes up and stays at the higher level even after switching back to "performance".
Also, I feel that keeping it in "ondemand" might be better - have been observing CPU freq for a while (with and without stress) and "ondemand" scales almost instantly to 3.4 ghz, but stays around 1.4 ghz when idle vs. "performance" which keeps the CPU freq continually around 3 ghz during idle.
 
Last edited:

arglebargle

H̸̖̅ȩ̸̐l̷̦͋l̴̰̈ỏ̶̱ ̸̢͋W̵͖̌ò̴͚r̴͇̀l̵̼͗d̷͕̈
Jul 15, 2018
656
233
43
@TheJaguar

Setup your kernel command line like @Mikepop indicated, then set your scaling governor to "performance" and let the radeon driver do all of the work. "radeon.bapm=1" is the only necessary command line flag unless you're using iommu for passthrough.

Mmm, it seems it's working now only with:

root@kasa:~# cat /etc/default/grub | grep CMDLINE
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="radeon.bapm=1 amd_iommu=on iommu=pt/g"

Every 1.0s: cpupower monitor kasa: Mon Aug 26 09:29:27 2019

| Mperf
CPU| C0 | Cx | Freq
0| 3.84| 96.16| 3191
1| 0.96| 99.04| 3190
2| 4.54| 95.46| 3191
3| 2.32| 97.68| 3189

root@kasa:~# cat /proc/cpuinfo | grep "MHz"
cpu MHz : 3192.432
cpu MHz : 3193.122
cpu MHz : 3193.130
cpu MHz : 3192.345

Thanks!
Regards
 

TheJaguar

New Member
Jan 19, 2020
18
1
3
@TheJaguar

Setup your kernel command line like @Mikepop indicated, then set your scaling governor to "performance" and let the radeon driver do all of the work. "radeon.bapm=1" is the only necessary command line flag unless you're using iommu for passthrough.
Yes, that's exactly how it's setup. All my NIC's are setup as VirtIO, but I wasn't sure if it caused any harm to include iommu in Grub and since I have seen all of your configs include it, I included it. Here is what my command line look like:

Code:
root@proxmox:~# cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.3.10-1-pve root=/dev/mapper/pve-root ro radeon.bapm=1 amd_iommu=on iommu=pt/g nomodeset video=1920x1080 quiet
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="radeon.bapm=1 amd_iommu=on iommu=pt/g nomodeset video=1920x1080"
I ended up creating a cron job to set the governor to "ondemand" at boot since I am not able to get the frequency beyond 1.4 ghz unless I switch once to "ondemand" and leave it there or switch back to "performance".
 

newabc

Member
Jan 20, 2019
65
15
8
Maybe there is an issue, geekbench v4 shows the linux version marks 2 cores but windows version as 4 cores with higher scores:
link

My scores when the cpu governor set to "ondemand" and then to "performance" with the pve kernel: link
Code:
# cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.4.34-1-pve root=/dev/mapper/pve-root ro radeon.bapm=1 amd_iommu=on iommu=pt/g quiet

# cat /proc/cpuinfo | grep MHz
cpu MHz        : 2933.108
cpu MHz        : 2371.110
cpu MHz        : 2513.083
cpu MHz        : 2500.035
I can get 53xx on Debian 10, bare metal.
 

sloniu82

New Member
Jun 11, 2020
2
0
1
Hi.
I'm fighting with cpu scalling on my fresh proxmox setup.
Whatever I try, my T730 never went beyond 1396MHz on cpu.

I've added required kernel parametes:
root@t730:~# cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.4.41-1-pve root=/dev/mapper/pve-root ro radeon.bapm=1 amd_iommu=on iommu=pt/g quiet
When quering cpupower everything seems working fine
root@t730:~# cpupower frequency-info
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 4.0 us
hardware limits: 1.40 GHz - 2.70 GHz
available frequency steps: 2.70 GHz, 2.50 GHz, 2.20 GHz, 1.80 GHz, 1.40 GHz
available cpufreq governors: conservative ondemand userspace powersave performance schedutil
current policy: frequency should be within 1.40 GHz and 2.70 GHz.
The governor "performance" may decide which speed to use
within this range.
current CPU frequency: 2.70 GHz (asserted by call to hardware)
boost state support:
Supported: yes
Active: yes
Boost States: 3
Total States: 8
Pstate-Pb0: 3600MHz (boost state)
Pstate-Pb1: 3200MHz (boost state)
Pstate-Pb2: 3000MHz (boost state)
Pstate-P0: 2700MHz
Pstate-P1: 2500MHz
Pstate-P2: 2200MHz
Pstate-P3: 1800MHz
Pstate-P4: 1400MHz
But cpu under strees never go beyond 1.4GHz.
Strange thing I found, cpupower frequency-info thinks that cpu is @ 2.7GHz

very 1.0s: cpupower monitor t730: Thu Jun 11 10:11:24 2020
| Mperf || Idle_Stats
CPU| C0 | Cx | Freq || POLL | C1 | C2
0| 99.98| 0.02| 1396|| 0.00| 0.00| 0.00
1| 99.98| 0.02| 1396|| 0.00| 0.00| 0.00
2| 99.98| 0.02| 1396|| 0.00| 0.00| 0.00
3| 99.98| 0.02| 1396|| 0.00| 0.00| 0.00
Changing cpu governor doesn't change anything.
I've tried change to ondemand, back to perfor mace and so on.
CPU always stay @ 1.4GHz

Is there something else that I need to change at BIOS or in proxmox to get full cpu speeds?
 

newabc

Member
Jan 20, 2019
65
15
8
I set the cpu governor ondemand and then performance to get high frequency again. It seems a cron job is needed.
 

sloniu82

New Member
Jun 11, 2020
2
0
1
I set the cpu governor ondemand and then performance to get high frequency again. It seems a cron job is needed.
That's my problem that all things described here doesn't work for me.
Whatever governor I set, no change in cpu freq.
I'm using cpupower frequency-set -g ondemand and lunch stress - 1.4GHz on cpu.
Then I use cpupower frequency-set -g performance + stress - still 1.4GHz, nothing is changing

dmesg showing that
root@t730:~# dmesg | grep cpufreq
[ 2.522541] acpi_cpufreq: overriding BIOS provided _PSD data
and cpupower show that frequency scalling is actvie
root@t730:~# cpupower frequency-info
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 4.0 us
hardware limits: 1.40 GHz - 2.70 GHz
available frequency steps: 2.70 GHz, 2.50 GHz, 2.20 GHz, 1.80 GHz, 1.40 GHz
available cpufreq governors: conservative ondemand userspace powersave performance schedutil
current policy: frequency should be within 1.40 GHz and 2.70 GHz.
The governor "performance" may decide which speed to use
within this range.
current CPU frequency: 2.70 GHz (asserted by call to hardware)
boost state support:
Supported: yes
Active: ye
s
....
For test I've restored my pfsense vm from main proxmox machine (E3-1235L v5).
Cpu performance on T730 is pretty bad without normal cpu freqs - user experinence on pfsence web interface,vm cpu usage on hypervizor.

I'm on fresh proxmox install, maybe something changed/broke with this in latest builds?
Or some specific setting in bios?