How can I passthrough this GPU [video]?

IamSpartacus

Well-Known Member
Mar 14, 2016
2,299
553
113
No matter what I do this does not stop and will not let me hit the toggle passthrough button. Nothing shows up in /etc/vmware/esx.conf for me to change in there. I've tried 6.7U3 and 7.0 now. No difference.

 

Net-Runner

Member
Feb 25, 2016
80
24
8
37
The GTX 1660 worked for me on ESXi 6.5U2 flawlessly a while ago. If I am not mistaking, it did great on 6.7U1 also. The only issue I can remember out of my head that it didn't like the VM reboot (error 43) and required a host reboot.
Any chance you can try it on 6.5U2 just to make sure it is newer ESXi that is causing the issue and not the GPU itself?
 

ARNiTECT

Member
Jan 14, 2020
59
3
8
The flashing is strange, tried a different browser?

If I select the GPU, it automatically selects the GPU's audio also and does not allow me to see the device ID etc. but I can toggle both for passthrough, after I edit the passthru.map:
/etc/vmware/passthru.map
# NVIDIA
10de ffff link false

then restart host

I have had to add a few devices to this list for my system

if you are then allowed to toggle passthrough on and added PCI device, then add VM configuration parameters:
hypervisor.cpuid.v0 = FALSE
pciPassthru0.msiEnabled = FALSE
pciPassthru.use64bitMMIO=TRUE

I keep forgetting to that a restart of the host isn't enough (error code 43), I have to completely power down for a few seconds (IPMI seems ok to remain on)
 

TLN

Active Member
Feb 26, 2016
403
55
28
30
I've followed this post: https://forums.servethehome.com/ind...assthrough-esxi-6-5.12631/page-11#post-237765
1. comment-out the default NVIDIA setting („#10de ffff bridge false“).
2. Added passthrough map for everything except GPU (Audio, serial, usb). Use lspci to get devid for devices.
10de xxxx d3d0 false
3. Added hypervisor.cpuid.v0 =FALSE“
4. Added four devices to VM (GPOU, Audio, USB, Serial)
5. Added pciPassthru0.msiEnabled = FALSE for al the devices except USB controller) Replace pciPassthru0 with pciPassthru3 or pciPassthru4 and etc.

My 2070RTX works fine using non-modified drivers, that I got from nvidia website. I can reboot VM, overclock GPU and do all the usual stuff. Got 70-90 FPS in all games I'm playing.
 
  • Like
Reactions: epicurean and zack$

zack$

Active Member
Aug 16, 2018
476
182
43
I've followed this post: https://forums.servethehome.com/ind...assthrough-esxi-6-5.12631/page-11#post-237765
1. comment-out the default NVIDIA setting („#10de ffff bridge false“).
2. Added passthrough map for everything except GPU (Audio, serial, usb). Use lspci to get devid for devices.
10de xxxx d3d0 false
3. Added hypervisor.cpuid.v0 =FALSE“
4. Added four devices to VM (GPOU, Audio, USB, Serial)
5. Added pciPassthru0.msiEnabled = FALSE for al the devices except USB controller) Replace pciPassthru0 with pciPassthru3 or pciPassthru4 and etc.

My 2070RTX works fine using non-modified drivers, that I got from nvidia website. I can reboot VM, overclock GPU and do all the usual stuff. Got 70-90 FPS in all games I'm playing.
What CPU are you using?