HGST 100GB SAS SSD HUSSL4010BSS600 at 40usd

whitey

Moderator
Jun 30, 2014
2,770
866
113
38
$50, 2+ yrs ago, so not too shabby

I still have 4 of these arnd accelerating a shucked 2.5" seagate pool and an ancient 3.5" spinner pool soon to be retired, other than that I have moved to AFA and husmm series for VM storage.
 
Last edited:

T_Minus

Build. Break. Fix. Repeat
Feb 15, 2015
7,008
1,569
113
CA
If someone wants to buy ~26 of these but 200GB either bare drive, or in a complete JBOD (SUperMicro Sc216) I have some I've been thinking of retiring for 400GB, and 800GB model upgrades shoot me a pM :) As of now I won't sell unless you want 12+ at once. Sorry, don't wnat to ship tons 1 by 1.
 

shoguneye

Member
Jan 21, 2016
33
1
8
57
I have some supermicro 5017r-mtfs that I'd like to upgrade from SATA to SAS. Can anyone recommend a decent SAS card for this system (1u) and what if I need anything else to move from SATA to SAS. Thanks in advance.

Cheers
 

mmk

Member
Oct 15, 2016
64
12
8
Czech Republic
They claim they're new but then again, the previous auction said '7.2K' so taking it with a grain of salt. The endurance is such they will almost certainly have plenty left anyway..

Edit: talking about the starmicro auction here
 

rune-san

Member
Feb 7, 2014
78
15
8
Just to note, I got one of these, and it was an HP Spare with almost no wear (1.3TB write, 4TB read). That stated, because it was an HP spare, it had 520 byte sectors, not 512. I followed the sg_utils post on How to reformat HDD & SSD to 512B Sector Size to get it back to 512. Then I noticed that it was a reported 4K Sector size, so I thought "why not" and used sg_utils to put it to 4096. Well it didn't like that. I couldn't write anything to it because it would announce an alignment issue in linux. So I put it back to 512. Now it works, and works *great*. About 520MB/s read / write with almost any size file. But, one thing I noticed is that the drive is now showing much fewer sectors, like I've essentially short-stroked it.

Total disk size is 1946 cylinders

Cylinder size is 12544 (512 byte) blocks


Cylinders

Partition Status Type Start End Length %

========= ====== ============ ===== === ====== ===

1 EFI 0 1946 1947 100

In my brilliance, I didn't check to see what the number of cylinders was before. As such my 100GB drive is now as 12GB drive. Formatting didn't change that. I figure there's an academic thing I need to do to fix it, but I'm not terribly sure what :) Perhaps that odd sectoring is why formatting it straight as 4K didn't work (then again, it might have to be 512 byte sectors. It is an old 3PAR SSD after all).

I figure I'd post this here for others getting ready to deal with the SSDs, and if they know a way to fix the above, that'd be great too. I'm using it as a ZIL, so I don't really care about the size, but I want to do a couple more of these, and it'd be nice to have them all the same size :D

EDIT:

In case anyone sees this later, I wanted to add my own resolution. After I got 3 more of the SSDs (which turned out to be untouched Hitachi SSDs, not 3PARs, and therefore were standard 512 byte drives), I took down the SAN to experiment a bit more. I looked at a copy of the man page for sg_format at sg_format(8): format/resize SCSI disk - Linux man page and found that a resize with a count of -1 will resize the drive to its maximum block count given the currently set block size. In this case, I ran the following (the drive was sde at the time):

Code:
sg_format --resize --count=-1 /dev/sde
The drive was then extended back to the maximum block count of 195371568 512 byte sectors. Running a standard format afterwards cleaned up the drive and it was ready to go again:

Code:
sg_format --format /dev/sde
At that point the drive completely matched the 3 other non-3PAR Hitachi SSDs I received.
 
Last edited: