Help crossflashing HP SmartArray P400 to LSI equivalent

Discussion in 'RAID Controllers and Host Bus Adapters' started by Rubén Martinez Cabello, Oct 4, 2016.

  1. Rubén Martinez Cabello

    Joined:
    Sep 30, 2016
    Messages:
    2
    Likes Received:
    0
    Hello,
    I've obtained recently two working HP SmartArray P400 from some decomissioned servers with the 512MB cache. I want to use one of them to build a file server where to store the video camera recordings of several cameras of my shop and then stream it to my phone.

    I've been using a PC built from spare parts and a Linux software RAID , but the disk usage it's pretty heavy and can't read the videos and stream them at the same time. The motherboard is a Gigabyte ga-p43-es3g (Intel chipset for Core 2 processor) from an unused desktop. It does only have a single PCIe*16 connector that I removed and plugged an old S3 PCI videocard on a PCI and the P400 in the PCIe.

    The problem it is that it does not pass the BIOS test on that motherboard. If you press <DEL> to go to the BIOS menu, after the five spinning bars happen, it does report the size of the cache and enter the BIOS, as it should. If you do not press <DEL>, after the five spinning bars, it does NOT report the cache size and the boot process halts.
    At first I though it was that the card was broken, due to damage to the leds (two of them damaged, one does not work), but testing the other card (in mint condition) produced the same results.

    I tested them on my desktop, which used a Gigabyte ga-970a-ds3p rev 2.0, setting it on the secondary PCIe, and it worked perfectly, Windows 10 Pro recognized it, and seems to work with a simple test RAID 1.

    I still want to make them work on the first computer, and I suspect that the problem it is not as much as some incompatibility with non-HP motherboards as that the HP BIOS of the Proliants they came from (G5) are UEFI, and the HP branded P400 cards may not work correctly with some non-UEFI BIOS.

    Since there are a few people that have managed to use them and equivalent LSI cards in non-HP, non-server motherboards, I think that the only solution I have is to cross-flash the cards to their LSI equivalent, and hope it does fix the issue.

    Other possible reasons would be the know incompatibility of the Gigabyte motherboards with the additional BIOS of some expansion cards. But those where fixed on their F9 BIOS versions for their Intel chipsets, and the BIOS of the ga-p43-es3g is already on it's latest version, FD.
    Other is those two PCIE contacts to block. Yes, I already trying taping them over but it made no difference, and the problems detecting the amount and timing of the RAM that are supposed to happen never cropped up, so I assume that there is no incompatibility with the chipset itself.

    So, my questions are:

    1. What is the LSI more similar equivalent of the P400 controller?
    2. Would I lose some features of the card doing the cross-flash?
    3. Can I cross-flash back?
    4. Would I keep the fixed writing throughput on RAID 5 that HP patched up?
    5. Is there a simple tutorial for cross-flashing a similar (LSI 1078) card?
    6. If that does not let it boot, is there something else I can try?

    Sorry for my poor explanations and generally poor english skills. Thanks for any help you can provide.
     
    #1
  2. klree

    klree Member

    Joined:
    Mar 28, 2013
    Messages:
    58
    Likes Received:
    0
    there is no LSI equivalent for P400. And just throw the P400 to the bin for good.
     
    #2
  3. Rubén Martinez Cabello

    Joined:
    Sep 30, 2016
    Messages:
    2
    Likes Received:
    0
    And if money would grow on trees, I would be doing that and buying a brand new card instead of trying to make use of a couple of working cards and sata hard drives out of the discard bin. Alas, it does not, so I am trying to make due with what I have, and one f the things I have is a card I can sacrify trying, so...
     
    #3
  4. mervincm

    mervincm Active Member

    Joined:
    Jun 18, 2014
    Messages:
    141
    Likes Received:
    32
    I threw mine out as they were a time sink, but I do recall that an older p400 bios (5.x?) worked in my on HP MB, and when I updated it to something current, it would fail in boot like you describe. you might have to find an HP systemboard to flash it, but see if you can find some old firmware for the p400, might work.
     
    #4
Similar Threads: Help crossflashing
Forum Title Date
RAID Controllers and Host Bus Adapters X8DT6-F and second HBA MegaRaid 9240-4i ( CrossFlashing Help needed) Jul 7, 2018
RAID Controllers and Host Bus Adapters Oracle F40 - bricked? help recover. Have backup files. Friday at 8:37 AM
RAID Controllers and Host Bus Adapters SSD Drives on LSI 9207-8i vs. on-board SATA2 help Feb 16, 2020
RAID Controllers and Host Bus Adapters Help with ASUS Z10PC-D8/SAS LSI3008 to IT Mode Feb 11, 2020
RAID Controllers and Host Bus Adapters Need help with my LSI SAS 9207-8i Feb 6, 2020

Share This Page