Fujitsu TX1320 M3 - Cheap low power server (barebone)

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Bjorn Smith

Well-Known Member
Sep 3, 2019
873
474
63
49
r00t.dk
I think its this guy here:
FTS_D3373TX1320M3TX1330M3iRMCKronos4Firmwa_D3373B10969Fsdr0318_1272409.EXE

If you run that, you can write that to an usb stick, boot in UEFI mode (thats the only mode that worked for me)

Then you get a menu with some options to flash.

And you can also use it to reset the IPMI password directly on the server via ipmitool, since its running on the server you have full privileges and can just reset admin password.

Resetting via BIOS never worked for me.
 
  • Like
Reactions: Rand__

dbram

New Member
Mar 3, 2021
10
6
3
You can download an ISO usb stick that allows you to emergency flash, which just overwrites everything :)
Thanks for the suggestion.

Tried exactly that using that bootable usb. Finally managed to boot from the usb after removing nvme ssd, sata ssd and pcie network card. Had some trouble getting it fully booted with these items in the system.

Then performed the emergency flash. Flashing worked fine. But that doesn't change the situation, still invalid. I've opened up support ticket at Fujitsu support. It seems like these systems are supported until end of 2024.

Keeping the iRMC bios as is for now.
 

hmartin

Active Member
Sep 20, 2017
308
238
43
37
Is anyone successfully using 32GB DIMMs? Mine is able to POST with one or two 32GB DIMMs installed, but an NMI is generated as soon as memtest tries to access beyond 16GB (even with only one 32GB DIMM installed).
 

Attachments

joeribl

Member
Jun 6, 2021
99
29
18
Is anyone successfully using 32GB DIMMs? Mine is able to POST with one or two 32GB DIMMs installed, but an NMI is generated as soon as memtest tries to access beyond 16GB (even with only one 32GB DIMM installed).
No experience here, but spec sheet and Kingston and Crucial memory configurator seem to suggest that 64GB with 4x16GB is the max supported. No mention of 32GB dimm support.
 

hmartin

Active Member
Sep 20, 2017
308
238
43
37
No experience here, but spec sheet and Kingston and Crucial memory configurator seem to suggest that 64GB with 4x16GB is the max supported. No mention of 32GB dimm support.
Yes, seemingly every spec sheet will tell you that 4*16GB is supported, but I wanted to know if 32GB DIMMs would be supported up to 64GB.

Someone on Reddit claimed a 32GB DIMM worked in their Skylake Thinkpad, so I thought maybe it could work.

But it would seem that 32GB DIMMs are not compatible with the TX1320 M3. I guess I will have to buy some 16GB DIMMs for this :confused:
 

joeribl

Member
Jun 6, 2021
99
29
18
Yes, seemingly every spec sheet will tell you that 4*16GB is supported, but I wanted to know if 32GB DIMMs would be supported up to 64GB.

Someone on Reddit claimed a 32GB DIMM worked in their Skylake Thinkpad, so I thought maybe it could work.

But it would seem that 32GB DIMMs are not compatible with the TX1320 M3. I guess I will have to buy some 16GB DIMMs for this :confused:
Yeah there could be some exceptions. My Lenovo M720q supposedly also supports 2x32GB DIMM unofficially while officially only 32GB.

Compuram.biz seems to indicate the same for the TX1320 M3:RAM Upgrades | Primergy TX1320 M3 (D3373) Tower Server - max up to 64GB
Could be dependent on the organisation of the DIMM. Compuram indicates for their compatible one: 4Gx72. What is yours?
 

hipiman069

New Member
Mar 6, 2023
1
0
1
I have used different 32GB ECC moduls and all of them do not work.
The capacity is detected but a blue screen appears.

Samsung M391A* Moduls.

Bios Version 1.33.
 

Bjorn Smith

Well-Known Member
Sep 3, 2019
873
474
63
49
r00t.dk
Something weird happened to one of my servers.
After having everything updated and testing everything working - and having had the machine not powered on for two months or so - then when I finally get around to powering it on because I want to take it in use - then suddenly it refuses to accept any of the memory modules that was working months prior.

Any good idea to fix this - or should I just accept I have a dud?

The memory I tested with works in another server, same version of everything - and it just reports "No memory detected"

Oh well - apparently powering off the server and leaving it off for a couple of hours, and then tinkering with a replacement - got the server to smarten up - and now it detects all the RAM :)
 
Last edited:
  • Like
Reactions: richard.dzavoronok

richard.dzavoronok

Active Member
Jun 23, 2021
154
72
28
Something weird happened to one of my servers.
After having everything updated and testing everything working - and having had the machine not powered on for two months or so - then when I finally get around to powering it on because I want to take it in use - then suddenly it refuses to accept any of the memory modules that was working months prior.

Any good idea to fix this - or should I just accept I have a dud?

The memory I tested with works in another server, same version of everything - and it just reports "No memory detected"

Oh well - apparently powering off the server and leaving it off for a couple of hours, and then tinkering with a replacement - got the server to smarten up - and now it detects all the RAM :)
This is the first method which I try when I'm troubleshooting - reseat everything. Don't know why, but (in my experience) intel sockets are prone to not align CPU pins right upon installation. From four of my hp servers, on three of them I had to reseat CPUs to detect all ram sticks.
 

buyenne

New Member
Sep 22, 2019
3
0
1
Flashed to latest BIOS (V5.0.0.11 R1.33.0) with an i3-7100. Still having a problem to flash iRMC to latest version. 3.17 is fine, 3.18 shows status invalid. Going to test the USB Drive way like described here

Swapped CPU with a Xeon E3-1245 v5. After some 10? minutes of silence, then some boot loops showing an alternating iRMC / dark screen, it finally booted correctly, message showing error CPU changed. After pressing Enter it booted into windows 10.

Still have E3-1225 v5 and a E3-1260L v5 laying around. Will test them another day. Not going to test the E3-1220 v6 since its officially supported.

Adapter used and working (boots from NVMe): https://www.amazon.de/dp/B07FN3YZ8P

Other problems encountered: no connection to the SAS Drives. Also tested with a HBA in IT Mode using a SFF-8087 - SFF-8643 cable. Probably backplane defective.

firefox_wbOimTZKwC.png

mstsc_x0J3Q24Xih.png
mstsc_BsLOoVSYZa.png
 

phariseo

New Member
Dec 5, 2022
3
3
3
For guys having problems with iRMC updates - I had the same, highest I could get was 09.20.
What helped me, was enabling NTP time sync, instead of default RTC. I do not know what does it affect, after this operation I upgraded to 09.21, then to 09.60, and finally to 09.69.
 

hmartin

Active Member
Sep 20, 2017
308
238
43
37
~55€ for 10
Could someone please confirm the exact part number of the 2.5" caddies you're using in the TX1320 M3? I don't want to buy QTY 10 just to realize I've bought the wrong ones.

I am not done fleshing them out, as i mentioned i only got them the other day. But I hope to run them with 64G/node

Fujitsu 2.5" HDD Einbaurahmen Caddy A3C40101974 Primergy Server | eBay 10 bucks each, known seller who takes offers.
The above link is for A3C40101974 but other eBay listings suggest A3C40179841 is the corresponding HDD caddy for the TX1320 M3. Are they both compatible?
 

richard.dzavoronok

Active Member
Jun 23, 2021
154
72
28
Could someone please confirm the exact part number of the 2.5" caddies you're using in the TX1320 M3? I don't want to buy QTY 10 just to realize I've bought the wrong ones.

The above link is for A3C40101974 but other eBay listings suggest A3C40179841 is the corresponding HDD caddy for the TX1320 M3. Are they both compatible?
A3C40179841 is the correct one.