Frustrating Java + Supermicro IPMI

Patrick

Administrator
Staff member
Dec 21, 2010
11,965
4,924
113
What motherboard? I would first try the latest IPMI firmware. Also - are you trying to connect via https?
 

neo

Well-Known Member
Mar 18, 2015
672
362
63
Java is not the samething as Javascript. You need to open your Java options panel and lower the security settings to accept self signed certificates.
 
Last edited:
  • Like
Reactions: William

Chuckleb

Moderator
Mar 5, 2013
1,017
331
83
Minnesota
I don't think that the current java allows you to accept self certs anymore, you have to allow by URI now for everything. *sigh*
 

smithse79

Active Member
Sep 17, 2014
196
33
28
40
put the IP addresses in your hosts file as whatever you want to call them, then use the hostname you just created and add it to the exceptions in your Java control panel and reference the IPMI at that hostname. We had to do that with our Cisco ASDM at work.
 

j_h_o

Active Member
Apr 21, 2015
475
112
43
California, US
Update to latest IPMI firmware via HTTPS, then use IPMIView if possible when remoting:

ftp://ftp.supermicro.com/utility/IPMIView/
 

MikeC

Member
Apr 27, 2013
59
11
8
UK
You need to add:
Code:
https://123.123.96.63:443
to the exceptions site list on the Java Security tab and make sure that Enable Java content in the browser is checked along high security level. IPMIView should then work or you can use the web interface onto the IPMI on the box with:
Code:
http://123.123.96.63/
 
Last edited by a moderator:

Patrick

Administrator
Staff member
Dec 21, 2010
11,965
4,924
113
Hey @MikeC I edited your post to add code tags. The URL in the middle and the URL at the end were making XenForo unhappy.
 

Bashed

Member
Apr 29, 2015
36
0
6
70
You need to add:
Code:
https://123.123.96.63:443
to the exceptions site list on the Java Security tab and make sure that Enable Java content in the browser is checked along high security level. IPMIView should then work or you can use the web interface onto the IPMI on the box with:
Code:
http://123.123.96.63/
Thanks that did the trick.

Update to latest IPMI firmware via HTTPS, then use IPMIView if possible when remoting:

ftp://ftp.supermicro.com/utility/IPMIView/
I'm still getting the Java runtime update popup though.

Where do I update the IPMI itself? I'm in the Supermicro gui now. Is this the "firmware update" section under maintenance menu?
 

Bashed

Member
Apr 29, 2015
36
0
6
70
Ahhhhh....so annoying with these Java popups!

Still getting the popups

"You need the latest Java(TM) Runtime Environment. Would you like to update now?"

I'm at a loss. I'm running the latest Java, have "enable java content in the browser" enabled, and whitelisted the IP address for the web interface. Restarted browser, same crap. Stupid SM!
 

Jon Massey

Active Member
Nov 11, 2015
340
82
28
34
My understanding is that the client-side Java version detection code from the BMC doesn't handle the scenario whereby your installed JVM version is higher than the one it expects. Quite annoying but if you use IPMIView you don't get those nagging popups!
 

Scott Laird

Active Member
Aug 30, 2014
256
101
43
I haven't tried Supermicro's IPMI lately, but a lot of Java web apps (like the Lantronix Spider app) will work if you *download* the jnlp version of the app and run it via javaws (which should come with the JDK).

Running Java in the browser is basically dead.
 

Jon Massey

Active Member
Nov 11, 2015
340
82
28
34
The connection defined in the JNLA authenticates by a web session ID so this won't work in this scenario alas
 

Scott Laird

Active Member
Aug 30, 2014
256
101
43
Ugh. I don't think any of my Supermicro systems' IPMI will work with any browser on any computer I have. Considering the amount of crapware that Oracle tries to bundle with newer Java installs (trying to change my default search engine? WTF?) and their horrid security record, I'm not very eager to upgrade Java to try.
 

BeefyDog

New Member
Jun 5, 2017
2
0
1
54
Have the same problem. No answers anywhere. I would love to hear anyone who has gotten IPMIView (now version 2.12) that actually will load the KVM Console (in Windows 8.x or Windows 10). The KVM Console simply does not work, nor does the browser version of the console as it is looking for an ancient version of Java Runtime (God-only-knows what that version is!) and won't run in Chrome, Firefox, Internet Explorer, Opera, or Edge. Sorry about your luck! But there is no working solution to the problem except to buy another brand. Their hardware is wonderful, but the software was written by amateurs (and it shows!).