First test for the Sumo fork.

onsit

Member
Jan 5, 2018
98
26
18
29
My open compute servers:

2660v1 x2 443 H/s
2665v1 x2 449 H/s

Now for some reason the RX Vega is hashing at half of what it was.
You know what. I do appear to actually having less wattage spent on all my machines after using a clamp meter. I'd say it's about a 20% reduction in watts across all servers total.

Went from 20KH/s cummulative, to about 11KH/s.

And given that the current profitability of Sumo is 4x other coins, with less power. This could be better to mine, even when Monero does their switch.
 

Joel

Active Member
Jan 30, 2015
811
162
43
39
So what's daily profitability looking like?

I switched my gear off about a week ago, was on Nicehash before but this might actually get me to mine direct again!
 

onsit

Member
Jan 5, 2018
98
26
18
29
So what's daily profitability looking like?

I switched my gear off about a week ago, was on Nicehash before but this might actually get me to mine direct again!
My current setup was 21KH/s mining on average $17 a day during this blood bath of a dip in crypto. With Sumo it's now 11KH/s, 20% power consumption, and about $30 a day at the current low difficulty as the network stabilizes.

Now is a very good time to turn everything on and mine Sumo. This also makes me feel like XMR will be amazing to mine too once the network diff drops from ASICs, bots, and people not updating their miners, and pools not updating their daemon in time.
 

Nero24

Member
Jul 26, 2017
32
5
8
44
www.planet3dnw.de
The scratchpad size of the new Sumokoin Algo is 4 MB instead of 2 MB. So CPUs with big caches have an advantage, because they can use more threads still. AMD Ryzen 7 for example used 8 threads with the old algo to fill its 16 MB L3 cache. Now with the new algo it's down to 4 threads. So 50 percent of its cores or 75 percent of its logical SMT cores are unused now :eek: Powerconsumption before 90 W (whole system), now 76 W. Hashrate before 530 H/s, now 240 H/s (-55%). Similar Intel Xeon E3-1231-v3, which mined at 274 H/s before and now is down to 105 H/s (-61%) with cryptonight-heavy.

The AMD FX-8300 instead was at 335 H/s before (with 8 threads, using L2+L3 cache completely) or 295 H/s (with 4 threads fitting in L2) and is now at 187 H/s, which is "just" -36% or -45% dependend on the setting before. Or AMD Epyc 7351P with 64 MB L3; before 1681 H/s now 962 H/s (-43%)

Somebody in a pool chat told me, that now it's better to use just one thread with Radeon RX 580, not 2 anymore. ("RX 580 (8GB), 1 thread, intensity 864, worksize 8 - around 660 H/s"). Perhaps worth a try? :)

So the RX 580 GPUs seem to be the big winner at Sumokoin...
 
Last edited:

marcoi

Well-Known Member
Apr 6, 2013
1,403
224
63
Gotha Florida
So i setup a wallet and used the used he fairpool mentioned above. With my dual e5-2680v2, im only getting 600 h/s. Power according to monitor is 160 Watts. But this is a 4 node unit, so there might be more power due to dual psu and other nodes off but still drawing a little power.


upload_2018-4-5_14-12-50.png

Cpu setup
Code:
"cpu_threads_conf" :
[
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 0 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 1 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 2 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 3 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 4 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 5 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 6 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 7 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 8 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 9 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 10 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 11 },

],

Update:
Started my dockers for mining at nicehash to compare power. 2 dockers running the power is at 168. Hashing at 600 h/s each on nicehash.

Code:
 * VERSIONS:     XMRig/2.5.1 libuv/1.18.0 gcc/7.2.0
 * HUGE PAGES:   available, enabled
 * CPU:          Intel(R) Xeon(R) CPU E5-2680 v2 @ 2.80GHz (1) x64 AES-NI
 * CPU L2/L3:    2.5 MB/25.0 MB
 * THREADS:      12, cryptonight, av=1, donate=1%
 * POOL #1:      cryptonight.usa.nicehash.com:3355
Update2: with HT disabled im seeing 155W. So not much difference.
 
Last edited:

Nero24

Member
Jul 26, 2017
32
5
8
44
www.planet3dnw.de
With my dual e5-2680v2, im only getting 600 h/s.
You are using too much threads! The E5-2680 v2 has 25 MB L3 cache. Sumo uses 4 MB per thread. So you should use 6 threads per CPU, the even cores or the odd.

For one CPU:

"cpu_threads_conf" :
[
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 0 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 2 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 4 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 6 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 8 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 10 },
],

For the second one you must look how the cores a numbered, may be

{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 29 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 31 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 33 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 35 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 37},
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 39 },


Addition! The core numbers are the Windows scheme. May be running Linux physical cores and logical cores are numbered differently. You have to look :)
 
Last edited:

marcoi

Well-Known Member
Apr 6, 2013
1,403
224
63
Gotha Florida
You are using too much threads! The E5-2680 v2 has 25 MB L3 cache. Sumo uses 4 MB per thread. So you should use 6 threads per CPU, the even cores or the odd.

For one CPU:

"cpu_threads_conf" :
[
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 0 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 2 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 4 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 6 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 8 },
{ "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 10 },
],

For the second one you must look how the cores a numbered
Code:
Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              24
On-line CPU(s) list: 0-23
Thread(s) per core:  2
Core(s) per socket:  6
Socket(s):           2
NUMA node(s):        2
Vendor ID:           GenuineIntel
CPU family:          6
Model:               62
Model name:          Intel(R) Xeon(R) CPU E5-2680 v2 @ 2.80GHz
Stepping:            4
CPU MHz:             2799.893
CPU max MHz:         3600.0000
CPU min MHz:         1200.0000
BogoMIPS:            5599.78
Virtualization:      VT-x
L1d cache:           32K
L1i cache:           32K
L2 cache:            256K
L3 cache:            25600K
NUMA node0 CPU(s):   0-5,12-17
NUMA node1 CPU(s):   6-11,18-23
I think the cpu.txt auto configured correctly. It using 6 cores per CPU (6x4MB = 24 MB).
I should turn off the HT to save on power though.
 

Joel

Active Member
Jan 30, 2015
811
162
43
39
  • Like
Reactions: marcoi

marcoi

Well-Known Member
Apr 6, 2013
1,403
224
63
Gotha Florida
looks like my 1080 card does 594
upload_2018-4-5_15-22-29.png
Code:
"gpu_threads_conf" :
[
  // gpu: GeForce GTX 1080 architecture: 61
  //      memory: 6757/8192 MiB
  //      smx: 20
  { "index" : 0,
    "threads" : 10, "blocks" : 60,
    "bfactor" : 6, "bsleep" :  25,
    "affine_to_cpu" : false, "sync_mode" : 3,
  },
 
Last edited:

marcoi

Well-Known Member
Apr 6, 2013
1,403
224
63
Gotha Florida
amd vega 64 and e3-1265L v3 cpu

upload_2018-4-5_15-33-20.png

Code:
"gpu_threads_conf" : [
  // gpu: gfx901 memory:3920
  // compute units: 64
  { "index" : 0,
    "intensity" : 512, "worksize" : 8,
    "affine_to_cpu" : false, "strided_index" : 1, "mem_chunk" : 2,
    "comp_mode" : true
  },

],
Update - i used the following settings
Code:
"gpu_threads_conf" : [
  // gpu: gfx901 memory:3920
  // compute units: 64
  { "index" : 0,
    "intensity" : 864, "worksize" : 8,
    "affine_to_cpu" : false, "strided_index" : 1, "mem_chunk" : 2,
    "comp_mode" : true
  },
Now doing better:
upload_2018-4-5_16-32-6.png
 
Last edited:

Joel

Active Member
Jan 30, 2015
811
162
43
39
Wow, I'd have expected better from a Vega! Wonder if a FE card would be better?
 

marcoi

Well-Known Member
Apr 6, 2013
1,403
224
63
Gotha Florida
Wow, I'd have expected better from a Vega! Wonder if a FE card would be better?
I didnt tune anything, im just running config xmr-stak came up with. (I do have some changes to windows to lower amd power and running the amd mining drivers so not sure if that makes a difference.)
 

marcoi

Well-Known Member
Apr 6, 2013
1,403
224
63
Gotha Florida
and final box. running two 1050 TI cards and two e5-2651 v2 cpu
upload_2018-4-5_15-46-52.png

Code:
"cpu_threads_conf" :
[
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 0 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 1 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 2 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 3 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 4 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 5 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 6 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 7 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 12 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 13 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 14 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 15 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 16 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 17 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 18 },
    { "low_power_mode" : false, "no_prefetch" : true, "affine_to_cpu" : 19 },

],

"gpu_threads_conf" :
[
  // gpu: GeForce GTX 1050 Ti architecture: 61
  //      memory: 3372/4096 MiB
  //      smx: 6
  { "index" : 0,
    "threads" : 4, "blocks" : 18,
    "bfactor" : 8, "bsleep" :  25,
    "affine_to_cpu" : false, "sync_mode" : 3,
  },
  // gpu: GeForce GTX 1050 Ti architecture: 61
  //      memory: 3372/4096 MiB
  //      smx: 6
  { "index" : 1,
    "threads" : 4, "blocks" : 18,
    "bfactor" : 8, "bsleep" :  25,
    "affine_to_cpu" : false, "sync_mode" : 3,
  },
],
Update: I changed the threads to 12 and blocks to 60. now each 1050 card does 300 H/s
 
Last edited:

Joel

Active Member
Jan 30, 2015
811
162
43
39
I didnt tune anything, im just running config xmr-stak came up with. (I do have some changes to windows to lower amd power and running the amd mining drivers so not sure if that makes a difference.)
That explains it. I know @Klee said that with his 580s two threads wasn't effective any more, but you could probably bump the intensity up to 1500 or so.
 

marcoi

Well-Known Member
Apr 6, 2013
1,403
224
63
Gotha Florida
That explains it. I know @Klee said that with his 580s two threads wasn't effective any more, but you could probably bump the intensity up to 1500 or so.
1512 intensity causes the amd card to not be found. not sure why.

change the settings to 864 and now doing 720H/s

update 2 - change the intensity to 999 and updated amd drivers. now doing 778 H/S
My amps did go up by 1 though, so total miners running at 12 amps.

upload_2018-4-5_16-48-39.png
 
Last edited: