Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Discussion in 'Networking' started by fohdeesha, Jul 12, 2018.

  1. kyled

    kyled New Member

    Joined:
    Jan 25, 2019
    Messages:
    5
    Likes Received:
    0
    I have an ICX7250-24P and ran through the updates and I think something is wrong with PoE on it. whenever I try to install the PoE firmware I get this message:

    Code:
    PoE Info: FW Download on slot 1...programming firmware...completed.
    PoE Info: FW Download on slot 1...upgrading firmware...completed. Module will be reset.
    PoE Info: Resetting in slot 1....
    PoE Info: Resetting module in slot 1....completed.
    PoE Error: Failed Devices Bitmap on PoE module:4, numDev:3.
    PoE Severe Error: Hardware Fault with ports 1/1/17 to 1/1/24. Remove PDs and then configure "no inline power" on these ports.
    PoE Info: PoE module 1 of Unit 1 initialization is done.
    
    and on reboot I get these messages:

    Code:
    PoE: Stack unit 1 PS 1, Internal Power supply  with 370000 mwatts capacity is up
    PoE Info: Adding new 54V capacity of 370000 mW, total capacity is 370000, total free capacity is 370000
    PoE Info: PoE module 1 of Unit 1 on ports 1/1/1 to 1/1/24 detected. Initializing....
    2000 log entries of PoE Event Trace Log Buffer is allocated on unit 1 for unit 1
    PoE Event Trace Logging enabled for unit 1
    PoE Error: Failed Devices Bitmap on PoE module:4, numDev:3.
    Resetting module in slot 1 again to recover from dev fault
    PoE Info: Hard Resetting in slot 1....
    sh: can't create /proc/iproc-i2c/iproc-i2c0/iproc-i2c-reset: nonexistent directory
                                                                                      PoE Info: Resetting module in slot 1....completed.
    
    pdsineReadResetResponse: Received an all-0 message
    PoE Info: Expected post-reset system status response not received from the controller in slot 1...so reset of i2c will be initiated first to recover.
    PoE Info: I2c Reset in slot 1....completed.
    PoE Info: Hard Resetting in slot 1....
    PoE Info: Resetting module in slot 1....completed.
    
    pdsineReadResetResponse: Received an all-0 message
    PoE Severe Error: Controller Reset failed on unit 1 in slot 1
    
    has anyone seen this before or do I just have a bad switch? show inline power says "internal h/w fault" after installing the firmware, but that message goes away after a reboot. PoE still isn't working though on a factory reset default configuration

    Just tried every port and PoE does work on 17-23 (but shows as "Non-PD") so I guess it's probably a bad switch
     
    #1261
    Last edited: Jan 25, 2019
  2. mrgstiffler

    mrgstiffler New Member

    Joined:
    Jan 20, 2019
    Messages:
    6
    Likes Received:
    4
    Thanks @fohdeesha! Your guide made the initial setup flawless!

    [​IMG]
     
    #1262
  3. fohdeesha

    fohdeesha Kaini Industries

    Joined:
    Nov 20, 2016
    Messages:
    1,391
    Likes Received:
    1,120

    the PoE board is damaged, seen this twice before. I ended up just removing the POE daughter board and using them as regular switches
     
    #1263
  4. kyled

    kyled New Member

    Joined:
    Jan 25, 2019
    Messages:
    5
    Likes Received:
    0
    Thanks for confirming, I guess I'll see if the seller can replace it

    Edit: Opened it up and I think I found the problem...
    [​IMG]
     
    #1264
    Last edited: Jan 26, 2019
  5. fohdeesha

    fohdeesha Kaini Industries

    Joined:
    Nov 20, 2016
    Messages:
    1,391
    Likes Received:
    1,120
    oof, looks like an outdoor PoE device on one of the ports took an indirect static hit or something
     
    #1265
  6. Stephan

    Stephan IT Professional

    Joined:
    Apr 21, 2017
    Messages:
    102
    Likes Received:
    34
    Whats the black goo? If that is the glue to hold the chip in position before being soldered down then that chip got cooked really bad. ESD from lightning strike I'd say.
     
    #1266
  7. 747builder

    747builder Member

    Joined:
    Dec 17, 2017
    Messages:
    93
    Likes Received:
    38
    PoE chip and trace took a hit one way or another. id see if you can exchange it or if you can live without PoE get a discount for it.
     
    #1267
  8. Corey Clingo

    Corey Clingo New Member

    Joined:
    May 13, 2016
    Messages:
    5
    Likes Received:
    4
    Finally got my 6610 :)

    (UPS had it sitting at a store, which I didn't know). I powered it up, and while it's probably too much noise to have sitting on my desk, it does spin down as noted in this thread and should be fine in a closet rack. (Compared to the Aruba S3500 I have, which doesn't ever spin down its PS fans, it's a ghost.)

    I bought it without rack ears, thinking I would put it on a shelf, but it's too deep, so now I'm going to have to find or make some ears so I can put it in a rack. It draws around 115W with 2 power supplies and nothing plugged in, and that only drops about 10W when I unplug one supply (as expected).

    I've hit fohdeesha up for the licenses, and hope to get some time to play with it soon.

    I'd still like to get a 6450-24P (for its shallower depth), but those have gotten pricier on eBay as of late. Haven't seen one for less than $350 shipped, which is more than I paid for the 6610-48P.

    C
     
    #1268
    fohdeesha likes this.
  9. mrgstiffler

    mrgstiffler New Member

    Joined:
    Jan 20, 2019
    Messages:
    6
    Likes Received:
    4
    Has anyone tried a multi-gigabit SFP+ module like an AQS-107 or AQS-109?
     
    #1269
  10. Roelf Zomerman

    Joined:
    Jan 10, 2019
    Messages:
    34
    Likes Received:
    4
    So.. I got my Sunon KDE1204PKv3 fans.. but upon connecting I noticed the different coloring (see picture).. do I need to re-adjust the wiring on these?
    (Top is new, below is original)

    <EDIT> Never mind.. found the answer on page 29.. switching yellow and black. </EDIT>

    man this thing is silent now :)
     
    #1270
    Last edited: Jan 28, 2019
    svtkobra7 likes this.
  11. svtkobra7

    svtkobra7 Active Member

    Joined:
    Jan 2, 2017
    Messages:
    316
    Likes Received:
    64
    [​IMG]

    @Roelf Zomerman Well now you know that your build date was Christmas Day and the elves were having some fun assembling your switch! ;)

    jk of course
     
    #1271
  12. fohdeesha

    fohdeesha Kaini Industries

    Joined:
    Nov 20, 2016
    Messages:
    1,391
    Likes Received:
    1,120

    the only rates supported on the SFP+ ports are 1gbe and 10gbe, nothing in between
     
    #1272
  13. fleeball

    fleeball New Member

    Joined:
    Dec 19, 2018
    Messages:
    4
    Likes Received:
    2
    Thanks to this forum and fohdeesha, I have installed my converted 649281-B21(now a MCX354A-FCBT) Network card in my QNAP NAS and connected it at 40GbE via the Brocade ICX6610-48P. I am using the NetApp 112-00178 X6559-R6 External SAS Cable to connect the two devices.

    upload_2019-1-29_16-23-33.png

    upload_2019-1-29_16-24-17.png

    Still running tests on performance, but so far everything is working perfectly. Contemplating enabling Jumbo frames, but reading some of the replies on this thread, not sure it is worth the hassle.
     
    #1273
    tommybackeast and fohdeesha like this.
  14. seang86s

    seang86s Member

    Joined:
    Feb 19, 2013
    Messages:
    133
    Likes Received:
    12
    What model QNAP are you running?
     
    #1274
  15. fleeball

    fleeball New Member

    Joined:
    Dec 19, 2018
    Messages:
    4
    Likes Received:
    2
    QNAP TVS-873e
     
    #1275
  16. Roelf Zomerman

    Joined:
    Jan 10, 2019
    Messages:
    34
    Likes Received:
    4
    Hi everyone,

    So the cooling seems to be ok.. (49-55C).. but the status indicates that the FAN's have failed.. I'm guessing that's normal with non-stock fans?
     
    #1276
  17. fohdeesha

    fohdeesha Kaini Industries

    Joined:
    Nov 20, 2016
    Messages:
    1,391
    Likes Received:
    1,120
    yeah that's normal, the RPM reading of the aftermarket fans isn't in the "normal" range it's looking for so it indicates they've failed. Luckily on the 6450 you can just ignore it. On the 6610 (and others) it won't even allow you to boot it like this

    You might still be able to view the raw RPM value of the aftermarket fans using a debug command, "dm fan-speed" at the enable level or higher. can't remember if it works on the 6450
     
    #1277
  18. Joao Paulo Mello

    Joao Paulo Mello New Member

    Joined:
    Jan 16, 2019
    Messages:
    14
    Likes Received:
    1
    #1278
    Last edited: Jan 30, 2019
  19. Roelf Zomerman

    Joined:
    Jan 10, 2019
    Messages:
    34
    Likes Received:
    4
    is there a way to upgrade the keyexchange method on the 6450 ? I tried using the method on this URL .. but doesnt work :(
     
    #1279
  20. EffrafaxOfWug

    EffrafaxOfWug Radioactive Member

    Joined:
    Feb 12, 2015
    Messages:
    1,079
    Likes Received:
    356
    Not a brocade user myself, but from discussions in this thread it seems others have also looked into it and it's not possible:
    https://forums.servethehome.com/index.php?threads/brocade-icx6450-icx6610-etc.21107/page-54

    If it's clashing with your ssh configuration, and assuming standard openssh, your best bet is to make an individual KEX exception in your .ssh/config e.g.
    Code:
    Host myswitch.mydomain.lan
    	KexAlgorithms +diffie-hellman-group1-sha1
    If you're unsure of what KEX the systems support (or ciphers for that matter), trusty nmap to the rescue:
    Code:
    effrafax@wug:~$ nmap --script ssh2-enum-algos -sV -p 22 myswitch.mydomain.lan
    
    Starting Nmap 7.40 ( https://nmap.org ) at 2019-01-31 15:51 GMT
    Nmap scan report for 10.122.10.2
    Host is up (0.0029s latency).
    PORT   STATE SERVICE VERSION
    22/tcp open  ssh     OpenSSH 4.3 (protocol 2.0)
    | ssh2-enum-algos:
    |   kex_algorithms: (3)
    |       diffie-hellman-group-exchange-sha1
    |       diffie-hellman-group14-sha1
    |       diffie-hellman-group1-sha1
    |   server_host_key_algorithms: (2)
    |       ssh-rsa
    |       ssh-dss
    |   encryption_algorithms: (13)
    |       aes128-cbc
    |       3des-cbc
    |       blowfish-cbc
    |       cast128-cbc
    |       arcfour128
    |       arcfour256
    |       arcfour
    |       aes192-cbc
    |       aes256-cbc
    |       rijndael-cbc@lysator.liu.se
    |       aes128-ctr
    |       aes192-ctr
    |       aes256-ctr
    |   mac_algorithms: (6)
    |       hmac-md5
    |       hmac-sha1
    |       hmac-ripemd160
    |       hmac-ripemd160@openssh.com
    |       hmac-sha1-96
    |       hmac-md5-96
    |   compression_algorithms: (2)
    |       none
    |_      zlib@openssh.com
     
    #1280
Similar Threads: Brocade Series
Forum Title Date
Networking [SOLVED] Help Needed - Brocade ICX 6450 + Ruckus R720 Nov 25, 2019
Networking Brocade ICX 6610 - what does dhcp-client enable do? Nov 19, 2019
Networking MikroTik CSS326-24G-2S+RM vs Brocade ICX6450-24 Nov 1, 2019
Networking Brocade ICX6450-24P vs Aruba S2500-24P for Homelab Sep 22, 2019
Networking Brocade VDX 6720 - what do I need to know? Sep 16, 2019

Share This Page