Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Wolfcastle

Member
Jan 3, 2022
50
23
8
I'm going to test temps again today with the stock fan to see if that makes a big difference. As far as a fan on the ASIC itself, I had seen someone suggest this: https://www.mouser.com/ProductDetail/Sunon/MF60101V3-1000U-A99?qs=EU6FO9ffTwekSIQ43CVQVg==

I'm guessing you'd point it up, but given the space constraints, I'm wondering how much of a difference this would make. I assume I could run it off a y-splitter on the one fan header?

You mentioned vertical space--I guess that would mean running it without the cover? I'd definitely prefer to keep it in the enclosure if possible, but obviously that introduces cooling challenges. Or were you thinking just on the exterior? The bottom gets way hotter than the top, so maybe propping it up off the metal shelf it's sitting on or putting some airflow underneath it might help (update: propping it up didn't make any difference).

I know these things run hot, but it seems like idling at 85-90 is too hot and could cause issues.

Edit: I think the best option is to add a fan to the ASIC along with the quieter exhaust fan. I've seen folks recommend the Sunon MF60101V1-1000U-G99, but I can't find it in stock anywhere... Any other good 60x10mm fans you guys would recommend? I assume I need the 3-wire here and a y-splitter to run both this and the exhaust off the one fan header?
See the ICX 6610 fan mod thread, basically you scribe and cut an acrylic sheet to size and mount a fan above the asic and/or CPU. I made the fan push air down onto the asic on my 6610 but I don’t think it hugely matters whether you’re pushing or pulling air if you’re not in a datacenter. The only catch to this is that the switch is now 2RU instead of 1RU which is probably not an issue for most homelabs.
 
  • Like
Reactions: WampaCow

tubs-ffm

Active Member
Sep 1, 2013
171
57
28
And now for a second question as I get further along in the process here with my ICX 7250-24. Is the temp reported in show chassis accurate? This seems way hotter than it should be with nothing connected and no PoE:
You could go with a Sunon MF60101V3-1000U-A99 on top of the cooling rips of the CPU.

The stock fan had a fairly annoying coil whine to it and this thing sits fairly close to my desk. I assumed it wouldn't be that big of a hit to thermals on a 24 port switch without PoE. Thoughts?
I gave up on tuning my ICX 7250-24P after the power supply died. I believe it was due to heat. Some guys here have similar tuned systems running over years without issue.

I switched to an ICX 7150-24P. I only get 4 SPF+ ports but I can run this device in fan less mode at zero noise as long the PoE power is below a certain limit (sorry forgot the number).
 
  • Like
Reactions: WampaCow

WampaCow

New Member
Feb 4, 2022
7
4
3
You could go with a Sunon MF60101V3-1000U-A99 on top of the cooling rips of the CPU.



I gave up on tuning my ICX 7250-24P after the power supply died. I believe it was due to heat. Some guys here have similar tuned systems running over years without issue.

I switched to an ICX 7150-24P. I only get 4 SPF+ ports but I can run this device in fan less mode at zero noise as long the PoE power is below a certain limit (sorry forgot the number).
Thanks tubs-ffm. I actually just placed an order for that exact fan yesterday. Thoughts on pointing it down vs up? I was leaning towards up, but can test it pretty easily.

Right now, I actually have a 40mm fan sitting on the ASIC heatsink with the case open and it stays below 65. Hopefully the 60mm will help with the case closed, otherwise I might consider moving it to a closet with the stock exhaust--annoying as I'd have to buy a few other cables for it, but it's a possibility. I also toyed with the idea of an intake fan on the side vent. With these lower powered fans, seems like it'd be okay to run 3 off the one header. I guess I could also just leave the case open, although not excited about that plan.
 

WampaCow

New Member
Feb 4, 2022
7
4
3
See the ICX 6610 fan mod thread, basically you scribe and cut an acrylic sheet to size and mount a fan above the asic and/or CPU. I made the fan push air down onto the asic on my 6610 but I don’t think it hugely matters whether you’re pushing or pulling air if you’re not in a datacenter. The only catch to this is that the switch is now 2RU instead of 1RU which is probably not an issue for most homelabs.
Woa, just checked this out. This is pretty wild. So basically replace the case cover with a piece of acrylic and you cut a hole in the acrylic to plop a larger fan on top. Pretty cool idea--I might consider it if I can't get things where I want within the existing case.
 

sth

Active Member
Oct 29, 2015
379
91
28
Has anyone with a 7150-c12p had issues with it occasionally stopping switching? I've had a new one for about 4 months now and approximately every two months it turns into a brick until its rebooted.
 

tubs-ffm

Active Member
Sep 1, 2013
171
57
28
Hopefully the 60mm will help with the case closed,
Yes. My ASIC temperature with two modified exhaust fans and the Sunon MF60101V3-1000U-A99 on top of the ASIC was between 66 and 76 °C, depending on the ambient temperature.

I also toyed with the idea of an intake fan on the side vent. With these lower powered fans, seems like it'd be okay to run 3 off the one header.
Before you do a radical tuning and cut the case, I would start to cut out the "holes" in front of the exhaust fans. There is more metal sheet instead of hole. For safety and good locking fix a metal net from inside.
 
  • Like
Reactions: WampaCow

Roelf Zomerman

Active Member
Jan 10, 2019
145
27
28
blog.azureinfra.com
I was wondering if there is a technique in the ICX platform that allows me to intercept all DNS traffic from clients and redirect it on the switch itself..

I'm trying out Anycast on Windows Domain Controllers (blog.azureinfra.com) - and was wondering if there was a way to essentially force the clients (by the switch) to use a specific IP address for DNS resolving.. (and yes.. I also need to post on how to perform the BGP routes on the 6450 directly rather than the Juniper)....

so in short.. even if a client has 172.16.5.1 configured as their DNS server - I want the Brocade to intercept all this traffic and point it straight to 51.51.51.51 - my configured anycast IP
 

mfolnovic

New Member
Jun 7, 2021
6
2
3
My network consists of devices connected to 6450, which is connected to pfsense, which is then connected to modem (192.168.1.1).
I've setup inter-vlan routing on switch by following https://forums.servethehome.com/index.php?threads/layer-3-switch-w-pfsense.23236/.

For some reason, my ISP forces me to connected IPTV receivers directly to modem. But, I only have one ethernet port in living room. So my end goal is to have IPTV receiver and TV connected to a USW Flex Mini in living room, that's connected to 6450, if that's possible.

My idea was to have new VLAN 100, and all traffic on that VLAN would be routed directly to modem (not through pfsense). I didn't setup VLAN 100 on pfsense - should I?

At the moment, I have:
- pfsense connected to port 1
- modem connected to port 47
- Flex Mini in living room connected to port 24:
- port 1 is on VLAN70 - TV connected to it
- port 2 is on VLAN100 - laptop connected to it

I also tried to simplify things by connecting living room to port 43, which has untagged VLAN100.

In both scenarios, I can't get IP address from DHCP server. I've tried to play with static routes but couldn't make it work.
While diagnosing this, I've realised that as soon as I add ve 100, I can't ping modem (192.168.1.1).

Any ideas? Thanks in advance! :)

Here's my configuration:
Code:
ver 08.0.30tT313
!
stack unit 1
  module 1 icx6450-48p-poe-port-management-module
  module 2 icx6450-sfp-plus-4port-40g-module
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
!
vlan 30 name Trusted by port
tagged ethe 1/1/1 to 1/1/2 ethe 1/1/7 to 1/1/24
router-interface ve 30
!
vlan 40 name Management by port
tagged ethe 1/1/1 to 1/1/2 ethe 1/1/7 to 1/1/24
untagged ethe 1/1/3 to 1/1/4
router-interface ve 40
!
vlan 70 name IOT by port
tagged ethe 1/1/1 to 1/1/2 ethe 1/1/7 to 1/1/24
router-interface ve 70
!
vlan 100 name IPTV by port
tagged ethe 1/1/13 to 1/1/24 ethe 1/1/47
untagged ethe 1/1/43
router-interface ve 100
!
vlan 300 by port
tagged ethe 1/1/1 to 1/1/2
router-interface ve 300
!
!
!
!
!
aaa authentication web-server default local
aaa authentication enable default local
aaa authentication login default local
enable telnet authentication
hostname icx6450
ip route 0.0.0.0/0 172.26.1.1
!
username root password .....
!
!
!
!
!
interface ve 1
ip address 192.168.2.1 255.255.255.0
!
interface ve 30
ip address 192.168.30.2 255.255.255.0
!
interface ve 40
ip address 192.168.40.2 255.255.255.0
!
interface ve 70
ip address 192.168.70.2 255.255.255.0
!
interface ve 100
ip address 192.168.1.253 255.255.255.0
ip helper-address 1 192.168.1.1
!
interface ve 300
ip address 172.26.1.2 255.255.255.0
And also show ip route:

Code:
Total number of IP routes: 9
Type Codes - B:BGP D:Connected O:OSPF R:RIP S:Static; Cost - Dist/Metric
BGP  Codes - i:iBGP e:eBGP
OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2
        Destination        Gateway         Port          Cost          Type Uptime
1       0.0.0.0/0          172.26.1.1      ve 300        1/1           S    1h55m
2       172.26.1.0/24      DIRECT          ve 300        0/0           D    7d2h
3       192.168.1.0/24     DIRECT          ve 100        0/0           D    1h47m
4       192.168.20.0/24    DIRECT          ve 20         0/0           D    7d2h
5       192.168.30.0/24    DIRECT          ve 30         0/0           D    7d2h
6       192.168.40.0/24    DIRECT          ve 40         0/0           D    7d2h
7       192.168.70.0/24    DIRECT          ve 70         0/0           D    7d2h
8       192.168.80.0/24    DIRECT          ve 80         0/0           D    7d2h
9       192.168.90.0/24    DIRECT          ve 90         0/0           D    7d2h
 

Drewy

Active Member
Apr 23, 2016
208
56
28
54
Before you do a radical tuning and cut the case, I would start to cut out the "holes" in front of the exhaust fans. There is more metal sheet instead of hole. For safety and good locking fix a metal net from inside.
I’ve done this to my pair of 7250’s and while I think it makes (marginal) improvements in temps, it doesn’t (to my old ears) make much if any difference to the noise. To be honest I think it makes it worse

obviously your mileage and ears will vary.
 
  • Like
Reactions: noduck

covfefe

New Member
Jan 9, 2022
4
0
1
Could someone help me understand what I am doing wrong? Just got an ICX7250, and tried to follow the guide to enable the license, but failed.
It seems I'm missing an easy step, as the `enable` is not working

Code:
ICX7250-24 Switch#enable
Incomplete command.

ICX7250-24 Switch#license install perpetual 1 8x10g
Invalid input -> install perpetual 1 8x10g
Type ? for a list

ICX7250-24 Switch#conf t
ICX7250-24 Switch(config)#enable
Incomplete command.

ICX7250-24 Switch(config)#license install perpetual 1 8x10g
Invalid input -> license install perpetual 1 8x10g
Type ? for a list

ICX7250-24 Switch(config)#show license
Index  Lic Mode    Lic Name        Lid/Serial No Lic Type  Status   Lic Period  Lic Capacity  
Stack unit 1:
1    Node Lock    ICX7250-10G-LIC-POD  fwjxxxxxxxFOO  Normal   Active   Unlimited     2
ICX7250-24 Switch(config)#

ICX7250-24 Switch#show version
  Copyright (c) 2017 Ruckus Wireless, Inc. All rights reserved.
    UNIT 1: compiled on Nov 28 2018 at 10:32:45 labeled as SPS08070d
      (25707496 bytes) from Primary SPS08070d.bin
        SW: Version 08.0.70dT211
      Compressed Boot-Monitor Image size = 786944, Version:10.1.14T215 (spz10114)
       Compiled on Thu Nov 15 07:39:58 2018

  HW: Stackable ICX7250-24
==========================================================================
UNIT 1: SL 1: ICX7250-24 24-port Management Module
      Serial  #:DUxxxxxxx99
      License: BASE_SOFT_PACKAGE   (LID: fwxxxxxxFOO)
      P-ASIC  0: type B344, rev 01  Chip BCM56344_A0
==========================================================================
UNIT 1: SL 2: ICX7250-SFP-Plus 8-port 80G Module
==========================================================================
1000 MHz ARM processor ARMv7 88 MHz bus
8192 KB boot flash memory
2048 MB code flash memory
2048 MB DRAM
STACKID 1  system uptime is 2 minute(s) 18 second(s)
The system started at 06:20:59 GMT+00 Tue Feb 08 2022

The system : started=cold start                                  
2:48
 
Last edited:

fohdeesha

Kaini Industries
Nov 20, 2016
2,721
3,055
113
33
fohdeesha.com
Could someone help me understand what I am doing wrong? Just got an ICX7250, and tried to follow the guide to enable the license, but failed.
It seems I'm missing an easy step, as the `enable` is not working

Code:
ICX7250-24 Switch#enable
Incomplete command.

ICX7250-24 Switch#license install perpetual 1 8x10g
Invalid input -> install perpetual 1 8x10g
Type ? for a list

ICX7250-24 Switch#conf t
ICX7250-24 Switch(config)#enable
Incomplete command.

ICX7250-24 Switch(config)#license install perpetual 1 8x10g
Invalid input -> license install perpetual 1 8x10g
Type ? for a list

ICX7250-24 Switch(config)#show license
Index  Lic Mode    Lic Name        Lid/Serial No Lic Type  Status   Lic Period  Lic Capacity 
Stack unit 1:
1    Node Lock    ICX7250-10G-LIC-POD  fwjxxxxxxxFOO  Normal   Active   Unlimited     2
ICX7250-24 Switch(config)#

ICX7250-24 Switch#show version
  Copyright (c) 2017 Ruckus Wireless, Inc. All rights reserved.
    UNIT 1: compiled on Nov 28 2018 at 10:32:45 labeled as SPS08070d
      (25707496 bytes) from Primary SPS08070d.bin
        SW: Version 08.0.70dT211
      Compressed Boot-Monitor Image size = 786944, Version:10.1.14T215 (spz10114)
       Compiled on Thu Nov 15 07:39:58 2018

  HW: Stackable ICX7250-24
==========================================================================
UNIT 1: SL 1: ICX7250-24 24-port Management Module
      Serial  #:DUxxxxxxx99
      License: BASE_SOFT_PACKAGE   (LID: fwxxxxxxFOO)
      P-ASIC  0: type B344, rev 01  Chip BCM56344_A0
==========================================================================
UNIT 1: SL 2: ICX7250-SFP-Plus 8-port 80G Module
==========================================================================
1000 MHz ARM processor ARMv7 88 MHz bus
8192 KB boot flash memory
2048 MB code flash memory
2048 MB DRAM
STACKID 1  system uptime is 2 minute(s) 18 second(s)
The system started at 06:20:59 GMT+00 Tue Feb 08 2022

The system : started=cold start                                 
2:48
the part you're doing wrong is skipping the entire configuration guide, which the license page you're trying to follow says at the top should be followed first. also enable command isn't working because you were already at the enable level prompt when running it
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,721
3,055
113
33
fohdeesha.com
I was wondering if there is a technique in the ICX platform that allows me to intercept all DNS traffic from clients and redirect it on the switch itself..

I'm trying out Anycast on Windows Domain Controllers (blog.azureinfra.com) - and was wondering if there was a way to essentially force the clients (by the switch) to use a specific IP address for DNS resolving.. (and yes.. I also need to post on how to perform the BGP routes on the 6450 directly rather than the Juniper)....

so in short.. even if a client has 172.16.5.1 configured as their DNS server - I want the Brocade to intercept all this traffic and point it straight to 51.51.51.51 - my configured anycast IP
that would be NAT, which L3 switches don't do. also the 6450 does not support bgp
 

vfxer

New Member
Feb 2, 2022
3
1
3
I just downloaded latest FI 09.0.10 for icx7150-c12p. Just curious what is the difference between SPR09010ufi.bin and SPS09010ufi.bin? Notice there is SPR vs SPS. Based the doc from ICX7150 - Fohdeesha Docs, I should be using SPR version yeah?
 

Rain

Active Member
May 13, 2013
274
116
43
I just downloaded latest FI 09.0.10 for icx7150-c12p. Just curious what is the difference between SPR09010ufi.bin and SPS09010ufi.bin? Notice there is SPR vs SPS. Based the doc from ICX7150 - Fohdeesha Docs, I should be using SPR version yeah?
SPR is the routing firmware (with L3 routing features, ect). SPS is the "basic" switch firmware. The routing firmware can do everything the switching firmware can do and more. If you don't need SPS for some specific reason, just go with SPR.
 
  • Like
Reactions: gseeley

mfolnovic

New Member
Jun 7, 2021
6
2
3
My network consists of devices connected to 6450, which is connected to pfsense, which is then connected to modem (192.168.1.1).
I've setup inter-vlan routing on switch by following https://forums.servethehome.com/index.php?threads/layer-3-switch-w-pfsense.23236/.

For some reason, my ISP forces me to connected IPTV receivers directly to modem. But, I only have one ethernet port in living room. So my end goal is to have IPTV receiver and TV connected to a USW Flex Mini in living room, that's connected to 6450, if that's possible.

My idea was to have new VLAN 100, and all traffic on that VLAN would be routed directly to modem (not through pfsense). I didn't setup VLAN 100 on pfsense - should I?

At the moment, I have:
- pfsense connected to port 1
- modem connected to port 47
- Flex Mini in living room connected to port 24:
- port 1 is on VLAN70 - TV connected to it
- port 2 is on VLAN100 - laptop connected to it

I also tried to simplify things by connecting living room to port 43, which has untagged VLAN100.

In both scenarios, I can't get IP address from DHCP server. I've tried to play with static routes but couldn't make it work.
While diagnosing this, I've realised that as soon as I add ve 100, I can't ping modem (192.168.1.1).

Any ideas? Thanks in advance! :)

Here's my configuration:
Code:
ver 08.0.30tT313
!
stack unit 1
  module 1 icx6450-48p-poe-port-management-module
  module 2 icx6450-sfp-plus-4port-40g-module
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
!
vlan 30 name Trusted by port
tagged ethe 1/1/1 to 1/1/2 ethe 1/1/7 to 1/1/24
router-interface ve 30
!
vlan 40 name Management by port
tagged ethe 1/1/1 to 1/1/2 ethe 1/1/7 to 1/1/24
untagged ethe 1/1/3 to 1/1/4
router-interface ve 40
!
vlan 70 name IOT by port
tagged ethe 1/1/1 to 1/1/2 ethe 1/1/7 to 1/1/24
router-interface ve 70
!
vlan 100 name IPTV by port
tagged ethe 1/1/13 to 1/1/24 ethe 1/1/47
untagged ethe 1/1/43
router-interface ve 100
!
vlan 300 by port
tagged ethe 1/1/1 to 1/1/2
router-interface ve 300
!
!
!
!
!
aaa authentication web-server default local
aaa authentication enable default local
aaa authentication login default local
enable telnet authentication
hostname icx6450
ip route 0.0.0.0/0 172.26.1.1
!
username root password .....
!
!
!
!
!
interface ve 1
ip address 192.168.2.1 255.255.255.0
!
interface ve 30
ip address 192.168.30.2 255.255.255.0
!
interface ve 40
ip address 192.168.40.2 255.255.255.0
!
interface ve 70
ip address 192.168.70.2 255.255.255.0
!
interface ve 100
ip address 192.168.1.253 255.255.255.0
ip helper-address 1 192.168.1.1
!
interface ve 300
ip address 172.26.1.2 255.255.255.0
And also show ip route:

Code:
Total number of IP routes: 9
Type Codes - B:BGP D:Connected O:OSPF R:RIP S:Static; Cost - Dist/Metric
BGP  Codes - i:iBGP e:eBGP
OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2
        Destination        Gateway         Port          Cost          Type Uptime
1       0.0.0.0/0          172.26.1.1      ve 300        1/1           S    1h55m
2       172.26.1.0/24      DIRECT          ve 300        0/0           D    7d2h
3       192.168.1.0/24     DIRECT          ve 100        0/0           D    1h47m
4       192.168.20.0/24    DIRECT          ve 20         0/0           D    7d2h
5       192.168.30.0/24    DIRECT          ve 30         0/0           D    7d2h
6       192.168.40.0/24    DIRECT          ve 40         0/0           D    7d2h
7       192.168.70.0/24    DIRECT          ve 70         0/0           D    7d2h
8       192.168.80.0/24    DIRECT          ve 80         0/0           D    7d2h
9       192.168.90.0/24    DIRECT          ve 90         0/0           D    7d2h
After good night sleep, I've added:

Code:
interface ethernet 1/1/47
dual-mode  100
!
And all I said above is working now.

I'm quite new at this, so my thought process was this. Packages directly from switch won't be tagged, and it needs to reach modem (192.168.1.1) because of udp helper. ip route says those packages should go through ve 100, whose uplink (port 47) until now only accepted packages tagged with vlan100 (but not untagged packages).

The only problem I have now is I can't reach modem from other vlans, but that'll probably be fixed after another good night sleep. If someone sees obvious mistake I did, please tell. :)

I'm trying this from device on vlan30, and I've updated it with:

Code:
vlan 30 name Trusted by port
tagged ethe 1/1/1 to 1/1/2 ethe 1/1/7 to 1/1/24 ethe 1/1/47
router-interface ve 30
So that port 47 accepts packages tagged with vlan30.
 

Didomir

New Member
Oct 13, 2019
4
0
1
50
I was wondering how the price/performance ratio looks like in 2022 ? I was looking to buy 7250/7450/6450/6610 24P models, however prices seems to be high. I'll need a pair of 24P in Q3/22 - Q1/22 shall I wait for good price of 7250/7450 (price and noise are in consideration) or I can go with 6610/6450 (8080vs8030) ?
Do someone have audio/video comparing noise from 6610/7450/6450/7250 24P models ? I'm trying to decide which switch will provide best price/performance/features ratio and for now I'm steering to 6610 but can figure out how noisier will be compared to the others...