Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Roelf Zomerman

Active Member
Jan 10, 2019
141
26
28
blog.azureinfra.com
yups that works too.. all clients point to your switch, and your switch points to the router with the default route in the virtual router on the 192.168.1.0/30 subnet..

by not giving the 20/30/40 VLAN's an interface, you essentially take them out of the L3 option of the switch.. and they would be normal untagged or tagged traffic inside the switch..
 

Wronglebowski

New Member
Jun 18, 2018
5
0
1
Is there a good source for newer firmware? The fohdeesha website for the ICX 7250 has 2019 Firmware. If I can find newer firmware is there any reason not to upgrade?
 

neb50

Member
Aug 28, 2018
69
24
8
FYI. I am on 8.0.92dc and it looks like they have a 8.0.92e out now. I did not jump to the .95 train since I don't need any of those features and figured that .92 was out long enough to be stable.
 

Wronglebowski

New Member
Jun 18, 2018
5
0
1
FYI. I am on 8.0.92dc and it looks like they have a 8.0.92e out now. I did not jump to the .95 train since I don't need any of those features and figured that .92 was out long enough to be stable.
So is the number the feature set followed by the security revision? I see 8.0.70h, released on Jan 18th 2021. So this would be a much older release with backported security fixes?

My main concern is the licensing. Is the "Honor system" still present even on .95?
 

neb50

Member
Aug 28, 2018
69
24
8
I haven't tried 95, but 92 still works

I am not an expert, but from what I understand each 8.0.xx is a release train and the letters are different rev's of that release train.

.90 or higher was needed to work with Ruckus Unleashed, so I went with .92. Why-It was newer than .90 and older than .95 and seems to have been out long enough to have most of the bugs worked out.
 

LodeRunner

Active Member
Apr 27, 2019
455
199
43
Is there a good source for newer firmware? The fohdeesha website for the ICX 7250 has 2019 Firmware. If I can find newer firmware is there any reason not to upgrade?
He has that firmware posted as a known good starting point. You can' t go wrong with 8080d/e. If you need more advanced features, then upgrade to 8090/8092. But if you're just getting started and your devices are not on 8080, follow his guide first.
 
Last edited:

neb50

Member
Aug 28, 2018
69
24
8
He has that firmware posted as a known good starting point. You can' t go wrong with 8080d/e. If you need more advanced features, then upgrade tp 8090/8092. But if you're just getting started and your devices are not on 8080, follow his guide first.
Good point with the 8.0.80 that fohdeesha has on his upgrade page. You will need to go to it if you are not already on 8.0.80 to be able to go to 8.0.9x and his guide is a nice way to get the switch configured before you make the jump up (it should be the same once you go to 8.0.9x but the config transfers up)
 
  • Like
Reactions: Ericthenerd

tubs-ffm

Active Member
Sep 1, 2013
122
39
28
yups that works too.. all clients point to your switch, and your switch points to the router with the default route in the virtual router on the 192.168.1.0/30 subnet..

by not giving the 20/30/40 VLAN's an interface, you essentially take them out of the L3 option of the switch.. and they would be normal untagged or tagged traffic inside the switch..
That this way will work was quite clear to me. Maybe the most popular set-up I guess. The reasons why I wanted to go a different way were these:
  • utilising all 3 available physical nic at the firewall
  • avoiding VLAN and LAGG on the firewall (small OPNsense box)
  • continue using DHCP server on firewall
  • keep network topology simple and easy to change back to a L2 set-up in case of need for modifications
Any alternative solution for set-up you could suggest?
 

Pyro_Fox

New Member
Feb 9, 2021
1
0
1
Hey I'm really new to L3 networking, so hopefully this is the right place to ask this.

Does the ICX6450 support passive SFP+ uplink connections? I'm trying to connect my new ICX6450 to a Mellanox CX3 (MCX311A-XCAT) using an SFP+ passthru cable, but the devices just refuse to connect/negotiate. Is this even supported? I know the CX3 supports passthru since we use them at my job, but those are connected to Cisco Nexus switches with QSFP28 breakout cables so I just don't know how to tell if this switch can .

Things I've already done:
  • Updated the ICX6450 to the latest L3 firmware using @fohdeesha 's wonderful tutorials
  • Updated the the NIC to the latest FW (2.42.5000)
  • Updated my OS to the latest WinOF driver (5.50.53000)
Things I've observed:
  • When the passthru cable is connected to the PC and switch, the light on the back of the NIC comes on.
  • While monitoring the serial port on the switch I see it log Port 1/2/2 optics inserted, wait for Phy port initialization...
  • The switch port lights does not come on.
  • If I use an SFP+ to 10GBaseT adapter either in the NIC or the same SFP+ port on the switch, it works just fine. (I only have one so I can't test if just using 2x adapters would solve the issue).


Edit: Apparently I wasn't thorough enough. It looks like only 2 of the 4 SFP+ ports are working (X1 and X3). I wonder how do I check if they are defective?
 
Last edited:

MoMeanMugs

Member
Apr 16, 2018
57
17
8
72
Hey I'm really new to L3 networking, so hopefully this is the right place to ask this.

Does the ICX6450 support passive SFP+ uplink connections? I'm trying to connect my new ICX6450 to a Mellanox CX3 (MCX311A-XCAT) using an SFP+ passthru cable, but the devices just refuse to connect/negotiate. Is this even supported? I know the CX3 supports passthru since we use them at my job, but those are connected to Cisco Nexus switches with QSFP28 breakout cables so I just don't know how to tell if this switch can .

Things I've already done:
  • Updated the ICX6450 to the latest L3 firmware using @fohdeesha 's wonderful tutorials
  • Updated the the NIC to the latest FW (2.42.5000)
  • Updated my OS to the latest WinOF driver (5.50.53000)
Things I've observed:
  • When the passthru cable is connected to the PC and switch, the light on the back of the NIC comes on.
  • While monitoring the serial port on the switch I see it log Port 1/2/2 optics inserted, wait for Phy port initialization...
  • The switch port lights does not come on.
  • If I use an SFP+ to 10GBaseT adapter either in the NIC or the same SFP+ port on the switch, it works just fine. (I only have one so I can't test if just using 2x adapters would solve the issue).
I had bad luck with DAC cables and my ICX6650's with the ConnectX-3's. I bought 4 of the same DAC cables, all coded for Mellanox, and only one would work when connecting to the switch or between ports. The switch would read the DAC info, but the ports would never come up on 3 of them. I ending up giving up and getting some Brocade QSFP optics and fiber cables for each end. I would guess the ConnectX-3 is the problem. I know this creates a potential loop (depending on your switch config), but if you plug both ends of the DAC into the switch, do the ports come up?
 

bubsterboo

Member
Dec 15, 2019
41
18
8
Hey I'm really new to L3 networking, so hopefully this is the right place to ask this.

Does the ICX6450 support passive SFP+ uplink connections? I'm trying to connect my new ICX6450 to a Mellanox CX3 (MCX311A-XCAT) using an SFP+ passthru cable, but the devices just refuse to connect/negotiate. Is this even supported? I know the CX3 supports passthru since we use them at my job, but those are connected to Cisco Nexus switches with QSFP28 breakout cables so I just don't know how to tell if this switch can .

Things I've already done:
  • Updated the ICX6450 to the latest L3 firmware using @fohdeesha 's wonderful tutorials
  • Updated the the NIC to the latest FW (2.42.5000)
  • Updated my OS to the latest WinOF driver (5.50.53000)
Things I've observed:
  • When the passthru cable is connected to the PC and switch, the light on the back of the NIC comes on.
  • While monitoring the serial port on the switch I see it log Port 1/2/2 optics inserted, wait for Phy port initialization...
  • The switch port lights does not come on.
  • If I use an SFP+ to 10GBaseT adapter either in the NIC or the same SFP+ port on the switch, it works just fine. (I only have one so I can't test if just using 2x adapters would solve the issue).
I've have been able to use this dac passive sfp+ cable between a Mellanox CX3 and a ICX6450 without issues. When I did this I was using Ubuntu 20.04 and whatever its default drivers were.
 
  • Like
Reactions: Pyro_Fox

m4r1k

Member
Nov 4, 2016
66
8
8
33
Hey there!

Recently my ICX 6610 has a weird problem, after like 12/13 hours that is on, the fan speed increases by a lot probably almost like during a fresh start/reload.

Do you have any clue?

Thanks!

Edit: BTW the higher airflow is generated by the power supply #2 , if I'm not wrong, the two power supply have different hardware revisions

Code:
show chassis
The stack unit 1 chassis info:

Power supply 1 (AC - Regular) present, status ok
     Model Number:    23-0000144-02
    Serial Number:    3A7
    Firmware Ver:      C
Power supply 1 Fan Air Flow Direction:  Front to Back
Power supply 2 (AC - Regular) present, status ok
     Model Number:    23-0000144-02
    Serial Number:    21H
    Firmware Ver:      C
Power supply 2 Fan Air Flow Direction:  Front to Back

Fan 1 ok, speed (auto): [[1]]<->2
Fan 2 ok, speed (auto): [[1]]<->2

Fan controlled temperature: 45.0 deg-C

Fan speed switching temperature thresholds:
        Speed 1: NM<----->78       deg-C
        Speed 2:       73<-----> 83 deg-C (shutdown)

Fan 1 Air Flow Direction:  Front to Back
Fan 2 Air Flow Direction:  Front to Back
MAC 1 Temperature Readings:
    Current temperature : 42.0 deg-C
CPU Temperature Readings:
    Current temperature : 35.0 deg-C
sensor A Temperature Readings:
    Current temperature : 25.5 deg-C
sensor B Temperature Readings:
    Current temperature : 37.0 deg-C
sensor C Temperature Readings:
    Current temperature : 24.0 deg-C
sensor D Temperature Readings:
    Current temperature : 22.0 deg-C
stacking card Temperature Readings:
    Current temperature : 45.0 deg-C
    Warning level.......: 80.0 deg-C
    Shutdown level......: 83.0 deg-C
Boot Prom MAC : cc4e.24f8.98d0
Management MAC: cc4e.24f8.98d0
 
Last edited:

infoMatt

Active Member
Apr 16, 2019
222
99
28
It looks like only 2 of the 4 SFP+ ports are working (X1 and X3). I wonder how do I check if they are defective?
Look at the first page. If you don't have any licence on it, only two ports can be set at 10G, the other two works only at 1G (and you have to set up for that, if you leave the ports configured for 10G they go into an ERR-DISABLED state).
SFP/SFP+ ports do not auto-negotiate the speed. Try to set up both the NIC and the switch for 1G speed and it will work also on the other two ports.
 

Wronglebowski

New Member
Jun 18, 2018
5
0
1
I just picked up an ICX 7250 and I'm very happy with it. I got it configured and on the network via the out of band management port. Suddenly it's no longer on the network. It's still functioning and my network is up but it won't respond via IP.

I've tried to find one of the Mini-USB to Serial cables but they seem to be very rare. Anyone have a good source for them? I'm tempted to just cut up a Mini-usb cable and rig something up.
 

rocketpanda40

Member
Dec 12, 2019
39
24
8
I just picked up an ICX 7250 and I'm very happy with it. I got it configured and on the network via the out of band management port. Suddenly it's no longer on the network. It's still functioning and my network is up but it won't respond via IP.

I've tried to find one of the Mini-USB to Serial cables but they seem to be very rare. Anyone have a good source for them? I'm tempted to just cut up a Mini-usb cable and rig something up.
I just made one. Stripped a mini-usb cable, snipped off the red and black wires, and used an ethernet crimper to crimp the green usb wire in the green/white ethernet slot and the white usb wire in the green ethernet slot. Then connected that with an rj45 coupler/keystone I had laying around to a cisco-style usb-a to rj45 console cable. It works great, the only issue is I only have Cat6 8p8c connectors, and the mini-usb cable is a much smaller guage so it barely crimped tight enough. I would recommend if you do this, to place a small bit of normal ethernet cable jacket around the mini-usb cable inside the connector so it crimps tighter.