Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
If all other devices are pulling addresses fine except for the sonos, that would be a sonos problem. Is the wireless access point a true bridge and not blocking any packets, and connected directly to the vlan with the 192.xxx dhcp server on it?
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
and do you have multiple of those zonebridge things? I'm not familiar with sonos but from some quick googling it seems they're using a broken implementation of rstp with multiple bases/wireless networks and some people have had issues with this.

reboot the sonos if you haven't
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
If all other devices are pulling addresses fine except for the sonos, that would be a sonos problem. Is the wireless access point a true bridge and not blocking any packets, and connected directly to the vlan with the 192.xxx dhcp server on it?
The UnFi APs are connected to interfaces on the ICX 6610 that has Vlan 1 (192.168.1.0 network) and Vlan 30 (192.168.30.0 network - Guest Wi-Fi network) assigned. Vlan 30 traffic is tagged and Vlan 1 traffic is untagged using the dual-mode command.
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
and do you have multiple of those zonebridge things? I'm not familiar with sonos but from some quick googling it seems they're using a broken implementation of rstp with multiple bases/wireless networks and some people have had issues with this.

reboot the sonos if you haven't
This is a good article that talks about Sonos and Spanning Tree Protocol and BPDU.. I am wondering if I need to turn STP on for Vlan 1 and Vlan 30.

Sonos and the Spanning Tree Protocol | Sonos Community
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
yikes that is a mess. why are they using the original 1990 standard?

STP is off by default with the l3 OS image (off globally and off per vlan), but remains "ON" per port, meaning ports are eligible to participate in an STP topology, but one hasn't been defined globally so they don't perform STP. They may still be blocking BPDU's though, so try turning off STP on each port connected to something related to sonos crap (every port connected to an access point and every port connected to a wired sonos device)

enable
conf t
interface ethernet 1/1/5
no spanning-tree

you might have to restart the sonos stuff afterwords. How is your sonos set up? is it one device or multiple? One access point or multiple?
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
yikes that is a mess

STP is off by default with the l3 OS image (off globally and off per vlan), but remains "ON" per port, meaning ports are eligible to participate in an STP topology, but one hasn't been defined globally so they don't perform STP. They may still be blocking BPDU's though, so try turning off STP on each port connected to something related to sonos crap (every port connected to an access point and every port connected to a wired sonos device)

enable
conf t
interface ethernet 1/1/5
no spanning-tree

you might have to restart the sonos stuff afterwords. How is your sonos set up? is it one device or multiple? One access point or multiple?
So, when I go through the Sonos setup for a Sonos device, it should be picking up a 192.168.1.x address from DHCP, but it is picking up a 169.254.48.x address. See screenshot from Unifi dashboard. I have 6 sonos devices in 6 different rooms in my house.

upload_2018-7-28_22-56-7.png
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
did you run the suggested "no spanning-tree" command I put above on every brocade port connected to an access point (either directly or indirectly)?

better yet just turn it off on all copper ports (since it's already off globally)

enable
conf t
int e 1/1/1 to 1/1/48
no spanning-tree

then reboot the sonos and see if they pull an IP
 

K D

Well-Known Member
Dec 24, 2016
1,433
311
83
30041
The UnFi APs are connected to interfaces on the ICX 6610 that has Vlan 1 (192.168.1.0 network) and Vlan 30 (192.168.30.0 network - Guest Wi-Fi network) assigned. Vlan 30 traffic is tagged and Vlan 1 traffic is untagged using the dual-mode command.
Looks like your Sonos devices are not able to hit the DHCP Server. Had a similar issue a couple of years earlier. Also, my entire network would crash due to a broadcast storm the moment I brought any of these online. Finally fixed it by turning off Wifi in all devices that were connected via a wired network as well. Some troubleshooting steps that I remember.

1. Check if your Sonos devices are using the right WiFi network.
2. In Unifi Controller, check if you have defined the required VLANS in networks AND set the right VLAN ID in the Wifi network Settings.
3. Power off all your Sonos devices (all of them).
4. One by one power your sonos devices and if they are connected via a wired network, disable the Wifi network (Disabling the WiFi Link on a Sonos Music Player). Once it is online, proceed with the next one.

For me, everything worked like clockwork till I replaced my home network with a full Unifi Stack. Took me days of troubleshooting to figure it out. Sonos does not play well with Unifi.
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
did you run the suggested "no spanning-tree" command I put above on every brocade port connected to an access point (either directly or indirectly)?

better yet just turn it off on all copper ports (since it's already off globally)

enable
conf t
int e 1/1/1 to 1/1/48
no spanning-tree

then reboot the sonos and see if they pull an IP
I will try it right now....
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
Looks like your Sonos devices are not able to hit the DHCP Server. Had a similar issue a couple of years earlier. Also, my entire network would crash due to a broadcast storm the moment I brought any of these online. Finally fixed it by turning off Wifi in all devices that were connected via a wired network as well. Some troubleshooting steps that I remember.

1. Check if your Sonos devices are using the right WiFi network.
2. In Unifi Controller, check if you have defined the required VLANS in networks AND set the right VLAN ID in the Wifi network Settings.
3. Power off all your Sonos devices (all of them).
4. One by one power your sonos devices and if they are connected via a wired network, disable the Wifi network (Disabling the WiFi Link on a Sonos Music Player). Once it is online, proceed with the next one.

For me, everything worked like clockwork till I replaced my home network with a full Unifi Stack. Took me days of troubleshooting to figure it out. Sonos does not play well with Unifi.
The UniFi AP was working fine with the Juniper Switches which was replaced by the ICX 6610. So it's not the UniFi APs.
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
it's because the brocade is blocking BPDU packets, which it shouldn't do when STP is totally disabled (which is what the command above should do)
 

K D

Well-Known Member
Dec 24, 2016
1,433
311
83
30041
The UniFi AP was working fine with the Juniper Switches which was replaced by the ICX 6610. So it's not the UniFi APs.
Glad you have ruled it out. The reason I mentioned it was because they worked fine for me with a Cisco SG300 switch before I replaced them with Unifi switches.
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
did you run the suggested "no spanning-tree" command I put above on every brocade port connected to an access point (either directly or indirectly)?

better yet just turn it off on all copper ports (since it's already off globally)

enable
conf t
int e 1/1/1 to 1/1/48
no spanning-tree

then reboot the sonos and see if they pull an IP
Unfortunately that did not work.. I will try powering down all the Sonos devices and start with only 1 device at a time.. Any other recommendation?

upload_2018-7-28_23-33-26.png
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
I see you have two access points, are they running multiple wireless networks? if multiple are the sonos's configured to connect to just one of them? if they're only connecting to one access point and not using that wired base thing also, the brocade shouldn't even need to forward BPDU packets, if the sonos is flooding them out and looking to see them from other sonos devices, they should hit the access point and get flooded right back out over the wifi AP. turn them all off and start 1 by one