Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

PGlover

Active Member
Nov 8, 2014
472
58
28
54
I see you have two access points, are they running multiple wireless networks? if multiple are the sonos's configured to connect to just one of them? if they're only connecting to one access point and not using that wired base thing also, the brocade shouldn't even need to forward BPDU packets, if the sonos is flooding them out and looking to see them from other sonos devices, they should hit the access point and get flooded right back out over the wifi AP. turn them all off and start 1 by one
Yes.. I have 3 APs.. They are running 2 Wi-Fi networks. One for Guests (Vlan 30) and the one other for internal LAN users (Vlan 1). The sonos device will connect to the nearest AP.
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
Also, if you are using Sonos with Wifi, do not have them connected to the wired network as well.
I thought you need at least 1 sonos device connected to the wired network.. I do have 1 device connected to the wired network (ZP80 device). I only have ZP80, ZP100, and ZP120 Sonos devices.
 

K D

Well-Known Member
Dec 24, 2016
1,433
311
83
30041
Yeah you need at least one device connected. I had issues with it though finally and got a Sonos boost that’s wired. All my ZPs, Playbars and Subs are wired and have the WiFi disabled.

Sonos works seamlessly with consumer network gear but getting it to work with enterprise gear is a PITA .
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
Yeah you need at least one device connected. I had issues with it though finally and got a Sonos boost that’s wired. All my ZPs, Playbars and Subs are wired and have the WiFi disabled.

Sonos works seamlessly with consumer network gear but getting it to work with enterprise gear is a PITA .
I may have to invest in the Sonos boost...
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
So the issue is it's sending out BPDU packets over wireless, through the AP, through the switch, over the wired connection, to the other sonos (and vice versa), and it needs to see that happening. However the brocade is dropping the BPDU packets so they never make it there. this is my best guess anyway, from reading their stp thread but never touching sonos in my life

Try this, at the global config level:

enable
conf t
bpdu-flood-enable

I've never used this command personally, but that *should* allow unfiltered BPDU forwarding. you'll probably have to turn off all the sonos and bring them online one at a time after making that change.

Switches are *supposed* to pass BPDU traffic unfiltered when STP is configured OFF (as to not interrupt other STP topologies), so that's surprising that it was still happening with it off globally and at the port level
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
So the issue is it's sending out BPDU packets over wireless, through the AP, through the switch, over the wired connection, to the other sonos (and vice versa), and it needs to see that happening. However the brocade is dropping the BPDU packets so they never make it there. this is my best guess anyway, from reading their stp thread but never touching sonos in my life

Try this, at the global config level:

enable
conf t
bpdu-flood-enable

I've never used this command personally, but that *should* allow unfiltered BPDU forwarding. you'll probably have to turn off all the sonos and bring them online one at a time after making that change.

Switches are *supposed* to pass BPDU traffic unfiltered when STP is configured OFF (as to not interrupt other STP topologies), so that's surprising that it was still happening with it off globally and at the port level
Thanks for all your help.. I think the best alterative may be to go to Best Buy in the morning and purchase the Sonos Boost. It looks like this product creates a dedicated 2.5G Wi-Fi network for the sonos devices to communicate over; however, I think the boost device needs to connect to the switch. So I may still have the same issues...
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
well just try that command, at this point I'm honestly curious if it's a BPDU blocking issue - if that flood command fixes it, that means the 6610 was blocking STP BPDU packets even though STP was off, which would be a bug I need to report
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
well just try that command, at this point I'm honestly curious if it's a BPDU blocking issue - if that flood command fixes it, that means the 6610 was blocking STP BPDU packets even though STP was off, which would be a bug I need tp report
Will that command have any impact to other devices connected to the switch?
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
nope, it just means "if I get a BPDU packet, send it to the other ports instead of dropping it", which is what it's supposed to be doing by default to be compliant with the STP spec (which says devices not participating in STP actively must blindly forward BPDU packets)
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
nope, it just means "if I get a BPDU packet, send it to the other ports instead of dropping it", which is what it's supposed to be doing by default to be compliant with the STP spec (which says devices not participating in STP actively must blindly forward BPDU packets)
Should I reboot the switch and all Sonos devices?
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
sure, couldn't hurt. I would imagine the switch does not need to be rebooted, but the sonos's definitely should

if you reboot the switch don't forget to write memory first
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
sure, couldn't hurt. I would imagine the switch does not need to be rebooted, but the sonos's definitely should

if you reboot the switch don't forget to write memory first
I'm reading more information about Sonos and STP and it looks like it needs to be enabled on the switch.. On my Juniper I had RSTP enabled. I can post the configuration..
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
it does not need to be enabled, it just needs to blindly forward BPDU packets - turning on STP/RSTP achieves this as well, because it becomes BPDU packet aware and also forwards them - it's not required though. just forwarding BPDU packets without actually running STP is more than enough

if STP had to be on, sonos stuff wouldn't work with 99% of consumer network gear
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
it does not need to be enabled, it just needs to blindly forward BPDU packets - turning on STP/RSTP achieves this as well, because it becomes BPDU packet aware and also forwards them - it's not required though. just forwarding BPDU packets without actually running STP is more than enough

if STP had to be on, sonos stuff wouldn't work with 99% of consumer network gear
You are correct...
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
So the issue is it's sending out BPDU packets over wireless, through the AP, through the switch, over the wired connection, to the other sonos (and vice versa), and it needs to see that happening. However the brocade is dropping the BPDU packets so they never make it there. this is my best guess anyway, from reading their stp thread but never touching sonos in my life

Try this, at the global config level:

enable
conf t
bpdu-flood-enable

I've never used this command personally, but that *should* allow unfiltered BPDU forwarding. you'll probably have to turn off all the sonos and bring them online one at a time after making that change.

Switches are *supposed* to pass BPDU traffic unfiltered when STP is configured OFF (as to not interrupt other STP topologies), so that's surprising that it was still happening with it off globally and at the port level
I tried the command and I am still getting a 169.254 address being assigned to the Sonos device.
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
If you have something else you want me to try, let me know.. I can execute the steps in the morning...
 

PGlover

Active Member
Nov 8, 2014
472
58
28
54
Another thought is how can I add my Juniper EX2300-C POE switch back in my setup. This switch was dedicated for the 3 UnFi APs in my old setup and I know Sonos works on that switch....
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,003
1,824
113
29
fohdeesha.com
hmm, if it is indeed a BPDU issue, the brocade might have a bug where it simply will not flood BPDU packets unless you turn STP on, but that would be a pretty serious bug

You can just enable STP or RSTP on the brocade, at the vlan level of the vlans the sonos talk on. It shouldn't be necessary, but it seems due to a bug or otherwise you might not have a choice.

There's a chance this has absolutely nothing to do with STP and is a misconfiguration somewhere else, but I dunno. turning on STP on the brocade will confirm that. if it STILL doesn't work, then it's not stp related. You need to be sure to turn stp on for the vlans, and remove all the no spanning-tree commands you added