Beware of EMC switches sold as Mellanox SX6XXX on eBay

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

up3up4

Member
Jun 10, 2018
87
29
18
Mlnx-os 3.3.4402 will recognized those ethernet interface, but if you go 3.6.8012 directly you have to follow the guide's step.4 to handle the management ethernet interface name mapping even on the native sx6036.
 
  • Like
Reactions: zuikaku

crash_maxed

New Member
Oct 30, 2019
5
20
3
Mlnx-os 3.3.4402 will recognized those ethernet interface, but if you go 3.6.8012 directly you have to follow the guide's step.4 to handle the management ethernet interface name mapping even on the native sx6036.
I'm not sure if this is being directed at me and I'm not sure what 3.3.4402 has to do with things. I never stated anything to the contrary, step 4 and setting the mgmt0 / mgmt1 interfaces in /etc/mactab is still most definitely required. I'm sure if I spent enough time fiddling with /etc/rc.d/init.d/rename_ifs that I could decipher what is going on and fix things, but frankly the /etc/mactab fix is just so simple that I don't have the motivation to take time to look into it. Furthermore, you don't even need to do this fix on a native MLNX-OS switch, only one that is being cross-flashed from EMC OS.
 

cktm57

New Member
Mar 1, 2021
13
0
1
There are appropriate documents and files linked in the thread
Dear Rand_!
I looked through the forum but couldn't find a solution to my problem.
Can I downgrade to old (EMC) firmware (EMC1270110020) after flashing the wrong MT_1260110020 firmware using the console and TFTP (To start the procedure again)?
When trying to flash with the Flint command, an error is issued:
mst status
MST devices:
------------
mt4099_pci_cr0
mt4099_pciconf0

Inband devices:
-------------------
CA_MT4099_CKTM-SERVER8_lid-0x0002
SW_MT51000_SwitchX_lid-0x0004

flint -d SW_MT51000_SwitchX_lid-0x0004 q
ibwarn: [12760] _do_madrpc: recv failed: Unknown error
ibwarn: [12760] mad_rpc: _do_madrpc failed; dport (Lid 4)

Thanks in advance,
Pavel
 

zuikaku

New Member
Feb 7, 2021
7
3
3
Mlnx-os 3.3.4402 will recognized those ethernet interface, but if you go 3.6.8012 directly you have to follow the guide's step.4 to handle the management ethernet interface name mapping even on the native sx6036.
Yeah by reading manufacture.sh this seems true - even on a native machine the script creates if-mappings in some cases. Anyway, I managed to rename management interfaces by adding following entries on mfdb:

Bash:
mddbreq -c /mnt/config/mfg/mfdb set modify "" /mfg/mfdb/interface/rename_type string "mac-map"
mddbreq -c /mnt/config/mfg/mfdb set modify "" /mfg/mfdb/interface/map/enable bool true
mddbreq -c /mnt/config/mfg/mfdb set modify "" /mfg/mfdb/interface/name/1 uint32 1
mddbreq -c /mnt/config/mfg/mfdb set modify "" /mfg/mfdb/interface/name/1/name string "mgmt0"
mddbreq -c /mnt/config/mfg/mfdb set modify "" /mfg/mfdb/interface/map/macifname/1 uint32 1
mddbreq -c /mnt/config/mfg/mfdb set modify "" /mfg/mfdb/interface/map/macifname/1/macaddr macaddr802 00:11:22:33:44:55
00:11:22:33:44:55 is a MAC address of eth0. If you're setting up for eth1 as well, you need to change "1" in each entry into "2". I applied this onto my converted SX6012 (freshly flashed with 3.6.1002) and it has so far worked flawlessly.

Lastly many thanks to @mpogr and all for wonderful guides and tricks - there are so much beyond the original guide like a fan mod script, a manufacture usb/tftp booting and single user mode etc. Now am looking into tweaking i2c stuff but it may take some time ;)
 
  • Like
Reactions: andvalb and nasbdh9

zuikaku

New Member
Feb 7, 2021
7
3
3
Another way is edit the manufacture.sh Revision: 1.85 which is for mlnx-os 3.6
line 1521 to IF_CANDIDATES=`ifconfig -a | egrep '^[^ \t]' | grep 'Ethernet.*HWaddr' | awk '{print $1}' | tr '\n' ' '`

line 1539 to IF_NAME_MAC_RAW=`ifconfig -a | grep 'Ethernet.*HWaddr' | sed 's/^\([^ ]*\) .*HWaddr \(.*\)/\2 \1/' | tr -s ' ' | egrep -v '^.* [^:]*:.*$' | egrep ' ('${IF_ACCEPTED_PATTERN}')$'`
So were you able to convert with manufacture.sh? If so can you share detail?
 

cktm57

New Member
Mar 1, 2021
13
0
1
I've tried 3 devices so far. two emc sx6018 and one emc sx6012. the mod doesn't work. Either the instructions are incorrect or Ive got bad files. I studied the docs and every page of this thread over and over and over. I even wrote my own docs. first boot I can never log in with admin/admin so i break the links and swap out passwd and shadow, reboot them im in. I try starting cli from bash and it appears to be "configuring modules" for 15 minutes then crashes "fatal internal error occured"

Code:
md5
326a90195938c19523888bbf6fab19bc    chad
37c53191f8a1749ebdb42463d9454d88    fdt_uni
e6df18fddae5f10412eabd2755f81854    hwd
55ca2838e036872830bd35987e1cb1d3    ibd
f5faeb61a5a11b7b67f14735fe81406d    image_layout.sh
183345ad0d9b08d734fbab14b0228153    image.tgz
f9f87a0e10b9596786eaa75acd80729b    vmlinuz-uni
Code:
oot@n4:~# flint -i sx6012F_wt.bin q
Image type:            FS2
FW Version:            9.3.8170
FW Release Date:       6.6.2016
Device ID:             51000
Description:           Node             Sys image
GUIDs:                 0000000000000000 0000000000000000
Description:           Base             Switch
MACs:                      000000000000     000000000000
VSD:                   n/a
PSID:                  MT_1270111029
root@n4:~# flint --allow_psid_change -d lid-0x5 -i ./sx6012F_wt.bin b

    Current FW version on flash:  9.9.1260
    New FW version:               9.3.8170

    Note: The new FW version is older than the current FW version on flash.

Do you want to continue ? (y/n) [n] : y


    You are about to replace current PSID on flash - "EMC1270110020" with a different PSID - "MT_1270111029".
    Note: It is highly recommended not to change the PSID.

Do you want to continue ? (y/n) [n] : y
Burning FS2 FW image without signatures - OK
Restoring signature                     - OK
root@n4:~#
Code:
localhost login: admin
Last login: Sun Feb 11 20:17:26 on ttyS0
Feb 11 20:35:04 localhost mgmtd[4089]: [mgmtd.ERR]: md_db_process_trusted_auth_info(), mdm_db.c:9209, build 1: Required condition was not met
Feb 11 20:35:04 localhost cli[4621]: [cli.ERR]: user admin: cli_cluster_cmds_init(), cli_cluster_cmds.c:205, build 1: failed getting /cluster/config/enable
    System is initializing!
This may take a few minutes


    Modules are being configured
Feb 11 20:35:11 localhost xinetd[4622]: open( /var/opt/tms/output/xinetd.conf ) failed: No such file or directory (errno = 2)
Feb 11 20:35:11 localhost xinetd[4622]: 4622 {init_services} couldn't get configuration. Exiting...
Feb 11 20:35:15 localhost chad[4630]: [chad.ERR]: bn_binding_get_uint16(), bnode_types.c:3034, build 1: NULL binding passed
Feb 11 20:35:15 localhost chad[4630]: [chad.ERR]: s2m_init(), chad_2node.c:5453, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:35:15 localhost chad[4630]: [chad.ERR]: chad_init_internal(), chad.c:2761, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:35:15 localhost chad[4630]: [chad.ERR]: main(), chad.c:2917, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:35:19 localhost httpd[4638]: httpd: Could not open configuration file /var/opt/tms/output/httpd.conf: No such file or directory
Feb 11 20:36:33 localhost xinetd[4654]: open( /var/opt/tms/output/xinetd.conf ) failed: No such file or directory (errno = 2)
Feb 11 20:36:33 localhost xinetd[4654]: 4654 {init_services} couldn't get configuration. Exiting...
Feb 11 20:36:37 localhost chad[4662]: [chad.ERR]: bn_binding_get_uint16(), bnode_types.c:3034, build 1: NULL binding passed
Feb 11 20:36:37 localhost chad[4662]: [chad.ERR]: s2m_init(), chad_2node.c:5453, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:36:37 localhost chad[4662]: [chad.ERR]: chad_init_internal(), chad.c:2761, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:36:37 localhost chad[4662]: [chad.ERR]: main(), chad.c:2917, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:36:41 localhost httpd[4670]: httpd: Could not open configuration file /var/opt/tms/output/httpd.conf: No such file or directory
Feb 11 20:40:36 localhost xinetd[4686]: open( /var/opt/tms/output/xinetd.conf ) failed: No such file or directory (errno = 2)
Feb 11 20:40:36 localhost xinetd[4686]: 4686 {init_services} couldn't get configuration. Exiting...
Feb 11 20:40:40 localhost chad[4694]: [chad.ERR]: bn_binding_get_uint16(), bnode_types.c:3034, build 1: NULL binding passed
Feb 11 20:40:40 localhost chad[4694]: [chad.ERR]: s2m_init(), chad_2node.c:5453, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:40:40 localhost chad[4694]: [chad.ERR]: chad_init_internal(), chad.c:2761, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:40:40 localhost chad[4694]: [chad.ERR]: main(), chad.c:2917, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:40:45 localhost httpd[4702]: httpd: Could not open configuration file /var/opt/tms/output/httpd.conf: No such file or directory
Feb 11 20:46:33 localhost snmpd[4461]: TID 1208140448: [snmpd.ERR]: sn_mib_get_caching_interval(), sn_mib_mellanox.c:173, build 1: Unexpected NULL
Feb 11 20:46:33 localhost snmpd[4461]: TID 1208140448: [snmpd.ERR]: sn_mib_entity_init(), sn_mib_entity.c:76, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: cli_sm_login_banner(), cli_sm_cmds.c:21490, build 1: Error code 14022 (type conversion failed, or bad data type provided) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: cli_sm_init_sm_ha(), cli_sm_cmds.c:987, build 1: Error code 14022 (type conversion failed, or bad data type provided) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: cli_sm_cmds_init(), cli_sm_cmds.c:11627, build 1: Error code 14022 (type conversion failed, or bad data type provided) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: util_get_uint8(), libutils.c:57, build 1: Unexpected NULL
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: lib_ui_api_get_system_profile(), lib_ui_api_utils.c:667, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: cli_ports_cmds_init(), cli_ports_cmds.c:169, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: util_get_uint8(), libutils.c:57, build 1: Unexpected NULL
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: cli_chassis_cmds_init(), cli_chassis_cmds.c:6457, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: cli_ip_cmds_init(), cli_ip_cmds.c:344, build 1: Unexpected NULL
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: update_g_ip_proxy_arp_active(), cli_hide_cmds.c:1024, build 1: Unexpected NULL
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: chc_get_ip_proxy_arp_active(), cli_hide_cmds.c:1058, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: lib_ui_api_check_ip_l3_config(), lib_ui_api.c:6775, build 1: Unexpected NULL
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: chc_get_ip_l3_active(), cli_hide_cmds.c:3878, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:47:06 localhost mgmtd[4089]: [mgmtd.ERR]: md_openflow_openflow_enabled(), md_openflowd.c:216, build 1: Required condition was not met
Feb 11 20:47:06 localhost mgmtd[4089]: [mgmtd.ERR]: md_openflow_handle_state_protocol(), md_openflowd.c:236, build 1: Error code 14002 (assertion failed) returned
Feb 11 20:47:06 localhost mgmtd[4089]: [mgmtd.ERR]: mdb_query(), mdb_db.c:3060, build 1: Error code 14002 (assertion failed) returned
Feb 11 20:47:06 localhost mgmtd[4089]: [mgmtd.ERR]: md_commit_handle_query_request(), md_commit.c:4098, build 1: Error code 14002 (assertion failed) returned
Feb 11 20:47:06 localhost mgmtd[4089]: [mgmtd.ERR]: md_commit_handle_query_session_request(), md_commit.c:4290, build 1: Error code 14002 (assertion failed) returned
% Internal error, code 1006 (see logs for details)
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: update_g_router_state(), cli_hide_cmds.c:4479, build 1: Unexpected NULL
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: chc_get_router_state(), cli_hide_cmds.c:4466, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: chc_license_init(), cli_hide_cmds.c:799, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: cli_hide_cmds_init(), cli_hide_cmds.c:510, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:47:06 localhost cli[4621]: [cli.ERR]: user admin: cli_init_modules(), cli_modules.c:455, build 1: Error code 14001 (unexpected NULL) returned
Feb 11 20:47:07 localhost cli[4621]: [cli.ERR]: user admin: cli_register_help_handler(), cli_registration.c:1764, build 1: Help description can only be specified for literal command words; use cc_help_exp instead
Feb 11 20:47:07 localhost cli[4621]: [cli.ERR]: user admin: Cmd reg: error registering command "fae interface *"
Feb 11 20:47:07 localhost cli[4621]: [cli.ERR]: user admin: cli_register_command(), cli_registration.c:377, build 1: Error code 14002 (assertion failed) returned
Feb 11 20:47:07 localhost cli[4621]: [cli.ERR]: user admin: cli_sanity_check_node_internal(), cli_registration.c:1155, build 1: Error code 14002 (assertion failed) returned
Feb 11 20:47:07 localhost cli[4621]: [cli.ERR]: user admin: tree_foreach_internal(), tree.c:561, build 1: Error code 14002 (assertion failed) returned
Feb 11 20:47:07 localhost cli[4621]: [cli.ERR]: user admin: tree_foreach_internal(), tree.c:595, build 1: Error code 14002 (assertion failed) returned
Feb 11 20:47:07 localhost cli[4621]: [cli.ERR]: user admin: tree_foreach_internal(), tree.c:595, build 1: Error code 14002 (assertion failed) returned
Feb 11 20:47:07 localhost cli[4621]: [cli.ERR]: user admin: cli_register_help_handler(), cli_registration.c:1764, build 1: Help description can only be specified for literal command words; use cc_help_exp instead
Feb 11 20:47:07 localhost cli[4621]: [cli.ERR]: user admin: Cmd reg: error registering command "fae no interface *"
Feb 11 20:47:07 localhost cli[4621]: [cli.ERR]: user admin: cli_register_command(), cli_registration.c:377, build 1: Error code 14002 (assertion failed) returned
Feb 11 20:47:0Feb 11FeFeb 11 20:47:07 localhost last message repeated 3 times
Feb 11 20:47:07 localhost cli[4621]: [cli.EFeFeFeb 11FFeb 11 Feb 11 20:47:07% A fatal internal error occurred
I got the same problem after calling CLI - fatal internal error. As in your case, I used different firmware for my EMC SX6012 (including for the SX6005 - to get at least unmanaged, but a working device). The result is negative. Were you able to solve this problem?
Thank you in advance.
 

klui

༺༻
Feb 3, 2019
870
479
63
I got the same problem after calling CLI - fatal internal error. As in your case, I used different firmware for my EMC SX6012 (including for the SX6005 - to get at least unmanaged, but a working device). The result is negative. Were you able to solve this problem?
Thank you in advance.
If you created the recovery jffs2 manually using the original instructions there was at least one error and can be overlooked if you rely on copy+paste. Look towards the end of this thread to obtain a working prebuilt file. @Gabriel Mateiciuc's post at https://forums.servethehome.com/ind...anox-sx6xxx-on-ebay.10786/page-39#post-269945 contains the file.
 

cktm57

New Member
Mar 1, 2021
13
0
1
If you created the recovery jffs2 manually using the original instructions there was at least one error and can be overlooked if you rely on copy+paste. Look towards the end of this thread to obtain a working prebuilt file. @Gabriel Mateiciuc's post at https://forums.servethehome.com/ind...anox-sx6xxx-on-ebay.10786/page-39#post-269945 contains the file.
Thanks to Klui for the helpful link. After replacing Chad and Xwd with those taken from the link from Gabriel Mateiciuc (https://forums.servethehome.com/index.phpmembers/gabriel-mateiciuc.7439/), the device finally boots into the web interface. However, switch is still not found in box OS (MST status shows only Nics), thus it does not find openSM and, accordingly, all ports are in the lInk down state.
Is it possible to fix it?
 

klui

༺༻
Feb 3, 2019
870
479
63
switch is still not found in box OS (MST status shows only Nics), thus it does not find openSM and, accordingly, all ports are in the lInk down state.
I don't use Infiniband and not sure what you're referring to. What is the output of mst status?

Here's what happened when I converted mine. I lost part of one command due to stty settings but that had an error. A subsequent mst status showed more i2c devices but not important for controller FW update.
Code:
[admin@sx6012 ~]# flint -i /opt/sth/new/MSX6012.bin q
Image type:          FS2
FW Version:          9.3.8170
FW Release Date:     6.6.2016
Device ID:           51000
Description:         Node             Sys image
GUIDs:               0000000000000000 0000000000000000
Description:         Base             Switch
MACs:                    000000000000     000000000000
VSD:                 n/a
PSID:                MT_1270110020
[admin@sx6012 ~]# mst status
MST modules:
------------
    MST PCI module loaded
    MST PCI configuration module loaded

MST devices:
------------
/dev/mst/dev-i2c-0               - Embedded I2C master
/dev/mst/dev-i2c-1               - Embedded I2C master
/dev/mst/mt51000_pciconf0        - PCI configuration cycles access.
                                   domain:bus:dev.fn=0001:81:00.0 addr.reg=88 data.reg=92
                                   Chip revision is: 02
st/mst/mt51000_pciconf0 -i /opt/sth/new/MSX6012.bin bcache_replacement -d /dev/m

-W- Firmware flash cache access is enabled. Running in this mode may cause the firmware to hang.
-E- Cannot open Device: /dev/mst/mst/mt51000_pciconf0. No such file or directory. MFE_CR_ERROR
[admin@sx6012 ~]# mst start
Starting MST (Mellanox Software Tools) driver set
[warn] mst_pci is already loaded, skipping
[warn] mst_pciconf is already loaded, skipping
Create devices
[admin@sx6012 ~]# mst status
MST modules:
------------
    MST PCI module loaded
    MST PCI configuration module loaded

MST devices:
------------
/dev/mst/dev-i2c-0               - Embedded I2C master
/dev/mst/dev-i2c-1               - Embedded I2C master
/dev/mst/dev-i2c-2               - Embedded I2C master
/dev/mst/dev-i2c-3               - Embedded I2C master
/dev/mst/dev-i2c-4               - Embedded I2C master
/dev/mst/dev-i2c-5               - Embedded I2C master
/dev/mst/dev-i2c-6               - Embedded I2C master
/dev/mst/dev-i2c-7               - Embedded I2C master
/dev/mst/dev-i2c-8               - Embedded I2C master
/dev/mst/dev-i2c-9               - Embedded I2C master
/dev/mst/mt51000_pciconf0        - PCI configuration cycles access.
                                   domain:bus:dev.fn=0001:81:00.0 addr.reg=88 data.reg=92
                                   Chip revision is: 02
[admin@sx6012 ~]# flint -i /opt/sth/new/MSX6012.bin q
Image type:          FS2
FW Version:          9.3.8170
FW Release Date:     6.6.2016
Device ID:           51000
Description:         Node             Sys image
GUIDs:               0000000000000000 0000000000000000
Description:         Base             Switch
MACs:                    000000000000     000000000000
VSD:                 n/a
[admin@sx6012 ~]# stty columns 150
[admin@sx6012 ~]# flint -allow_psid_change -override_cache_replacement -d /dev/mst/mt51000_pciconf0 -i /opt/sth/new/MSX6012.bin b

-W- Firmware flash cache access is enabled. Running in this mode may cause the firmware to hang.

    Current FW version on flash:  9.9.1260
    New FW version:               9.3.8170

    Note: The new FW version is older than the current FW version on flash.

 Do you want to continue ? (y/n) [n] : y


    You are about to replace current PSID on flash - "EMC1270110020" with a different PSID - "MT_1270110020".
    Note: It is highly recommended not to change the PSID.

 Do you want to continue ? (y/n) [n] : y
Burning FS2 FW image without signatures - OK
Restoring signature                     - OK
[admin@sx6012 ~]#
 

Labs

Member
Mar 21, 2019
88
16
8
I'm not entirely sure what to try next, I've tried using the /sbin/manufacture.sh script, it sorta works, but I don't know what storage device to input into the configuration menus... screenshots below.

View attachment 16776View attachment 16777View attachment 16778View attachment 16779View attachment 16780View attachment 16781
You should run the script like this I guess:
manufacture.sh -a -m m460ex -f /image.img

Don't use your new 3.6.x image. Use the image.img from the zip archive.

As for device list use /dev/mtd only. I suppose the script is recreating the partition table.
To have a full conversion like the OEM one the partitions must be recreated.

The original conversion guide was changing the partition table that's why you cannot upgrade the switch using standard upgrade procedure.
If everything goes well you should end up with the old 3.2.x version and after you can upgrade using the WebGUI or the CLI until 3.6.8012.
 
  • Like
Reactions: nasbdh9

cktm57

New Member
Mar 1, 2021
13
0
1
I don't use Infiniband and not sure what you're referring to. What is the output of mst status?

Here's what happened when I converted mine. I lost part of one command due to stty settings but that had an error. A subsequent mst status showed more i2c devices but not important for controller FW update.
Code:
[admin@sx6012 ~]# flint -i /opt/sth/new/MSX6012.bin q
Image type:          FS2
FW Version:          9.3.8170
FW Release Date:     6.6.2016
Device ID:           51000
Description:         Node             Sys image
GUIDs:               0000000000000000 0000000000000000
Description:         Base             Switch
MACs:                    000000000000     000000000000
VSD:                 n/a
PSID:                MT_1270110020
[admin@sx6012 ~]# mst status
MST modules:
------------
    MST PCI module loaded
    MST PCI configuration module loaded

MST devices:
------------
/dev/mst/dev-i2c-0               - Embedded I2C master
/dev/mst/dev-i2c-1               - Embedded I2C master
/dev/mst/mt51000_pciconf0        - PCI configuration cycles access.
                                   domain:bus:dev.fn=0001:81:00.0 addr.reg=88 data.reg=92
                                   Chip revision is: 02
st/mst/mt51000_pciconf0 -i /opt/sth/new/MSX6012.bin bcache_replacement -d /dev/m

-W- Firmware flash cache access is enabled. Running in this mode may cause the firmware to hang.
-E- Cannot open Device: /dev/mst/mst/mt51000_pciconf0. No such file or directory. MFE_CR_ERROR
[admin@sx6012 ~]# mst start
Starting MST (Mellanox Software Tools) driver set
[warn] mst_pci is already loaded, skipping
[warn] mst_pciconf is already loaded, skipping
Create devices
[admin@sx6012 ~]# mst status
MST modules:
------------
    MST PCI module loaded
    MST PCI configuration module loaded

MST devices:
------------
/dev/mst/dev-i2c-0               - Embedded I2C master
/dev/mst/dev-i2c-1               - Embedded I2C master
/dev/mst/dev-i2c-2               - Embedded I2C master
/dev/mst/dev-i2c-3               - Embedded I2C master
/dev/mst/dev-i2c-4               - Embedded I2C master
/dev/mst/dev-i2c-5               - Embedded I2C master
/dev/mst/dev-i2c-6               - Embedded I2C master
/dev/mst/dev-i2c-7               - Embedded I2C master
/dev/mst/dev-i2c-8               - Embedded I2C master
/dev/mst/dev-i2c-9               - Embedded I2C master
/dev/mst/mt51000_pciconf0        - PCI configuration cycles access.
                                   domain:bus:dev.fn=0001:81:00.0 addr.reg=88 data.reg=92
                                   Chip revision is: 02
[admin@sx6012 ~]# flint -i /opt/sth/new/MSX6012.bin q
Image type:          FS2
FW Version:          9.3.8170
FW Release Date:     6.6.2016
Device ID:           51000
Description:         Node             Sys image
GUIDs:               0000000000000000 0000000000000000
Description:         Base             Switch
MACs:                    000000000000     000000000000
VSD:                 n/a
[admin@sx6012 ~]# stty columns 150
[admin@sx6012 ~]# flint -allow_psid_change -override_cache_replacement -d /dev/mst/mt51000_pciconf0 -i /opt/sth/new/MSX6012.bin b

-W- Firmware flash cache access is enabled. Running in this mode may cause the firmware to hang.

    Current FW version on flash:  9.9.1260
    New FW version:               9.3.8170

    Note: The new FW version is older than the current FW version on flash.

Do you want to continue ? (y/n) [n] : y


    You are about to replace current PSID on flash - "EMC1270110020" with a different PSID - "MT_1270110020".
    Note: It is highly recommended not to change the PSID.

Do you want to continue ? (y/n) [n] : y
Burning FS2 FW image without signatures - OK
Restoring signature                     - OK
[admin@sx6012 ~]#
Thanks everyone for the help! Due to current work, I temporarily suspend attempts to get a managed device. For now, I only need to have an infiniband switch, so I flashed the fw6005f firmware and got a working (hopefully) unmanaged switch.
 

JamesHawk

New Member
Dec 5, 2020
7
3
3
I went back in and removed the password requirement for admin and I was able to log in
Hello there,

I wonder that how could you remove the password requirement? I have tried to blank the md5 from shadow and nullok the pam.d configurations but no luck.

Thanks.
 

WeekendWarrior

Active Member
Apr 2, 2015
357
148
43
57
Would anyone be open to converting my 2x 6018s from IB into 40GBE as a paid project? I've followed this thread on and off for a couple years, and like the MacGyver aspects of the conversion, but have too many other projects already going on. I don't need anything fancy - just a simple 40GBE switch.

I would gladly pay $100 (for each switch) - possibly more - if that interests anyone. PM me if you're open to helping.

Edit: clarifying $100/switch possibly more