Beware of EMC switches sold as Mellanox SX6XXX on eBay

Necrotyr

Active Member
Jun 25, 2017
187
51
28
Denmark
Awesome, unfortunately I'm getting an error that the site can't be reached :(
Yeah about that... Had a little oopsie with my FreeNAS.

11.3 is not playing nice with my SuperMicro server, so I had to go back to 11.2-u7.

Site will be up within the hour.
 

Mithril

Active Member
Sep 13, 2019
187
43
28
Yeah about that... Had a little oopsie with my FreeNAS.

11.3 is not playing nice with my SuperMicro server, so I had to go back to 11.2-u7.

Site will be up within the hour.
Oh no :( What kind of issues? I was actually going to do the update to 11.3 this weekend or next... :-/
 

Necrotyr

Active Member
Jun 25, 2017
187
51
28
Denmark
Oh no :( What kind of issues? I was actually going to do the update to 11.3 this weekend or next... :-/
I havn't had time to look at the logs, but sufficient to say, the server keeps crashing and taking VMs down with it.

my vCenter is well and truly FUBAR.

good thing we have backups :)
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,333
2,475
113
31
fohdeesha.com
Yeah about that... Had a little oopsie with my FreeNAS.

11.3 is not playing nice with my SuperMicro server, so I had to go back to 11.2-u7.

Site will be up within the hour.
Pm me if you want actual web hosting out of our Chicago datacenter, would be more than happy to provide it especially for a guide
 

cw823

Active Member
Jan 14, 2014
338
120
43
I can pay it forward for those that just need the license generated. Thanks to a couple STH folks for walking me through the process. HP has 8010 firmware, lenovo actually has 8012 FWIW
 

Bjorn Smith

Active Member
Sep 3, 2019
421
225
43
Hi,

Quick question - I have a SX6018 and I am trying to update the software on in - I have a feeling that it might be a version that was "upgraded" from a EMC version. The reason why I think this is that when I check the serial number on mellanox, it states its a SX6012 - which is not correct, since it has 18 ports.

When I upload the new version of the OS and try to install it, it just fails:

Code:
(config) # image install image-PPC_M460EX-3.6.8008.img

% usage: /sbin/writeimage.sh -m [-u URL] [-f FILE] [-L LAYOUT_TYPE] -d /DEV/N1
             [-p PARTNAME -s SIZE] [-O LOCNAME] [-t] [-T LOCNAME]
             [-k KERNEL_TYPE] [-w HWNAME] [-I] [-r] [-z] [-y]
             [-F LOGFILE] [-v]
usage: /sbin/writeimage.sh -i [-u URL] [-f FILE] [-d /DEV/N1] -l {1,2} [-t]
             [-O LOCNAME] [-k KERNEL_TYPE] [-w HWNAME] [-I] [-r]
             [-F LOGFILE] [-v]
             [-P ID] [-b {1,2}]
Basically it seems like "image install" is calling the /sbin/writeimage.sh with wrong arguments.

Does this mean I just have to live with my switch as is? Or is there some other way I can get it updated?

Thanks
 
Last edited:

cw823

Active Member
Jan 14, 2014
338
120
43
What color is your switch? AFAIK that’s the indicator whether it’s EMC or not. I know I had to delete an old image at one point due to a space concern.

I did most of my upgrades through the webui
 

Bjorn Smith

Active Member
Sep 3, 2019
421
225
43
What color is your switch?
Its black - and I just noticed a label on the switch, which states: "switch upgraded from EMC to Mellanox OS - do not update the firmware" :)

I dont know how I could miss that.

So does that mean I am stuck with the current version on the switch?
 

Rand__

Well-Known Member
Mar 6, 2014
5,779
1,292
113
yep.
dont think anyone has created a newer version of the patched original files.
 

Renat

New Member
Jun 8, 2016
17
6
3
39
What is your current firmware?
It`s better to install 3.4.xx first, and only after 3.6.xx