ASROCK EPYCD8 - BMC Has No Dedicated Option?

IamSpartacus

Well-Known Member
Mar 14, 2016
2,274
548
113
In the BIOS for my EPYCD8 I only see that the BMC is set to Failover and there is no way to change that (it's greyed out and not configurable). Is this indended? I prefer to use dedicated for my IPMI interfaces and not failover.
 

EffrafaxOfWug

Radioactive Member
Feb 12, 2015
1,216
412
83
I had a similar bug in my X470D4U which was due to a duplicate MAC being used on both the IPMI NIC and the NCSI NIC - ASRock shipped me a util called BMCMAC to fix it, at another user's request I uploaded it here a few days back. Perhaps worth a shot?
Else I suspect you'd need to open a ticket with their support bods.
 

IamSpartacus

Well-Known Member
Mar 14, 2016
2,274
548
113
I had a similar bug in my X470D4U which was due to a duplicate MAC being used on both the IPMI NIC and the NCSI NIC - ASRock shipped me a util called BMCMAC to fix it, at another user's request I uploaded it here a few days back. Perhaps worth a shot?
Else I suspect you'd need to open a ticket with their support bods.
Thank you for this. Sounds exactly like my problem because I've also seen funny behavior between my BMC NIC and eth0. I will give this a shot.
 

IamSpartacus

Well-Known Member
Mar 14, 2016
2,274
548
113
@EffrafaxOfWug So I ran the command as you outline in your post but I just get the following output. Did you have to edit any of the files included with BMCMAC?

Code:
Get eth00 Mac Address Fail
Get eth00 Mac Address Fail
 

EffrafaxOfWug

Radioactive Member
Feb 12, 2015
1,216
412
83
I didn't edit any of the files, just used an offset of 0x40000 myself as seen in the ProgramMac.sh. Are you using the linux or the DOS version? The linux version included a supplemental file, asrripmi, which I was unable to include here due to space constraints but I've just attached an xz-compressed version to the original post.

Of course, it's also possible a newer version of the util might be required for newer motherboards depending on what magic numbers might be in play behind the scenes.
 

IamSpartacus

Well-Known Member
Mar 14, 2016
2,274
548
113
Ahh, yes I'm using Linux and I did notice that file was missing. Thank you, will try this again this evening!
 

EffrafaxOfWug

Radioactive Member
Feb 12, 2015
1,216
412
83
Yeah I wasn't sure if it was actually required or not and wasn't able to upload it just using deflate compression; hopefully adding that'll do the trick. Imagine it'll need to be made executable and if you didn't notice already the software apparently has dependencies on ipmitool and libncurses5-dev as well.

I didn't bother running any of their scripts, just executed ./BMCMAC directly as root. Hopefully it'll work this time!