Xeon E3-1240 and non-ECC RAM?

MikeFromCanada

New Member
Nov 7, 2019
2
0
1
Hi all, first post, looking for some advice on troubleshooting this issue.

I picked up one of the cheap LGA 1155 Inventec motherboards off eBay a few months ago and paired it with an old E3-1240 I had laying around.

Everything works fine when I run this setup with DDR3 ECC RAM, but when I try to run regular DDR3 UDIMMS i get 4 beeps. I get the same 4 beeps when RAM is not seated properly or when i use incompatible RAM, so I'm positive it's a RAM issue.

The DDR3 sticks I'm using are known good, and I've tried every configuration I can think of, single, dual, quad 2gb and 4gb sticks, but I always get the 4 beeps unless i'm using ECC RAM.

Is this a compatibility issue, or something else? The Xeon appears to be compatibile with UDIMMS, but I can't get it to work at all.

Any advice appreciated.
 

alex_stief

Active Member
May 31, 2016
666
211
43
35
Probably a limitation of the motherboard you are using. The CPU is compatible with non-ECC RAM.
 

Markess

Active Member
May 19, 2018
508
221
43
The issue is probably the chipset. If your board is like the Inventec 1155 board I bought, it has a C202/204 chipset. C202/204 don't work with non-ECC RAM. C206 & 216 did, but the Inventec have the lower end chipsets with less compatibility.
 

MikeFromCanada

New Member
Nov 7, 2019
2
0
1
The issue is probably the chipset. If your board is like the Inventec 1155 board I bought, it has a C202/204 chipset. C202/204 don't work with non-ECC RAM. C206 & 216 did, but the Inventec have the lower end chipsets with less compatibility.
That does make sense then. I tried an i3 2100 in the board the other day and it didn't work with the DDR3 either. I'll check the chipset when I get home and i bet it'll be one of the ones you listed.

Thanks!