Windows 10 C3 Sleep Issues

BlueFox

Well-Known Member
Oct 26, 2015
918
408
63
Spent hours on Google trying to figure this out, but alas, I've still yet to fix it. Maybe someone here has some ideas? Essentially my workstation will no longer stay in a C3 sleep state and it's quite frustrating. It will turn back on a couple seconds after entering sleep. I'm on Windows 10 Pro 1803 (build 17134.619 if it matters).

I made a recent hardware change of swapping some drives out. I went from a 1TB PM961 + 1TB 860 EVO to a ~4TB PM983. I can't see how that would affect sleep mode since I restored straight from my Veeam backup taken immediately prior to swapping the drives. Only other thing I did around that was run some Windows updates that I had been deferring for a couple weeks.

When trying to track down the culprit, powercfg always shows the following right after my computer wakes back up, but it will soon disappear. I've not been able to track down what device that might actually be referring to. I know it is not a USB device as unplugging everything makes no difference (not that I've changed anything there).
Code:
C:\WINDOWS\system32>powercfg -requests
DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
[DRIVER] Legacy Kernel Caller
Power Manager

ACTIVELOCKSCREEN:
None.
My power plan has wake timers disabled and there's nothing there that has changed anyway. Other stuff under powercfg isn't particularly helpful unfortunately:
Code:
C:\WINDOWS\system32>powercfg -lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 0

C:\WINDOWS\system32>powercfg -devicequery wake_armed
NONE
Anyone have any ideas as to why sleep mode might have stopped working for me? I can list the rest of my hardware specs if that would be helpful.
 
  • Like
Reactions: mathiastro

Dreece

Master Tinker
I have the same problem with one of my workstations... after tinkering around in the bios for other 'performance' reasons... workstation never goes to sleep now, even the screens stay on!.... definitely screwed something up.

If you figure it out, please do tell :)
 

acquacow

Well-Known Member
Feb 15, 2017
556
287
63
38
The biggest issue with my win10 systems waking up was caused by allowing windows updates to be served from my PC. There's a config option somewhere that disables it, after that, sleep worked fine.
 

BlueFox

Well-Known Member
Oct 26, 2015
918
408
63
The biggest issue with my win10 systems waking up was caused by allowing windows updates to be served from my PC. There's a config option somewhere that disables it, after that, sleep worked fine.
Looks like that is already disabled for me.
 

BlueFox

Well-Known Member
Oct 26, 2015
918
408
63
My issue was caused by my PM983 SSD. Switched to an Intel P4600 and S3 works again.