Why not support 4Kn HDD in Raid mode ,but work for HBA mode

mysy

Member
Apr 2, 2020
51
9
8
CHINA
try set a file server with 4 x 6TB SAS 4Kn HDD, it was seagate v5 SAS 12gb interface 7.2K HDD.

I try use HPE Raid card P840 and HPE ML110 Gen9 server to install OS and test the HDD, in HPE SSA software GUI, the card could fine those 4Kn SAS HDD, and show them as 4Kn group other than SAS HDD.

I run the diag from HPE SSA, it show some P840 sense feature list is 4k raid not support.
Snap15.jpg Snap16.jpg Snap17.jpg
 

Jason Antes

Active Member
Feb 28, 2020
178
56
28
Twin Cities
What's the firmware version of the p840?

*Edit: I see you've posted this to the HPE forums too and got the same question. The first place to start is there. I'm looking through the errata to see if I can see where 4k/4kn support came in but it could take a while, there's a lot to look through. I would imagine the other pushback you may get on that forum is whether these are HP/HPE "approved" drives. Will see what I can find.
 

mysy

Member
Apr 2, 2020
51
9
8
CHINA
Hi Jason,
I update the P840 and H240 to least version FW, both are v7.0.0. I use 2020.03 HPE Gen9 SPP. same version as I search from hpe version. I guess it just like that. Try use them with software Raid in someway.
 

Jason Antes

Active Member
Feb 28, 2020
178
56
28
Twin Cities
I'm not seeing anything saying they don't support RAID with those drives and have seen some questions about having them in RAID5 which isn't a good idea with the larger drives. It may be a limit on them not being drives with "HP/HPE" approved firmware, which sucks if it is.