Why does OmniOS SMB shares appear to require NIS arg in nsswitch.conf ?

AveryFreeman

ESXi + ( ILLUMOS / ZFS ) = HAPPY
Mar 17, 2017
165
19
18
39
Near Seattle
averyfreeman.com
Hi,

Not sure if this is a bug, but I was adjusting my nsswitch.conf in OmniOS installation from:

Code:
passwd: files nis ad
group:   files nis ad
to:

Code:
passwd: files ad
group:   files ad
because I couldn't edit local users' passwords as root - received error: user is in use (even though user not logged in).

I'm not using NIS, only AD, so someone in the OmniOS gitter recommended I remove the NIS tag from nsswitch.conf. That worked, and I could edit other users' passwords from the root account.

However, once I removed nis from the two lines, the SMB shares from the server were only viewable as long as I never leave the domain

If the server left the domain, when trying to re-join the domain, regardless of LMauth level, the shares were not viewable from windows clients until I re-added nis to the two lines in nsswitch.conf

What does nis have to do with AD in OmniOS SMB? I find it very confusing. svc -v nis shows nis is not enabled.

thanks :)