Where to find brocade NetworkOS image?

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.


New Member
Sep 9, 2023
So, back in March I picked up a Brocade VDX 6730 switch for my homelab. I know it's overkill, and I'm well aware that it's loud, but the 10gb enticed me. I didn't get to use it right away because I was saving up to buy the NICs and DACs for my Dells. Recently I tried getting everything up and running, but to no avail. For a while, I would get a "Flash usage out of range, switch status changed to MARGINAL" message (I did not get this message when I was first toying with it when I got it). This didn't seem to change much, except the fact that I needed to turn on ports with "no shutdown," but even still it wouldn't work. I'd plug a Dell server into it, then plug my router into it. I'd "no shutdown" both ports, and the server could not ping the default gateway, or get an address from DHCP. I tried the steps outlined in this support article from Dell, but it fixed nothing.

Now at this point, I believe I have a corrupted image on my hands. A large number of commands no longer work anymore. Commands that don't work anymore (such as "switchport") will give me an error that reads "%INFO : This command is not yet available. Please try again after sometime." According to this reddit thread, I apparently have a corrupted image.

I'd heard from these forums that a company called Extreme Networks has them, but when I attempted to make an account I was denied because I used a public domain email (outlook). I don't have a private domain email, and I'd prefer to not use my school email.

I've exhausted all other means of attempting to find an image or any other help regarding this thing. I'm about the rm -rf /* the thing and chuck out a window, but I'd prefer not to if there is any means to salvage it. Any help regarding an image or steps to repair would be appreciated. Here's a terminal capture of the boot log, as well as typing a few commands that should definitely work, but don't.