Upgrade LSI 2116IT in X10SDV-4C-7TP4F to P20

K D

Well-Known Member
Dec 24, 2016
1,439
320
83
30041
I have been trying to upgrade the firmware that is in P19 to P20 without success using the 9210-16i_it firmware. For now, I have reverted back to P19 using the firmware downloaded from supermicro's ftp site.

Can anyone provide some instructions?
 

IamSpartacus

Well-Known Member
Mar 14, 2016
2,481
628
113
I have been trying to upgrade the firmware that is in P19 to P20 without success using the 9210-16i_it firmware. For now, I have reverted back to P19 using the firmware downloaded from supermicro's ftp site.

Can anyone provide some instructions?
I had this same problem. I tried for days using the typical BIN files one uses to flash LSI cards with no success. Finally I reached out to SuperMicro support and they provided me with the necessary files (ROM) for a successful upgrade. Let me see if I can find them.

EDIT: See attached.
 

Attachments

Last edited:

K D

Well-Known Member
Dec 24, 2016
1,439
320
83
30041
@Patrick : Did not save the exact errors. Should have but was multi tasking. The process failed with Fault Code 0A. After that sas2flash.efi gave an error about a missing firmware for every command. Finally booted into freedos and updated with the SM default drivers.

@IamSpartacus : Thanks. I will try this out tomorrow. Just shutdown for the day. Have to finish a few work related items.
 

IamSpartacus

Well-Known Member
Mar 14, 2016
2,481
628
113
@Patrick : Did not save the exact errors. Should have but was multi tasking. The process failed with Fault Code 0A. After that sas2flash.efi gave an error about a missing firmware for every command. Finally booted into freedos and updated with the SM default drivers.

@IamSpartacus : Thanks. I will try this out tomorrow. Just shutdown for the day. Have to finish a few work related items.
I have no doubt it will work. The errors you're describing are exactly what I was getting before I tried the files SM provided.
 

K D

Well-Known Member
Dec 24, 2016
1,439
320
83
30041
I had started out a large file transfer to the system and that is still running. Another 26 hours to go. Waiting for it to complete before I can reboot the host to apply the firmware update.
 

i-void-warranties

New Member
Nov 15, 2012
5
0
1
Will this work for any SuperMicro motherboard with the LSI2116-IT HBA? Is there an article that outlines the upgrade process?
 

anomaly

Active Member
Jan 8, 2018
230
46
28
I'm having issues with 4.15.0-34-generic Ubuntu system detecting the HBA over here. The controller is enabled and I can see and access the BIOS during boot, but lspci shows no love. I might try upgrading.
 

anomaly

Active Member
Jan 8, 2018
230
46
28
Any actually important changes between P19 and P20? For SAS3 and SATA drives... I recently downgraded with the official fw from Supermicro and it's running perfectly fine with MSX interrupts and what not, 5.4 and up (as in Linux kernel).
 

ttvd

New Member
Jan 9, 2021
4
1
3
Canada
I recently picked up a new X10SDV-4C-7TP4F which spent last 6 years sitting somewhere on a shelf (came with a dead CMOS battery) and ran into this issue while trying to update the old P19 firmware. I tried updating using official Broadcom 9201-16i firmware to P20, but that didn't work (I am guessing due to vendor differences - card flashed fine, but it just did not show up for me afterwards and stopped showing up in the BIOS). Using the P20 Supermicro firmware posted by @IamSpartacus above worked just fine though.