Topton Jasper Lake Quad i225V Mini PC Report

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Stovar

Active Member
Dec 27, 2022
180
88
28
I have the same tvi7309x, I've bought Wallys MT7915 https://www.aliexpress.com/item/1005004992184544.html for ESXi8+OpenWRT and it works well with high speeds. I've just removed wifi chipset radiator and cool it with fan. Also I've made a custom cover instead of factory, suitable for this fan. There are a photos
I found out about the WLAN module via the openWRT forum, but unfortunately my country is not listed as a destination country.

Which BIOS version do you have?

Have you set any special settings or is it running with default values?

What RAM modules have you installed in the mini pc and what kind of SSD do you use?

I calculated with too little hardware myself and will buy a 1TB SSD and 32GB RAM if I get a good offer.

@VLMT and @merseburger just a quick question, did you guys have to do any magic to make you wallytech wifi card work with these cwwk/topton mini routers?

I have 3 different mini routers, 2x cwwk 6 port nic ones and also a new topton 6port router, but the Wallys MT7915 wifi card does not get detected at all once its in the mini pcie slot on any of these 3 mini routers, and 2 are brand new.

I have the MT7915/e firmware and driver installed in openwrtx86 also and rebooted it and no detection, also windows 10 and windows 11 no missing pci devices or anything under device manager.

I know the wallytech cards fine since I can plug it into an older Asrock motherboard desktop Pc and it gets detected fine in windows or openwrt.

I did try enabling every pci express bios option, even flashed to latest bioses but no luck with the card getting detected still.

Any magic you guys performed to get it to detect it?
 

oneplane

Well-Known Member
Jul 23, 2021
848
485
63
The card doesn't need drivers or firmware to be detected, basic PCIe detection has some universal primitives that work as long as the link can get established.

It's possible that the card needs something that's not available on the mini PCIe slot, like a dedicated clock or interrupt line, some specific PCIe revision or maybe it needs to draw more power than the slot can supply (all hypothetical). I do know that some of the CWWK boards have multiple slots that share some clocks and as soon as you plug in two devices that both need it, it doesn't work for one or both of them. You could try with just the PCIe card plugged in and nothing else, and then boot from USB and do an lspci from there. Also check if the card gets warm, it should at least get power to run the embedded cores.
 
  • Like
Reactions: Stovar

Stovar

Active Member
Dec 27, 2022
180
88
28
The card doesn't need drivers or firmware to be detected, basic PCIe detection has some universal primitives that work as long as the link can get established.

It's possible that the card needs something that's not available on the mini PCIe slot, like a dedicated clock or interrupt line, some specific PCIe revision or maybe it needs to draw more power than the slot can supply (all hypothetical). I do know that some of the CWWK boards have multiple slots that share some clocks and as soon as you plug in two devices that both need it, it doesn't work for one or both of them. You could try with just the PCIe card plugged in and nothing else, and then boot from USB and do an lspci from there. Also check if the card gets warm, it should at least get power to run the embedded cores.
thanks, yeah did try this already by disabling sata ports, usb ports even and just leaving the mini pcie wireless card in the slot and booting openwrtx86 off the usb stick, lspci still shows no device. Card is warm though.

I have spoken to a few others on openwrt community and they suggest the mini pcie slot is for USB only, so it won't actually work on wireless mini pcie devices, that is their thoughts at least.

Still confusing then how others got topton units and got their wallytech wifi same model cards to work, only obvious difference is their units were 4 port and mine is 6 port, maybe an 4port nic unit has the mini pcie slot better connected and working not sure.

cwwk and topton support have no idea.
 

oneplane

Well-Known Member
Jul 23, 2021
848
485
63
thanks, yeah did try this already by disabling sata ports, usb ports even and just leaving the mini pcie wireless card in the slot and booting openwrtx86 off the usb stick, lspci still shows no device. Card is warm though.

I have spoken to a few others on openwrt community and they suggest the mini pcie slot is for USB only, so it won't actually work on wireless mini pcie devices, that is their thoughts at least.

Still confusing then how others got topton units and got their wallytech wifi same model cards to work, only obvious difference is their units were 4 port and mine is 6 port, maybe an 4port nic unit has the mini pcie slot better connected and working not sure.

cwwk and topton support have no idea.
Could be the lane width or generation in that case. The 6 port model does use lanes for the NIC chips that others can 'spend' on the mPCIe port. If the card insists on an x2 or x4 link and the slot can only do x1 for example, that would be an issue (a weird one tho). It's also possible it's not an mPCIe port at all, but considering others have SSDs running on it, it would be weird if that were the case.
 
  • Like
Reactions: Stovar

Stovar

Active Member
Dec 27, 2022
180
88
28
Could be the lane width or generation in that case. The 6 port model does use lanes for the NIC chips that others can 'spend' on the mPCIe port. If the card insists on an x2 or x4 link and the slot can only do x1 for example, that would be an issue (a weird one tho). It's also possible it's not an mPCIe port at all, but considering others have SSDs running on it, it would be weird if that were the case.
Well about 3 other openwrt guys have now mentioned that mini pcie port is for usb 3g/4g modems only and not wireless mini pci-e cards.

I can't be 100% if 4 port ethernet cwwk/topton etc routers have a working mini pcie port for actual wireless wifi cards, but I can say that my own cwwk (N5100) 6 port nic and topton (N100) 6 port nic ones don't work for any mini pcie wireless cards.

My work around was to get an: Heayzoki Mini PCIE to M.2 (NGFF) Key M Adapter, Adapter Card Mini PCIE to NGFF(M.2) Key M Network Converter for Win10/8/7/2000/ for Linux
this one

Looks like this:
71fOO27JJDL._AC_SL1500_.jpg

Was very hard to search on aliexpress, amazon and ebay, since you end up with several different slots or the smaller E wireless keys, so triple check its the right connections for your nvme port and that it supports mini pci-e wireless cards.

Looks like this now:
adaptor.jpg

I cut the end tab off where the gold circle part is with pre cut lines, with some scissors and now its screwed in and sits flush.

Not ideal to lose an nvme slot but the sata port is there and so is usb for storage.

Wireless is now working, if I do ever get an 4 nic router I will test it if it has an compatible working slot for mini pci wireless cards or if its just for usb 3g/4g modems.

Manufacturer kingnovy provided the best support in this case, confirmed the mini pcie port is designed only for usb modems or usb based wireless cards like this one:

01.jpg
 
Last edited:
  • Like
Reactions: 3nodeproblem

STLJonny

New Member
Jan 24, 2024
5
0
1
Midwest USA
Looking for info on the following unit (specifically bios update and/or any other general info I'd need to know, like bugs/issues).

Topton N6005 6x2.5gbe (think case type is considered Type A, the "supposed" best heat sink design).
1710517113210.png

Baseboard Info:
Code:
Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
        Manufacturer: MW
        Product Name: CW-N11
        Version: Default string
        Serial Number: Default string
        Asset Tag: Default string
        Features:
                Board is a hosting board
                Board is replaceable
        Location In Chassis: <BAD INDEX>
        Chassis Handle: 0x0003
        Type: Motherboard
        Contained Object Handles: 0
BIOS Info:
Code:
Handle 0x0000, DMI type 0, 26 bytes
BIOS Information
        Vendor: American Megatrends International, LLC.
        Version: 5.19
        Release Date: 10/11/2022
        Address: 0xF0000
        Runtime Size: 64 kB
        ROM Size: 8 MB
        Characteristics:
                PCI is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                BIOS ROM is socketed
                EDD is supported
                5.25"/1.2 MB floppy services are supported (int 13h)
                3.5"/720 kB floppy services are supported (int 13h)
                3.5"/2.88 MB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                ACPI is supported
                USB legacy is supported
                BIOS boot specification is supported
                Targeted content distribution is supported
                UEFI is supported
        BIOS Revision: 5.19
Ordered ~Nov 2023, received ~Dec 2023.

It's currently my pfSense router, with (1) 16gb memory stick installed in bank 0 (bank 1 unoccupied), and a 256gb NVMe (both installed by myself).

Also curious if this is the right bios update, if i were to go that route?
 
Last edited:

yahyoh

New Member
Sep 9, 2022
22
7
3
Hey guys, i have been testing opnsense & openwrt/x-wrt.
Opnsense seems always have some delays when requesting a new page, like it just feel sluggish. Sometimes pages take 2-3 secs to start loading compared to instants response form openwrt, even though both running adguard home with same upstream DNS and same block list and using stock unbound without any block list has the same issue BTW.
Also, i tried to tune opnsense install, which did not help at all (as shown below):

vm.pmap.pti=0
hw.ibrs_disable=1
hw.mds_disable=0
net.isr.maxthreads=-1
net.isr.bindthreads=1
dev.igc.(x).fc=0
net.isr.dispatch= deferred


I tried to enable RSS which did not help, it made things worse, BTW im using PPPOE connection.
At this point i think it might be either due to freebsd nature how it handel PPPOE or might be related to intel igc i226v driver?
 

lioner23

New Member
Apr 12, 2024
1
0
1
Hi,

Is anyone here experience this on their minipc? This is my first mini pc for homelab.

Unit: Anyrevo N5100 4 port i226-v
Motherboard: GF-1338NP-12
BIOS Version: GF-1338NP-12-V142

3 out of 4 NICs is not appearing on proxmox via lspci and lshw. ports has light indicator when I connect a LAN cable to it but only 1 is detected. I think I disabled some functionality when I restore the defaults in BIOS.

Any help is greatly appreciated. Thank you.
 

3nodeproblem

Member
Jun 28, 2020
49
13
8
So I got a handful of these N5105 boxes (Topton 4-port i226-v) with a single on-board SATA port each, as well as some SATA cables that came with. However, none of the power plugs fit any of the boards!

Topton is being difficult about the whole thing.
Could someone advice on which of the headers/pins are actually intended for SATA power?

There are 4 on-board 4-pin plugs:
- SW1 next to the power switch (I assume this is power switch)
- HD_PWR1 next to SATA port (this is the main candidate; what's the size/pinout?)
- FAN1 next to that (fan I guess)
- unmarked next to DC plug

I tried my luck with a few options of 4-pin fan-headers etc at a local electronics shop but none of them turned out to be the right size for the HD_PWR1 :rolleyes:

Any pointers appreciated if anyone has one of these and connected a 2.5" drive successfully.
 

MrPomeroy

New Member
Apr 20, 2024
3
5
3
It’s a JST 4pin connector with 1.25 pitch. I purchased a set on Aliexpress (link) to convert a 40x10 5v Noctua fan. PWM works like a charm now.
Hi Adrjl64,
would you please post the pin /
connection layout or a picture of your selfmade adapter? Thx a lot in advance.
 
  • Like
Reactions: Stovar

MrPomeroy

New Member
Apr 20, 2024
3
5
3
Hi Adrjl64,
would you please post the pin /
connection layout or a picture of your selfmade adapter? Thx a lot in advance.
Figured it out myself. To whom is interested, the pinout from perspective of the socket is:
------
| - -12V
| - +12V
| - Tacho
| - PWM
------

Cheers!
 

Attachments

kazh

New Member
Jan 11, 2023
4
5
3
Figured it out myself. To whom is interested, the pinout from perspective of the socket is:
------
| - -12V
| - +12V
| - Tacho
| - PWM
------

Cheers!
Thank you for the info. It was very helpful. I've found a really good company here in the UK (GPU Connect Graphics Card GPU Fan Replacements & PC Accessories) that made these for me and is now available on their store for others like me :) John @ GPU Connect worked with me over the weekend to get the right pin-outs for the header. Helpful and responsive!

Paired with a Noctua NF-S12A, it's super quiet and drops temps by 20C. Running Opnsense and system temp is holding steady in the range of 28-30C!
IMG_1123.jpeg


Topton 4Pin Fan Connector
 
  • Like
Reactions: Stovar

MrPomeroy

New Member
Apr 20, 2024
3
5
3
...I've found a really good company here in the UK (GPU Connect Graphics Card GPU Fan Replacements & PC Accessories) that made these for me and is now available on their store for others like me...
Nice to see, will help anybody not so familar with a soldering iron, although the price is pretty... let's say "exotic".
Btw. there is another (actually THE) CPU fan socket on the front side of the board (the one on the back is the system fan socket). To reach it you will have to unmount the system planar. Furthermore the space between planar and case is very limited. I had to cut out some material from the case/heatsink to have enough space for plug and wires. With that in place you get the possibility to attach two PWM controlled fans to the system (you could also connect two fans to the same socket in parallel but then only one would be controlled by PWM and tacho).

Cheers!
 
  • Like
Reactions: Stovar

Stovar

Active Member
Dec 27, 2022
180
88
28
Oddly made a post regarding those 4 pin micro fan connectors, found cwwk store sells them for $10 for 2 of them and its also universal so can work on any mini pc mainboard. Also posted how I did my wiring the easy lazy quick way, I have posted it here