Testing XenForo on STH

Discussion in 'STH Suggestions and Updates' started by Patrick, Mar 5, 2014.

  1. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,520
    Likes Received:
    4,450
    I just setup a VM with Xenforo and an archived sql dump from 9 Feb 2014. If you want to give it a spin:
    1. edit your hosts file with:
    199.195.128.136 forums.servethehome.com

    2. Go to http://forums.servethehome.com

    You will need to comment out/ delete that hosts file line to get to get back to the current forums.

    If you registered after Feb 9 you may not have an account :-/

    This is going to take some time and a few more re-dos so I will keep a log regarding when I bring the test site down on this thread.

    Interestingly enough, some folks got avatars during the first import process. I am not 100% sure why that happened just yet :)

    Also I am not hosting STHbench and other files out of the new server so there will be a few things broken until the last attempt or two.
     
    #1
  2. OBasel

    OBasel Active Member

    Joined:
    Dec 28, 2010
    Messages:
    494
    Likes Received:
    62
    Looks like canned poop TBH. I sure hope you did not spend much time trying to make that look pretty.

    I'm a fan of all that nice AJAX stuff.
     
    #2
  3. mrkrad

    mrkrad Well-Known Member

    Joined:
    Oct 13, 2012
    Messages:
    1,237
    Likes Received:
    50
    why don't you just assign a beta.forums.servethehome.com or betaforums.servethehome.com so we don't have to change our hosts file? :)
     
    #3
  4. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,520
    Likes Received:
    4,450
    For those looking at the site, it is getting updated right now with a dump as of yesterday.
     
    #4
  5. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,520
    Likes Received:
    4,450
    Update: I just updated (scary) with the 5 March 2014 database dump. Also added an easy URL http://f.servethehome.com

    Probably a week or two until I am confident enough in this one. URLs are still really messed up thanks to vBSEO.
     
    #5
  6. mrkrad

    mrkrad Well-Known Member

    Joined:
    Oct 13, 2012
    Messages:
    1,237
    Likes Received:
    50
    Seems snappier than this forum software, but gosh! the skin/color setup has to go!
     
    #6
  7. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,520
    Likes Received:
    4,450
    Here is the fun bit: It is rebuilding the search index right now so should be a bit faster. You should also be able to see some of the AJAX stuff where vB is less good.

    Still working on it but yea... that gold... will be gone. I am still learning where everything is (hence why it is a "test" site.)
     
    #7
  8. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,520
    Likes Received:
    4,450
    #8
  9. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,520
    Likes Received:
    4,450
    Note to self: the forums are big enough to need APC cache >64MB.
     
    #9
  10. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,520
    Likes Received:
    4,450
    Thank you to burr for helping test PM's and discussions related to articles/ reviews! Super awesome! It looks like Facebook integration now works also.
     
    #10
  11. burr

    burr New Member

    Joined:
    Aug 11, 2012
    Messages:
    28
    Likes Received:
    2
    No problem, just let me know if you need me to beak anything else. :D
     
    #11
  12. Jeggs101

    Jeggs101 Well-Known Member

    Joined:
    Dec 29, 2010
    Messages:
    1,466
    Likes Received:
    215
    I tried it and was able to log in. Looking better than the older one. I still don't see SSL?

    Hey just so you know the front page on that one loaded in 1.14s for me. Fast!

    btw--- are you going to keep the xf logo? or brand it with STH? Seems like the STH logo does not really work well with that blue background.
     
    #12
  13. nitrobass24

    nitrobass24 Moderator

    Joined:
    Dec 26, 2010
    Messages:
    1,081
    Likes Received:
    125
    Logged into the site last night on my Nexus 7, works pretty well. No bugs that I noticed...just going to take some getting used to Xenforo instead of VB.
     
    #13
  14. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,520
    Likes Received:
    4,450
    Thank you for looking around! Very much agreed on the getting used to bit. I have to say, a few days in and I am really liking the UI and functionality a lot. First day was not so fun but afterwards things like logically laid out admin control panels are really nice.
     
    #14
  15. TeeJayHoward

    TeeJayHoward Active Member

    Joined:
    Feb 12, 2013
    Messages:
    374
    Likes Received:
    106
    Tried it out a little bit. I enjoyed the XenForo forum. I actually think it looks nicer than the current site. There's a couple of minor things I'd need to get used to, though. I like to use Windows 7+'s "Snap to side of screen" feature a lot, and with XenForo's main page, that right-hand module takes a lot of screen estate:

    [​IMG]

    (Sorry for the large photo)

    Overall, though, it feels very snappy and responsive. The color scheme and gradient are relaxing vs. the solid colors on the existing forum. Makes the new one feel more advanced. The breadcrumbs at top and bottom are a godsend.

    All-in-all, this move has my support!
     
    #15
  16. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,520
    Likes Received:
    4,450
    Thank you for the feedback. Will see what I can do on the snap thing. I have not noticed it being an issue as much.

    I am till playing with colors a bit. The STH logo simply will not show on the blue background.

    Looks like you were able to login though. That is a good sign!
     
    #16
  17. nitrobass24

    nitrobass24 Moderator

    Joined:
    Dec 26, 2010
    Messages:
    1,081
    Likes Received:
    125
    Is there a way to move that side thing to the bottom of the page? While the stats are neat, im not sure they are all that useful to the general public.
     
    #17
  18. Patrick

    Patrick Administrator
    Staff Member

    Joined:
    Dec 21, 2010
    Messages:
    11,520
    Likes Received:
    4,450
    Will look into this. If you have a lower resolution/ width window it actually moves to the bottom automatically.

    Also, I think that gets used more as some bits are added so will take that into account also.
     
    #18
  19. TeeJayHoward

    TeeJayHoward Active Member

    Joined:
    Feb 12, 2013
    Messages:
    374
    Likes Received:
    106
    Yeah, it's not a big thing. On my home monitor, I'd never notice it. It's just the little 24" dell I have at work that's annoying, and even on that, it's plenty usable. On my iPhone, it looks great!.
     
    #19
  20. nitrobass24

    nitrobass24 Moderator

    Joined:
    Dec 26, 2010
    Messages:
    1,081
    Likes Received:
    125
    Will the new forum support tapatalk? I'm a big fan of it
     
    #20
Similar Threads: Testing XenForo
Forum Title Date
STH Suggestions and Updates Multi-Page Testing on STH Main Site May 6, 2018
STH Suggestions and Updates Need some help testing STHbench features Jun 15, 2014
STH Suggestions and Updates Request for help testing - faster main site Feb 16, 2014
STH Suggestions and Updates Hardware stress testing best practices Apr 13, 2011
STH Suggestions and Updates New CPU Testing - Chance for Input Feb 26, 2011

Share This Page