Supermicro LSI 3108 Firmware reflash

michathe

Active Member
Feb 25, 2016
128
41
28
35
Hi,


I’m in the middle of sending a Supermicro X10DRH-CT in for repair since the Onboard SAS Controller died.


The Following happened:


The System lost the Raid Array under load. Controller was no longer accesible.


After a reboot i got the Message that the L2 and L3 Chache of the Controller would be Brocken and it should be replaced.


System did boot and array was Present but under Load it got dropped again.


I have tried a firmware update that failed, no i cannot recover the Controller.


Also the OS (Server 2016) does not boot anymore only if i disable the Controller by the Jumper.


I have tried:


Megacli under Dos, LSI Preeboot toll and Storclie under EFIshell all of them hangs the system whem I try to execute them.


i have also tried this ISO from Severian of course witch the Firmware for my Controller:


Is there a way to restore an LSI 2208 after firmware update failure?


Megarec find the Controller and tries to reflash it but it fails at the Validation point.


Maybe someone has a clue how to get this Controller back to life. Would be nice so get the system up and running again and not wait 5weeks for the repair.

:(