[SOLVED]I Got an HP ProLiant DL160 G5 and its not detecting any fans.

Tha_14

Server Newbie
Mar 9, 2017
72
10
8
Sorry if this thread is in the wrong section.
So I've got myself an HP SE1210 Motherboard a while ago from ebay(together with the pci-e 2 riser card) and I've been struggling ever since to make the fans work(I have 5 fans plugged in to the motherboard, 2 are 3-pin fans and the rest are 4-pin fans. Of course these are not stock fans.) when I plug in the PCI-E Riser Card(#2 Slot).

The moment I plug the riser card( https://cdn.img42.com/807dae940e7464e0ebdf6bcb9acbf1a2.jpeg ) and boot I get the "BMC updating... Please Do Not Shutdown or PowerCycle system!" message and when that is done it shuts itself down.

I boot it up again and I get this error: https://cdn.img42.com/c0bf9b3d92e2549319544f404ec06eb6.jpeg If I boot the system without the riser card it boots up normally without complaining but in LO100 I can see that only 4 fans are being detected: https://cdn.img42.com/b605504fe91f91d8c13080fa1695e3f2.png I understand why it's happening(Installing a PCI-E card will demand more power hence why the full extend of fans are needed.) but what bothers me is why am I getting a message that all fans are missing(Obviously I need the original hp redundant fans to make this work) but I don't know the correct way to mod the connectors in order to pass the TACHI2 PWM signal check.

BMC/iLO/LO100 is updated to the latest version available, as well as the system firmware(BIOS?). I have tried to use the jumpers on the motherboard but to no luck(maybe I'm doing this wrong?) The idea is to turn this into a workstation(Please don't start commenting on this matter.).

Any advice is welcome. Thank you in advance
 

Tha_14

Server Newbie
Mar 9, 2017
72
10
8
I assume I can bump my thread for hopes that someone who knows how to bypass fan check can see it.
 

Tha_14

Server Newbie
Mar 9, 2017
72
10
8
UPDATE! I seem to have found the solution to this problem, I will post pictures and diagrams for this solution later today.
 

Tha_14

Server Newbie
Mar 9, 2017
72
10
8
So turns out you have to short Pin 5 with Pin 3 of each fan connector because the system tries to read 2 rotors for each connector which in total is 12 fans. After shorting these out I managed to boot the system and read in IPMI a total of 12 rotors. I am now facing another issue which is getting a graphics card to work with this system. I am using a 16x to 16x riser card(from ebay, was cheap) but so far the gpu is not being detected. Could be that the 16x to 16x riser card is of bad quality but I will keep troubleshooting.
 

Diavuno

Active Member
HP is a pain the the rear when using no HP parts...

But they do make a quality machine.

Test the riser and card in another machine if you can.
Then check the BIOS, some BIOS can disable PCI gfx.
If you see anything regarding interrupt 19 make sure its allowed or on.
I had an old quarto that needed that to be detected.

Sent from my 0PJA2 using Tapatalk
 

Tha_14

Server Newbie
Mar 9, 2017
72
10
8
HP is a pain the the rear when using no HP parts...

But they do make a quality machine.

Test the riser and card in another machine if you can.
Then check the BIOS, some BIOS can disable PCI gfx.
If you see anything regarding interrupt 19 make sure its allowed or on.
I had an old quarto that needed that to be detected.

Sent from my 0PJA2 using Tapatalk
Thanks for the tip. I t was indeed the riser card, it seems to make a bad connection with the GPUs I have at hand, I will order a new one now :)