Serveraid M5210 installing ESX 6.7 problem

otaehryn

New Member
Aug 7, 2020
2
0
1
I'm building an ESX with Supermicro X9SCM-F, Xeon, ECC.

I have IBM Serveraid M5210 and plan to reuse WD Gold 4TB drives. Serveraid came in sealed bag and has no memory and battery modules. I plan to just use RAID 1 arrays with 2 drives for data stores.

I bought the card since it has good features and is supported by both ESX and FreeNAS

I've had problems with ESX 6.7 see drives:
After assembling motherboard I initially installed Centos 8 which saw controller and random 500GB drive attached to controller
When I installed ESX 6.7 U3 it would not see the card. I searched and installed driver which resulted in magenta screen PF Exception

When I tried controller in 2016 server it would not start - I assume it's because non-IBM motherboard

I updated firmware using Centos to IBM firmware v24.21.0-0126 from April 2020. I then tried different drivers (for FW 24.21.0-0067) which again resulted in violet screen.

Should I flash this to AVAGO/LSI firmware?
If so which?

Also there was no prompt to create arrays - I guess this integrates with IBM server BIOS.

Any help appreciated.
 

RTM

Active Member
Jan 26, 2014
566
202
43
I have a couple of those controllers, generally speaking they work fine in non IBM/Lenovo systems.
That said, I have had issues with them on an older Asus motherboard (firmware update failed, had to use a different machine to reflash the firmware after which it worked "fine" in the Asus machine).

There should be a separate BIOS for it (though I don't remember if it is configured through regular BIOS or prompt on boot), so the fact that you are not seeing it may be part of the reason why you are having issues.
Have you configured the motherboard to load option ROM's?

I am not aware of any options as far as crossflashing to LSI firmware goes, I believe part of the problem is that it is based on the SAS3108 controller, so crossflashing to a SAS3008 firmware is supposedly out of the question (though if someone figures something out I would be interested).
 

otaehryn

New Member
Aug 7, 2020
2
0
1
Solved the install, now need to figure out monitoring.

The reason for failure was that I thought since firmware is 24 something I installed earlier vib driver. Also I didn't see that RAID configuration is now in UEFI under Advanced, so I thought something was off when no Press CTRL+ was shown in BIOS.

With latest vib driver it works:

This firmware
BIOS and Firmware Update for ServeRAID M5200 Series SAS/SATA Controllers v24.21.0-0126 for Linux - IBM System x

I used Centos 7 to install firmware
works with (latest as of writing)
lsi_mr3 version 7.713.07.00-1OEM 4.680.00-8519

Now I need to enable figure out if drive monitoring can be enabled.

The Small Footprint CIM Broker Daemon (SFCBD) is running, but no data has been reported. You may need to install a CIM provider for your storage adapter.

The
MR 6.14
Version:
00.66.V0.02
File Size:
15157 KB
from MegaRAID SAS 9361-8i

works, I simulated drive failure and it showed degraded in ESX
 
Last edited: