SAS2 expanders $60 (IBM, LSI chip, Intel alternative)

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

clubman

New Member
Sep 15, 2019
5
4
3
Also thinking of getting another one, and see if I can get the Intel firmware to work on it. Unless anyone has already tried this?
 
  • Like
Reactions: TvdH

BestGear

Member
Aug 25, 2014
59
3
8
44
UPDATE: Fixed it - stupidly, when I transferred the firmware over to the Ubuntu box (FTP), I did not set binary mode - did so, and all ok!



*********************************************
Hi Guys

No point in letting a good thread die, now is there!??!

Trying to flash one of these expanders and have sg_write_buffer fail. SG Version is 1.28 20180628.

Please see attached screenshot.flash.JPG

Anyone have and idea why?

Expander is on a 9201, and works fine. Zero drives attached to the 9201 or expander when trying to flash.

Using Ubuntu live.


Thanks in advance.
 
Last edited:

SonicCube

New Member
Feb 13, 2022
1
4
3
Thank you everyone for those great tutorials. Unfortunately my Linux live usb stick wasn't working as expected.
So, after digging around. I found the solution to update it in Windows(or PE)

1. Make sure driver for the HBA is working correctly in Windows.
2. Download sg3_utils for Windows port.
3. Open CMD as administrator
4. Get device id of the SAS Expander from running >sg_scan -b -s ( You will get something like SCSI2:0,8,0 for the actual device ID)
You can also find current firmware version here.
5. Run >sg_write_buffer --mode=14 --in=dl-634a.rd2 SCSI2:0,8,0
6. After completion, run again above cmd with mode=15 and without the --in
7. Rescan with sg_scan, you should see the new firmware version.

dmc_offs_defer = 0x0E =14
activate_mc = 0x0F = 15
 

pld

New Member
Feb 14, 2022
13
0
1
Hi there,

I have a stupid question, maybe very stupid. If I'm not wrong, IBM 46M0997 and Lenovo 03X3834 use the same chipset. Did someone try to crossflash between IBM 46M0997 and Lenovo 03X3834 (any direction)? What would be potential benefits?
 

BackupProphet

Well-Known Member
Jul 2, 2014
1,112
695
113
Stavanger, Norway
olavgg.com
I have upgraded the firmware on the IBM 46M0997, I think it fixed the disk ordering or something. Don't remember, but there is a thread here on STH about it somewhere.
The standard firmware should be just fine for most people, there is not much reason to upgrade the firmware.