SAS cage and AHCI unwilling

Discussion in 'RAID Controllers and Host Bus Adapters' started by unwind-protect, Jul 21, 2016.

  1. unwind-protect

    Joined:
    Mar 7, 2016
    Messages:
    119
    Likes Received:
    9
    I have this Silverstone SAS cage.
    https://www.amazon.com/gp/product/B01C5TG82C/ref=oh_aui_detailpage_o08_s00?ie=UTF8&psc=1

    It seems to work on a random non-JBOD SAS controller, but when using with AHCI SATA controllers it won't. I tried Intel onboard SATA from x58 and I tried an AHCI PCIe controller.

    In all cases both Linux and FreeBSD get into endless loops saying that a drive discovery request is already in progress. Disks are SAS.

    This should be working, no?
     
    #1
  2. ttabbal

    ttabbal Active Member

    Joined:
    Mar 10, 2016
    Messages:
    719
    Likes Received:
    193
    I don't think compatibility goes the other way. SAS controllers can run SATA disks, but SATA controllers can't run SAS.
     
    #2
    vanfawx and Terry Kennedy like this.
  3. unwind-protect

    Joined:
    Mar 7, 2016
    Messages:
    119
    Likes Received:
    9
    Strange. I was sure that I randomly poked SAS disks into SATA backed frames before. But maybe I actually didn't and they had SAS controllers.

    Waiting for more cables in the mail. Sigh.

    Thanks, ttabbal.
     
    #3
Similar Threads: cage AHCI
Forum Title Date
RAID Controllers and Host Bus Adapters PIR8 CLONE HP Gen8 drive sled cages work !! Smart Carrier Fakeys tested partially! Jul 25, 2013
RAID Controllers and Host Bus Adapters "Verifying DMI App Pool..." stuck at boot when AHCI is enabled on MB while booting from LSI 2008 Feb 9, 2015

Share This Page