Rancher server & agent on same host setup question

nthu9280

Well-Known Member
Feb 3, 2016
1,588
440
83
San Antonio, TX
noob question
I have a Ubuntu 16.04.2 LTS homelab machine. Installed Docker 17.03.1-ce & Rancher 1.6.2.

Unable to add a host even after specifying IP & different port# (8180) as described here:

Adding Custom Hosts

root@ubnt01a:~# sudo docker run -d -e CATTLE_AGENT_IP=10.16.32.195 --rm --privileged -v /var/run/docker.sock:/var/run/docker.sock -v /var/lib/rancher:/var/lib/rancher rancher/agent:v1.2.2 http://ubnt01a:8180/v1/scripts/3AEC16302BB31AD8DFDF:1483142400000:53x92rSjf6A52USiISWlrgUtDU

The agent starts and stops after few moments. Host doesn't showup in browser GUI. I'm sure I'm missing something. Rancher server runs fine and I can access via browser.
 
Last edited:

nitrobass24

Moderator
Dec 26, 2010
1,083
127
63
TX
How have you installed Rancher Server?
Also when you add the server as a host, you do not need to specify a custom IP/Port. Just copy the default command on the add-hosts page. I know it says that it wont work, but it does. FWIW I have not gotten it to work any other way.
 

Ch33rios

Member
Nov 29, 2016
100
6
18
39
I have experienced the same thing. Its confusing for sure and my frustration with it caused me to really just give up on it for now. I've been managing my small little docker setup of 5 containers on a single host just via the CLI.
 

nitrobass24

Moderator
Dec 26, 2010
1,083
127
63
TX
Yea the documentation for Rancher seems to not align well to the current release.

Lately I have had issues adding additional nodes, which should be a simple process.


Sent from my iPhone using Tapatalk