Please help!! Aruba 2390F and OPNsense

TiredTiger

New Member
Apr 16, 2021
2
0
1
Hello,

I am desperately in need of some help setting up a new Aruba 2390F with my OPNsense firewall. I am trying to setup a couple of simple vlans but im pretty confused about the process at this point. Ultimately, Id like the switch to handle the internal routing and let the supermicro box handle the firewall tasks. Right off the bat, i'll readily admit Im a noob at this stuff, so please bear with me.. I've been reading all i can but so many things are spread out all over the place and other times the scenarios only partially apply to my situation.

So a little background, about 3 months ago I purchased a used supermicro 1u short rack off of ebay and I was using that that run OPNsense. I added an additional four port intel NIC for some expandability and everything was working ok. Just recently I added the switch because I wanted inter-vlan routing to play around with servers, security cameras, seperate vlans for insecure game consoles etc. Initially everything was working ok with the default vlan, but when I tried to add the second vlan it all went south.

The firewall is setup to get Wan on igb0 and Lan on igb1. After unsucessfully trying to subnetting a 192.168.1.1 to work with the vlans, I moved on to trying a 192.168.0.0/20 so that each vlan could potentially have their own ip addresse ranges like 192.168.2.1 for vlan 2, 192.168.3.0 for vlan 3, and so on. So the currently lan side of OPNsense is 192.168.0.1/20, and I've got the igb1 lan cable going from the supermicro box to port one on the 2930f, into default vlan 1. From what I've read the primary lan on the aruba cant be deleted and its generally used as a "tranport" vlan with all the ports untagged. Im still now 100 percent sure how to correctly mark those ports, but as of now I've set the ip address on that default vlan to 192.168.0.240, and all ports are still untagged. When I tried to setup vlan 2, with an ip of 192.168.2.1/20 the switch doesnt like those settings and tells me that ip address is already in use. Im not sure if i possibly setup the intial lan incorrectly in OPNsense or maybe i didnt configure the vlan correctly. I also setup an additional gateway so the switch has a path back to the box, but that doesnt seem to be working correctly either. If anyone has any experience with these two softwares and could give me some help I would greatly appreciate it.