OS X: Can't access napp-it SMB shares from Finder sidebar

bookemdano

New Member
Jun 29, 2011
15
0
1
Hi Gea and others,

I've had this problem ever since I first set up my All-in-one NAS (ESXi->OmniOS+napp-it) a few years ago. I have AFP turned off and only SMB on. The problem is I see the name of my napp-it server in the OS X Finder under "Shared". If I click on it it shows "Not Connected" in the top bar. If I click the "Connect As" button and put in my username (set up on the OmniOS server) it accepts the credentials but I get "Connection Failed" in the top bar.

However, if I do Command-K instead and put smb://ipaddress and put in the same username and password it connects just fine.

This same thing happens on all my Macs and has been an issue since at least 10.8 (they're now all on 10.11.4). I don't think it's a DNS issue because I have no problem pinging the server by hostname. Also, my Windows PCs have no problem accessing the shares by hostname.

I don't believe this is an OmniOS/napp-it specific issue, because I found a thread on the FreeNAS forum with the exact same problem (and of course no solution posted). Direct SMB connection works, Finder left pane returns "connection failed" | FreeNAS Community

I was hopeful that updating to OmniOS 151018 would solve it due to the SMB improvements but no such luck.

It's not a huge problem but it is annoying. Do you experience this too? If not, I wonder if you could suggest any ideas of settings to check.

Thanks!
 

gea

Well-Known Member
Dec 31, 2010
2,585
878
113
DE
I suppose, there is avahi enabled (a Bonjour alike behaviour).
When you click on it, it tries to connect via AFP what fails now.

I would do a clean reinstall of OmniOS 151018.
Optionally save/restore /var/web-gui/ with napp-it settings.
 

bookemdano

New Member
Jun 29, 2011
15
0
1
I suppose, there is avahi enabled (a Bonjour alike behaviour).
When you click on it, it tries to connect via AFP what fails now.

I would do a clean reinstall of OmniOS 151018.
Optionally save/restore /var/web-gui/ with napp-it settings.
Thanks gea. I think you're right? I tried saving the login in my keychain and when I opened up keychain access the entry is listed as "afp://(hostname)._afpovertcp._tcp.local"

So avahi is enabled on my server? Is that by default or is that something I did? Do I need it?

I was hoping to avoid a re-install but if you think that's the best way to solve this I will give it a try this week sometime.
 

gea

Well-Known Member
Dec 31, 2010
2,585
878
113
DE
Avahi was part of netatalk.
It is not needed for SMB

btw
OmniOS 151018 will give a real performance improvement for Macs
You can first try an update. A reinstall is also quite uncritical
(Install OmniOS, napp-it, restorae /var/web-gui if you need napp-it settings, recreate user and import pool)
 

bookemdano

New Member
Jun 29, 2011
15
0
1
Avahi was part of netatalk.
It is not needed for SMB

btw
OmniOS 151018 will give a real performance improvement for Macs
You can first try an update. A reinstall is also quite uncritical
(Install OmniOS, napp-it, restorae /var/web-gui if you need napp-it settings, recreate user and import pool)
Thanks gea.

OK I wiped the VM and started from scratch this morning. I decided not to preserve any settings. I installed OmniOS 151018 from ISO, installed VMWare Tools, installed Napp-it 16.02f. I created my user "dan" and reimported my ZFS pools. I did not install AFP. SMB sharing is on.

So on my Macs now I do not see the napp-it VM show up under "Shared" at all. I can do Command-K and type smb://ip_address or smb://hostname and log in with my user/pw and it works.

Do I need to install AFP to get the napp-it box to show by default under "Shared" in the Finder? All of my Windows boxes on the network show there, so I thought SMB was enough to appear in that list.

I would just like to be able to select my napp-it server from the Shared list in the finder sidebar and be able to authenticate from there rather than need to command-K. Can that be done without enabling AFP?

Any ideas? Thanks.
 

gea

Well-Known Member
Dec 31, 2010
2,585
878
113
DE
You do not need netatalk as this is for AFP only

You can use Bonjour with SMB,
see OpenSolaris derived ZFS NAS/ SAN (OmniOS, OpenIndiana, Solaris and napp-it)

On Windows, you usually use a Master Browser to list all servers under network.
As Solaris does not offer a Master Browser functionality, you need one ex a Windows server
and you must enable netbios in current OmniOS (netbios_enable=true)

see napp-it menu Services > SMB > Properties
 

bookemdano

New Member
Jun 29, 2011
15
0
1
You do not need netatalk as this is for AFP only

You can use Bonjour with SMB,
see OpenSolaris derived ZFS NAS/ SAN (OmniOS, OpenIndiana, Solaris and napp-it)

On Windows, you usually use a Master Browser to list all servers under network.
As Solaris does not offer a Master Browser functionality, you need one ex a Windows server
and you must enable netbios in current OmniOS (netbios_enable=true)

see napp-it menu Services > SMB > Properties
Awesome, that is just the info I needed. I even get the little Xserve icon :D

Thank you once again gea! You are the best.
 

gea

Well-Known Member
Dec 31, 2010
2,585
878
113
DE
I have added the option to just enable Bonjour in napp-it 16.04dev (menu Services > Bonjour)
The Xserve icon for SMB under OSX instead the oldstyle Monitor icon with a Windows bluescreen is too attractive.