OmniOS r151042, Napp-IT 21.06a9 on ASROCK Deskmini X300, TLS email alerts

minimaster

New Member
Jun 10, 2022
5
1
1
Hello All,
A little NAS box with a ASROCK DeskMini X300 has been set-up with OmniOS r151042 directly installed on a SATA-SSD. After the initial OmniOS configuration napp-it 21.06a9 was installed. After reboot the steps for installing TLS email support were follwed.
  • perl -MCPAN -e shell
  • notest install Net::SSLeay
  • notest install IO::Socket::SSL
  • notest install Net::SMTP::TLS
  • exit
This ended with some makefile errors. TLS email test in NappIt failed too. This is a bit of a surprise since the same set-up process as a VM under Esxi 7.0 upd3 worked just fine.

As suggested on the nappIt TLS webpage it was attempted to install Gcc7. This failed too.


root@omnios:~# pkg install --deny-new-be developer/gcc7

pkg install: The following pattern(s) did not match any allowable packages. Try
using a different matching pattern, or refreshing publisher information:

developer/gcc7


WARNING: Errors were encountered when attempting to retrieve package
catalog information. Packages added to the affected publisher repositories since
the last retrieval may not be available.

Errors were encountered when attempting to contact repository for publisher 'omnios'.

Unable to contact valid package repository: OmniOS r151042 core
Encountered the following error(s):
Framework error: code: E_SSL_CACERT (60) reason: SSL certificate problem: cerificate is not yet valid
URL: 'OmniOS r151042 core'


Does anyone have any suggestions how to get TLS email working on this box with a direct OmniOS installation?


Error results from

  • notest install Net::SSLeay
cpan[1]> notest install Net::SSLeay
Reading '/root/.cpan/Metadata'
Database was generated on Thu, 30 Jun 2022 08:29:02 GMT
Running install for module 'Net::SSLeay'
Checksum for /root/.cpan/sources/authors/id/C/CH/CHRISN/Net-SSLeay-1.92.tar.gz ok
Scanning cache /root/.cpan/build for sizes
............................................................................DONE
'YAML' not installed, will not store persistent state
Configuring C/CH/CHRISN/Net-SSLeay-1.92.tar.gz with Makefile.PL
Do you want to run external tests?
These tests *will* *fail* if you do not have network connectivity. [n] y
*** Be sure to use the same compiler and options to compile your OpenSSL, perl,
and Net::SSLeay. Mixing and matching compilers is not supported.
*** Found OpenSSL-3.0.2 installed in /usr
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Net::SSLeay
Writing MYMETA.yml and MYMETA.json
CHRISN/Net-SSLeay-1.92.tar.gz
/usr/perl5/5.34/bin/perl Makefile.PL -- OK
Running make for C/CH/CHRISN/Net-SSLeay-1.92.tar.gz
Makefile out-of-date with respect to Makefile.PL /usr/perl5/5.34/lib/i86pc-solaris-thread-multi-64/Config.pm /usr/perl5/5.34/lib/i86pc-solaris-thread-multi-64/CORE/config.h
Cleaning current config before rebuilding Makefile...
make -f Makefile.old clean > /dev/null 2>&1
"/usr/perl5/5.34/bin/perl" Makefile.PL
Do you want to run external tests?
These tests *will* *fail* if you do not have network connectivity. [n] y
*** Be sure to use the same compiler and options to compile your OpenSSL, perl,
and Net::SSLeay. Mixing and matching compilers is not supported.
*** Found OpenSSL-3.0.2 installed in /usr
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Net::SSLeay
Writing MYMETA.yml and MYMETA.json
==> Your Makefile has been rebuilt. <==
==> Please rerun the make command. <==
false
*** Error code 255
make: Fatal error: Command failed for target `Makefile'
Current working directory /root/.cpan/build/Net-SSLeay-1.92-1
CHRISN/Net-SSLeay-1.92.tar.gz
/usr/bin/make -- NOT OK
Failed during this command:
CHRISN/Net-SSLeay-1.92.tar.gz : make NO
 
Last edited:

gea

Well-Known Member
Dec 31, 2010
2,835
992
113
DE
- To compile the needed SSL modules, you need to install a compiler, see available ones:

- The certificate error hinders an installation, most propably your local date settings are wrong
 
  • Like
Reactions: gb00s

minimaster

New Member
Jun 10, 2022
5
1
1
Solution confirmed:
Adjusted date time in the BIOS settings
With Putty logged in as root and installed compiler with
  • pkg install --deny-new-be developer/gcc7
  • pkg install --deny-new-be gnu-tar linker header-math object-file gnu-coreutils lint system/header
Then installed TLS support with
  • perl -MCPAN -e shell
  • notest install Net::SSLeay
  • notest install IO::Socket::SSL
  • notest install Net::SMTP::TLS
  • exit
Rebooted and tested TLS email in napp-it successfully.

Thx Gea.
 
  • Like
Reactions: gb00s