OmniOS now includes LX support (from Joyent/SmartOS)

gea

Well-Known Member
Dec 31, 2010
2,485
837
113
DE
Yes, a matter of philosophy.
For me, absolutely nothing relevant should be on rpool beside minimal storage services. No need for a mirror or rpool backup. On problems reinstall OS to rpool, import datapools and you are again online within 15 minutes after any crash together with a restore option of basic settings from datapool.

Not as strict as SmartOS with a readonly rpool but near to this idea with less restrictions for the global zone.
 
Last edited:
  • Like
Reactions: cperalt1

Bronko

Member
May 13, 2016
96
7
8
101
I understand and fully agree on virtualized storage environments, as you have them without exception, if I remember right from a another thread here on this forum.
I cam from Solaris on SPARC and don't like the idea to have some other OS layers (ex. ESXi) between the hardware and Solaris'h' in the case of a storage setup. It should be "bare metal", for me. That doesn't mean I'm skeptical about virtualisation and we all here using it in so different ways, like KVM, Xen... or containers on Docker, Zones...

Napp-it will have the chance to understand setups on /syspool/zones ?
 

gea

Well-Known Member
Dec 31, 2010
2,485
837
113
DE
A pool named syspool should not be a problem. Only on Nexenta the Systempool is named syspool. On Solaris or OmniOS it is named rpool.

Napp-it does not really care about the pool. If you want to use rpool for zones it may be enough to modify the menu /var/web-gui/data/napp-it/zfsos/21_Add-On/01_zones_setup/action.pl at line 5 to allow creating zones to any pool
- @p=split(/\t/,$zfs{'datapools'});
+ @p=split(/\t/,$zfs{'allpools'});
similar in /var/web-gui/data/napp-it/zfsos/21_Add-On/action.pl line 97
 
Last edited:
  • Like
Reactions: Bronko

Bronko

Member
May 13, 2016
96
7
8
101
Thanks @gea
syspool was a placeholder for ex. rpool: /'syspool'/zones
'allpools' will take care in every pools, fine...!
 

gea

Well-Known Member
Dec 31, 2010
2,485
837
113
DE
Found a little time to improve setup of LX zones in OmniOS (Linux container)
You must re-download napp-it free or pro from today, napp-it release remains unchanged on this minor update
You can now preconfigure network settings and mount ZFS filesystems into the VM

Setup LX in OmniOS 151020
# pkg install lx

# create a filesystem with named "zones" below your datapool
napp-it: ZFS filesystems >> create >> zones

then setup for example Ubuntu in napp-it menu Add-Ons > zones setup (select menu set 'en' in topmenu beside logout)
http://www.napp-it.org/doc/downloads/zones.pdf - see page 8
 

yu130960

Member
Sep 4, 2013
122
10
18
Canada
Does anyone have a walk through or some tips on how to set up the network for the zones? I keep getting the error message that can't use the same device as used by the global zone or something.

Is the next version going to make network setup easier?
 

gea

Well-Known Member
Dec 31, 2010
2,485
837
113
DE
You should first create a vnic that you use exclusively in an LX zone.
Then you can assign an ip, router or DNS for this vnic in the LX zone settings
 

yu130960

Member
Sep 4, 2013
122
10
18
Canada
Here is what I have done so far

1. Deploy latest OVF napp-it_2017.01_ova_with OmniOS 151020 for_ESXi_5.5u2-6.5

2. General set up of VM (make sure vmxnet3s0 is connected on power on), create pool tank, create file system /tank/zones/, update napp-it

3.
Code:
pkg install brand/lx
4.
Code:
 chmod -R 700 /tank/zones/
5. Create LX Brand Zone by picking one of the identified LX brand zones at the beginning of the drop down list and putting in my network details.

6. For some reason, I get a partial install until I re-run after install

Code:
 chmod -R 700 /tank/zones/
and then delete and reinstall the same zone.

6. Everything should work.
 
Last edited:

gea

Well-Known Member
Dec 31, 2010
2,485
837
113
DE
You cannot set network parameter currently within Linux but must preset in zone.cfg
If you create the LX zone from napp-it, you can now setup nics and mounts during creation

example
set ip-type=exclusive
add net
set physical=e1000g1
add property (name=gateway,value=“172.16.4.253“)
add property (name=ips,value=“172.16.99.99/16“)
add property (name=primary,value=“true“)
end
add attr
set name=dns-domain
set type=string
set value=example.com
end
add attr
set name=resolvers
set type=string
set value=8.8.8.8
end
see example last page in
http://www.napp-it.org/doc/downloads/zones.pdf
 
  • Like
Reactions: yu130960

gea

Well-Known Member
Dec 31, 2010
2,485
837
113
DE
Yes, you can edit the settings in an unconfigured state.

With napp-it you can unconfigure/delete (=remove from inventory) the VM in menu Add-Ons.
Then you have the option to edit settings there when you click on "edit zone.cfg".

Afterwards you can configure/attach/boot again.
 
  • Like
Reactions: yu130960

gea

Well-Known Member
Dec 31, 2010
2,485
837
113
DE
Thanks gea.

For some reason I still have not been able to get my zones to name resolve. I can ping 8.8.8.8 but can't ping google.com.

I will continue to play with it tonight, but can't see what I am missing.

EDIT: Also, in your example you have "set physical=e1000g1" should it not be "set physical=lx0"?

EDIT2: Tried every combination and can't get it to resolve. Does anyone have any commands I can run to see what is going on in the zone. Omnios resolves fine, just not in the zone.
1. You should use a link exclusively,
does not matter if its a physical or virtual nic/link

2. The DNS part in the zone.cfg is (Google DNS 8.8.8.8)

add attr
set name=resolvers
set type=string
set value=8.8.8.8
 
  • Like
Reactions: yu130960

yu130960

Member
Sep 4, 2013
122
10
18
Canada
If I was to link a physical nic, should I set it up in Omnios first with IP, routing and DNS and then config it to the zone?
Of course this means I would not have to bother with the virtual nic.
 

gea

Well-Known Member
Dec 31, 2010
2,485
837
113
DE
If you use a nic or vnic exclusively in a zone you must not use it in OmniOS, keep it unconfigured there.
 
  • Like
Reactions: yu130960

gea

Well-Known Member
Dec 31, 2010
2,485
837
113
DE
yes, a ping www.napp-it.org
on my test-VM lx-ubuntu-14.04_20150320 works for me

root@node1:/root# zlogin lx-ubuntu-14.04_20150320
[Connected to zone 'lx-ubuntu-14.04_20150320' pts/2]
Last login: Mon Jan 9 16:10:03 UTC 2017 from zone:global on pts/2
Welcome to Ubuntu 14.04 LTS (GNU/Linux 3.13.0 x86_64)

* Documentation: Official Ubuntu Documentation
__ . .
_| |_ | .-. . . .-. :--. |-
|_ _| ;| || |(.-' | | |
|__| `--' `-' `;-| `-' ' ' `-'
/ ; Instance (Ubuntu 14.04 LX Brand 20150320)
`-' Triton images

root@ubuntu-lx-brand-image-builder:~# ping www.napp-it.org
PING www.napp-it.org (188.93.13.227) 56(84) bytes of data.
64 bytes from 188.93.13.227: icmp_seq=1 ttl=51 time=16.9 ms
64 bytes from 188.93.13.227: icmp_seq=2 ttl=51 time=16.6 ms
64 bytes from 188.93.13.227: icmp_seq=3 ttl=51 time=16.7 ms
 
Last edited:
  • Like
Reactions: yu130960

yu130960

Member
Sep 4, 2013
122
10
18
Canada
Thanks for posting the above.

My mistake was setting up the non-lx container (at the bottom of the list).

Once I went with the lx-ubuntu-14.04_20150320 everything worked.

Is this a restriction as all the lx-XXXXXXXXXXX are older builds (i.e. no ubuntu 16.04 zones)?

EDIT: It seems that the only container I can get to work reliably (i.e. name resolving) is the lx-ubuntu-14.04_20150320.
 
Last edited: