No IP address on OmniOS?

altano

Active Member
Sep 3, 2011
206
64
28
Cambridge, MA
I have an OmniOS + napp-it server hosted on ESXi. It's been running fine for years. Today I lowered the memory in the system and allocated less memory to the VM and now, when it boots up, it has no IP address.

I can get into the shell from the ESXi host just fine and it looks like napp-it is starting fine and the zpool is mounting fine. It just doesn't have an IP. My OmniOS skills are lacking here and I can't figure out why. ESXi says the VM is plugged in:

1612774049264.png

But the IP address is "?":

1612774072522.png

Restarting the machine or adapter (ifconfig vmxnet3s2 down / up) doesn't do anything.

Has anyone seen anything like this? Anyone know how I might go about fixing this?
 

altano

Active Member
Sep 3, 2011
206
64
28
Cambridge, MA
I was able to add another network interface to the VM and DHCP worked with that no problem. But my SFP+ network adapter still won't work. I tried recreating the interface and that didn't help either:

Bash:
ipadm delete-if vmxnet3s2
ipadm create-if vmxnet3s2
ipadm create-addr -T dhcp vmxnet3s2/dhcp
ipadm: warning: Communication with dhcpagent timed out
 

altano

Active Member
Sep 3, 2011
206
64
28
Cambridge, MA
I tried ipadm create-addr -T static -a 192.168.0.55/24 vmxnet3s1/static and it had no errors, but I still seem to have no network connectivity.
 

altano

Active Member
Sep 3, 2011
206
64
28
Cambridge, MA
E1000 devices are sort of working. If I add a new network adapter to the VM and use E1000 instead of VMXNET3 as the adapter type, and then create-addr in OmniOS, I get a DHCP IP address. I still can't seem to access the machine via that IP though (I tried napp-it web gui and also ssh).
 

gea

Well-Known Member
Dec 31, 2010
2,649
908
113
DE
I would try
- delete and re-add vnics
- recheck ESXi network and vlan settings

If you set an ip manually you should be able to access via ip from same subnet. Optionally check/ delete default routes
 

zos

Member
Oct 27, 2013
41
20
8
I encountered a similar problem a few weeks ago. The reason was a missing default-entry in the routing table of my OmniOS-machine. Do you have a default entry in your routing-table (netstat -rn -finet)?

If not, you can recreate it entering (supposing your gateway-ip is 192.168.0.1)
route -p add default 192.168.0.1
 

altano

Active Member
Sep 3, 2011
206
64
28
Cambridge, MA
Code:
route -p add 192.168.0.1/24 192.168.0.1 
add net 192.168.0.1/24: gateway 192.168.0.1: Network is unreachable
I guess the VM can't communicate with my router, for real. I just tried to setup an Ubuntu VM on the same VMWare port group and that can't get an address over DHCP either. If I switch the Ubuntu VM over to a different port group (backed by a copper 1gbe physical NIC instead of the SFP+ port) it works perfectly.

So this isn't an issue in my OmniOS installation, it's an issue at the VMWare level. Removing RAM (and then putting it back in) broke my port group or something upstream of that. Ugh.
 

altano

Active Member
Sep 3, 2011
206
64
28
Cambridge, MA
Switching to a different SFP port on a different switch in my network fixed things. I don't know if that means I fried the SFP+ port on the first switch or if ESXi can't talk to that port anymore for some reason. I'm not going to investigate further for now since I'm decommissioning this machine. Thanks for your help @gea and @zos.