Need help reseting the password on a Cisco 3560G switch

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
Problem I'm having is I can't interrupt the boot sequence. No key combo works. I'm using Putty under Windows 10. Damn boots no matter what I input at the proper time. All of the break sequences Cisco list are for old OS versions. Apparently Hyperterminal no longer exists. There's got to b e a way to proceed using Putty. I can connect to the switch just fine. Can't interrupt the boot sequence so I can proceed with the password reset.

Any assistance greatly appreciated.

P.S. Bought the switch off eBay. Can't get the seller to respond.
 

Kal G

Active Member
Oct 29, 2014
155
42
28
40
On the 3560s, you use the physical mode button on the front of the switch.

See this page for the procedure.
 

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
On the 3560s, you use the physical mode button on the front of the switch.

See this page for the procedure.
Thanks. I've been trying everything I could find on the web all evening. The problem is, most of the commands just flat don't work. load_helper returns an error, etc., etc.......

At first the enable command worked but now it asks for a password and will except nothing I try. also, using putty, neither ctrl-brk or ctrl-C will stop it from booting. I discovered by accident that if I hold the mode switch in long enough (a loong time) it will eventually get me to the switch: prompt. But now I'm stuck at enable asking for a password. :(
 

Kal G

Active Member
Oct 29, 2014
155
42
28
40
Ok, try this:
1) Unplug the power and plug it back in
2) As soon as the SYST LED starts blinking, press and hold the [Mode] button
3) You will eventually see the following scroll across your terminal:

Using driver version 1 for media type 1
Base ethernet MAC Address: xx:xx:xx:xx:xx:xx
Xmodem file system is available.
The password-recovery mechanism is enabled.

4) After you see this, release the [Mode] button
5) This should drop you to the "switch:" prompt
6) Then enter the command "flash_init"
7) Enter the command "help" to see if "load_helper" is available on your switch, if so, enter it next, if not, don't worry about it
8) Enter the command "delete flash:config.text" and confirm when prompted
9) Enter the command "delete flash:vlan.dat" and confirm when prompted
10) Enter the command "boot"

This should boot you to a clean switch.
 
  • Like
Reactions: Evan and Fritz

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
Ok, try this:
1) Unplug the power and plug it back in
2) As soon as the SYST LED starts blinking, press and hold the [Mode] button
3) You will eventually see the following scroll across your terminal:

Using driver version 1 for media type 1
Base ethernet MAC Address: xx:xx:xx:xx:xx:xx
Xmodem file system is available.
The password-recovery mechanism is enabled.

4) After you see this, release the [Mode] button
5) This should drop you to the "switch:" prompt
6) Then enter the command "flash_init"
7) Enter the command "help" to see if "load_helper" is available on your switch, if so, enter it next, if not, don't worry about it
8) Enter the command "delete flash:config.text" and confirm when prompted
9) Enter the command "delete flash:vlan.dat" and confirm when prompted
10) Enter the command "boot"

This should boot you to a clean switch.
Thank you sir. Apparently there is no vlan.dat. Got a "No Such File or Directory" error and load_helper isn't available on this switch.

Anyway, this got me back to square one. The switch is once again pulling an ip address from the router but I still can't log into the web GUI. Neither "admin" nor "cisco" work. Any ideas?
 

Kal G

Active Member
Oct 29, 2014
155
42
28
40
The web GUI does not work unless you create a user with level 15 access.

From the CLI:
- enable
- config t
- username admin privilege 15 secret password (replace "admin" and "password" with your own)
- ip http server (this enables the service)
- ip http authentication local

Then try logging in to the web interface with the user you created.
 
  • Like
Reactions: Evan and Fritz

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
The web GUI does not work unless you create a user with level 15 access.

From the CLI:
- enable
- config t
- username admin privilege 15 secret password (replace "admin" and "password" with your own)
- ip http server (this enables the service)
- ip http authentication local

Then try logging in to the web interface with the user you created.
Thank you sir. I'm in. :)