Napp-it web gui issues

altano

Active Member
Sep 3, 2011
159
45
28
Cambridge, MA
I rebooted my OmniOS server (to change the drive configuration) and now napp-it is misbehaving. I wasn't able to access the https site on port 82 at all but the port 81 http site allowed me to get to get to the login screen but had this error:
Code:
"admin.pl 1069: background taskserver is not running or you have updated to a new version, please reboot first or your background tasks will not work"
I saw in another thread that @gea recommended running
Code:
/etc/init.d/napp-it restart
which allowed me to get further. Now the web gui loads on both https and http but has errors at the top of the page:
Code:
sh: line 1: /tmp/err.log: cannot create [Permission denied]
sh: line 1: /tmp/err.log: cannot create [Permission denied]
and the GUI isn't fully loaded (e.g. the navigation is missing):

If I manually execute
Code:
/usr/bin/bash /var/web-gui/data/napp-it/zfsos/_lib/scripts/taskserver.sh
I can see on the console that I get this error:
Code:
UX: /usr/sbin/rolemod: ERROR: Users must be modified with "usermod".

bootinit: bye
Should I just reinstall napp-it? Anyone ever see something like this and know what's going on?
 

altano

Active Member
Sep 3, 2011
159
45
28
Cambridge, MA
I reinstalled napp-it via
Code:
wget -O - www.napp-it.org/nappit | perl
and that seems to have fixed things? Hmmm.
 

gea

Well-Known Member
Dec 31, 2010
2,472
834
113
DE
It propably would have been enough to delete /tmp/err.log

In general
On problems, your best options are
- reboot a former working BE or
- re-run the napp-it installer (preserves all settings)
 

altano

Active Member
Sep 3, 2011
159
45
28
Cambridge, MA
Good to know. It's super slick that it was easy to run, runs quick, and preserved all settings, essentially acting as just a repair. Nice work as usual, @gea!