Napp-it web gui issues

Discussion in 'Solaris, Nexenta, OpenIndiana, and napp-it' started by altano, Oct 5, 2019.

  1. altano

    altano Active Member

    Joined:
    Sep 3, 2011
    Messages:
    135
    Likes Received:
    28
    I rebooted my OmniOS server (to change the drive configuration) and now napp-it is misbehaving. I wasn't able to access the https site on port 82 at all but the port 81 http site allowed me to get to get to the login screen but had this error:
    Code:
    "admin.pl 1069: background taskserver is not running or you have updated to a new version, please reboot first or your background tasks will not work"
    I saw in another thread that @gea recommended running
    Code:
    /etc/init.d/napp-it restart
    which allowed me to get further. Now the web gui loads on both https and http but has errors at the top of the page:
    Code:
    sh: line 1: /tmp/err.log: cannot create [Permission denied]
    sh: line 1: /tmp/err.log: cannot create [Permission denied]
    
    and the GUI isn't fully loaded (e.g. the navigation is missing):
    [​IMG]
    If I manually execute
    Code:
    /usr/bin/bash /var/web-gui/data/napp-it/zfsos/_lib/scripts/taskserver.sh
    I can see on the console that I get this error:
    Code:
    UX: /usr/sbin/rolemod: ERROR: Users must be modified with "usermod".
    
    bootinit: bye
    Should I just reinstall napp-it? Anyone ever see something like this and know what's going on?
     
    #1
  2. altano

    altano Active Member

    Joined:
    Sep 3, 2011
    Messages:
    135
    Likes Received:
    28
    I reinstalled napp-it via
    Code:
    wget -O - www.napp-it.org/nappit | perl
    and that seems to have fixed things? Hmmm.
     
    #2
  3. gea

    gea Well-Known Member

    Joined:
    Dec 31, 2010
    Messages:
    2,261
    Likes Received:
    750
    It propably would have been enough to delete /tmp/err.log

    In general
    On problems, your best options are
    - reboot a former working BE or
    - re-run the napp-it installer (preserves all settings)
     
    #3
  4. altano

    altano Active Member

    Joined:
    Sep 3, 2011
    Messages:
    135
    Likes Received:
    28
    Good to know. It's super slick that it was easy to run, runs quick, and preserved all settings, essentially acting as just a repair. Nice work as usual, @gea!
     
    #4
Similar Threads: Napp-it issues
Forum Title Date
Solaris, Nexenta, OpenIndiana, and napp-it Napp-IT / ESXi issues Jan 6, 2019
Solaris, Nexenta, OpenIndiana, and napp-it Napp-IT and SMB Issues Jul 30, 2017
Solaris, Nexenta, OpenIndiana, and napp-it Issues reading from my storage (Solaris, Napp-it & SMB) Oct 30, 2013
Solaris, Nexenta, OpenIndiana, and napp-it napp-it replication issues. Feb 18, 2013
Solaris, Nexenta, OpenIndiana, and napp-it napp-it and AD issues Jan 2, 2013

Share This Page