NAPP-IT log errors - too many connections

NOTORIOUS VR

Member
Nov 24, 2015
77
7
8
40
Going through the logs, not quote sure what is causing these errors - attempted a google search but didn't come up with anything about it (suppose it's a tricky search)

Code:
Jan 31 08:55:57 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (11)
Jan 31 08:56:04 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (12)
Jan 31 08:56:04 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (4)
Jan 31 08:56:04 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (11)
Jan 31 08:56:05 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (13)
Jan 31 08:56:09 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (14)
Jan 31 08:56:10 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (15)
Jan 31 08:56:10 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (4)
Jan 31 08:56:10 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (11)
Jan 31 08:56:10 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (12)
Jan 31 08:56:11 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (13)
Jan 31 08:56:19 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (14)
Jan 31 08:56:19 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (6), releasing oldest (15)
Jan 31 08:56:22 batcavefs /usr/lib/nfs/nfsd[631]: [ID 696744 daemon.warning] too many connections (5), releasing oldest (4)
 

gea

Well-Known Member
Dec 31, 2010
2,649
908
113
DE
Have not seen such logs
What you can try is to increase tcp buffers and nfs buffers/threads/servers ex in napp-it menu System > Tuning.

Especially for nics > 1G this is recommended as defaults are best for 1G networks
 

NOTORIOUS VR

Member
Nov 24, 2015
77
7
8
40
@gea I was just going to show you the appliance tuning option page I am (was?) using (your default performance one) - but it seems you have removed that feature in the latest home version of napp-it? I just updated before to your latest 19.x home version.... so I downgraded back to 18.12q but no dice, guess you locked it even for the old napp-it versions now?

That's unfortunate...
 

NOTORIOUS VR

Member
Nov 24, 2015
77
7
8
40
odd - appliance tuning always worked (for years) for me right up until now when I updated to 19.x homeversion...

Anyway here is /etc/system...

Code:
* napp-it_tuning_begin:
* set my tuning option default
* enable sata hotplug
set sata:sata_auto_online=1
* set disk timeout 15s (default 60s=0x3c)
set sd:sd_io_time=0xF
* limit arc cache (optional ex 80% of RAM)
* set zfs:zfs_arc_max=0x266666666
* enable l2arc cache for sequential data
* set zfs:l2arc_noprefetch=0
* increase NFS number of threads
set nfs:nfs3_max_threads=128
set nfs:nfs4_max_threads=128
* increase NFS read ahead count
set nfs:nfs3_nra=64
set nfs:nfs4_nra=64
* increase NFS maximum transfer size
set nfs3:max_transfer_size=1048576
set nfs4:max_transfer_size=1048576
* increase NFS logical block size
set nfs:nfs3_bsize=1048576
set nfs:nfs4_bsize=1048576
* tuning_end:
 

gea

Well-Known Member
Dec 31, 2010
2,649
908
113
DE
Man könnte noch die Anzahl der NFS Prozesse hoch setzen, z.B.

sharectl set -p lockd_servers=1024 nfs