Napp-It AIO - iSCSI not showing LU in ESXi 5.5U2

NOTORIOUS VR

Member
Nov 24, 2015
73
7
8
39
I just can't get ESXi to show the volume... I can connect to the iSCSI host, I can even "connect" to the target, but the device never shows and I get the following error in ESXi:

iSCSI discovery to 10.10.10.2 on vmhba38 failed.
The iSCSI Initiator could not establish a network
connection to the discovery address.
error
11/30/2015 1:43:36 PM
vmhost1

I can enter a static iSCSI, or do a discovery and it will find 10.10.10.2, but no device is ever found/mounted.

I've tested my settings under Comstar and I can connect just fine from my Windows Server VM, so there must be something else (again) that is causing this issue for me just like I cannot connect to NFS shares via the E1000.

Any ideas?

 

NOTORIOUS VR

Member
Nov 24, 2015
73
7
8
39
Well I know now that the issue is again is related to E1000 adapter. I removed it from OmniOS an replaced with the vmxnet3 adapter and everything started to work. So clearly my system/ESXi has big issues with each other.
 

Jon Massey

Active Member
Nov 11, 2015
340
82
28
34
Unless you've got a good reason to do otherwise, I'd always go for vmxnet3 over E1000(E)
 

Lupu

New Member
Sep 13, 2015
6
0
1
40
I see that you have associated "esxi-server" host-group with LU View, try setting it to "ALL"
 

Lupu

New Member
Sep 13, 2015
6
0
1
40
I have experienced similar issues with esxi6 and OmniOS recently where esxi would not
see any luns but other initiators (Linux,Win) would have no problems (with custom defined host-group
instead of the default "ALL")

But in my case i was running omnios on baremetal not virtualised, so my problem might not be related with yours.
 

gea

Well-Known Member
Dec 31, 2010
2,535
856
113
DE
The main reason that I am aware that hinders ESXi to see a Lun is when you use high LUN numbers >256. You can set this when you create a view.
 

AveryFreeman

ESXi + ( ILLUMOS / ZFS ) = HAPPY
Mar 17, 2017
165
19
18
39
Near Seattle
averyfreeman.com
I was having this issue, the ESXi initiator could see the iSCSI target on OmniOS, but when I'd rescan for disks it wouldn't see any new devices. I couldn't figure it out for hours. Until I finally realized I had put 'auto' in setting the LUN number with smtfadm

1592390530209.png

I decided to use napp-it for this configuration to make it very explicit.

1592390579927.png

Now ESXi finally sees my iSCSI target. Not sure why it's degraded, probably just needs to be initialized...

Moving to iSCSI from NFS for the significant write speed bump, but had put it off for years because of exactly this issue - configuration can be a real PITA.