MSI Z68MA-ED55 won't post with 10GTek x520-10-1S

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.


New Member
Sep 23, 2015
I'm currently running TrueNAS Scale on this machine. Boot is off a USB3 SSD (intel S3500 over a SATA to USB converter). I'm trying to upgrade the machine to a 10GTek X520-10-1s SFP+ dual nic (PCIE2.1x8, yes I know its oversubscribed with the 4x port, but I can still get ~80%). The motherboard fails to post with the new card. When powering up, it flashes for a second, fan quarter turns, then immediate power off. Removal of the X520 card allows the machine to boot. Initially, I suspected this was just a bios related issue (since it won't post), but there isn't a later bios for this board. This post here on STH suggests the X520 may have issues with Z68 & Z77 motherboards, being tied to memory somehow. Reducing to 16Gb resolved it for them. That doesn't seem to be working here. Anyone else with this issue?

Steps taken:
* Replaced the current I350-T4 card in PCIE4 with the X520 - initial failure to post
* Moved the X520 from PCIE4 to PCIE 1 (CPU connected, eliminating the Z68 chipset)
* Removed all ram except for DIMM1
* Removed all drives except the TrueNAS SATA to USB boot drive

CPU: 1275v2 (Ivy Bridge)
Ram: 32GB (4x8) Ballistix 1600 1.35v
PSU: Antec HCG-750 (more than overkill for this built)
PCIE 1 Empty - reserved for an HBA at a later time. Placing the 10GTek here has no change
PCIE 4 currently has an Intel I350-T4 card (PCIE 2.1x4)
BIOS E7676IMS V11.1
CPU Microcode 306A9/15
BIOS settings are pretty defaults except disabling the sound and running XMP.

Any suggestions would be great. I had planned to keep this hardware running at least for another several years before throwing it to ewaste. I had hoped the X520 would give a nice bump up to 10gb.


Active Member
Jun 6, 2021
Have you tried blocking the smbus pin on the card, with electrical tape?