Migrate Napp-It from old server to new (complete rehaul)

g0dM@n

New Member
Feb 12, 2022
21
0
1
Robocopy is fine as it can transfer Windows ntfs ACL (rsync cannot)

Ram is used for caching but caching is not filebased but based on ZFS datablocks in recsize on a read last/ read most optimazation. Perfect for random io for many users not so for media files

Beside databases or VM storage you do not want or need (mostly) sync write.
OK no SLOG then. That's good to know and makes sense. I'm throwing my VMs on an NVMe on PCIe right now and backing it up with Veeam to a ZFS share. Napp-it is also on that NVMe, so I may move it off to a SSD... I'm guessing napp-it doesn't need to be on NVMe, so putting it on SSD it can be separate from everything else in case the NVMe dies.
 

g0dM@n

New Member
Feb 12, 2022
21
0
1
Alright, I'm 95% complete with this rehaul! Two more things to complete. I haven't touched SMTP alerting just yet, but I did get my snapshot and scrub schedules all done up. Got my Veeam backups going for all of my VMs to my napp-it repo too.

Assuming the SMTP info you gave above works, this is my final issue:
Built a new plex server on ubuntu desktop and had some trouble with CIFS until I figured out it wants to use SMB version 1.0. Can I upgrade to 3.0 on Napp-It; if so, what would that entail? I assume windows clients will be just fine with a conversion, but never done something like that before. I know back in the old napp-it days when I first got started I had to enable v1.0 to get the shares to work in windows.
 

gea

Well-Known Member
Dec 31, 2010
2,810
970
113
DE
The OmniOS kernelbased SMB server supports SMB up to 3.1.1. You can limit or set a minimum SMB version in napp-it menu Services > SMB > properties.

Only SMB feature that is awaited is 256bit Ciphers support for Windows 11/Server 2022. This is ready in Illumos and should be included in next OmniOS update. As a fix if this is a problem you can start the attached regedit (reboot required) to switch to 128bit in Windows 11.

 

Attachments

Last edited:

g0dM@n

New Member
Feb 12, 2022
21
0
1
The OmniOS kernelbased SMB server supports SMB up to 3.1.1. You can limit or set a minimum SMB version in napp-it menu Services > SMB > properties.

Only SMB feature that is awaited is 156bit Ciphers support for Windows 11/Server 2022. This is ready in Illumos and should be included in next OmniOS update. As a fix if this is a problem you can start the attached regedit (reboot required) to switch to 128bit in Windows 11.

Thank you. My issue is that ubuntu would not mount unless I specified as SMB v1.0. I'm not sure if napp-it is only allowing 1.0 or I'm doing something wrong through Ubuntu. When I tried v3.0 via automount and then test with "sudo mount -a" it only works if I put v1.0 in the code, as such in /etc/fstab:
//IPaddress/shares/entertainment /media/entertainment/ cifs vers=1.0,credentials=/home/username/.plexcreds,iocharset=utf8,sec=ntlm 0 0

If I must change it in napp-it, is it this highlighted option and do I put in as 3.0 or just 3?
1645553139455.png
 

gea

Well-Known Member
Dec 31, 2010
2,810
970
113
DE
For possible max_protocol options
smbd/max_protocol: = 1,2.1, 3.0,3.02,3.11
 
Last edited:

g0dM@n

New Member
Feb 12, 2022
21
0
1
Thanks!
Do you think this is my likely problem with Ubuntu only being able to mount if I use smb v1.0? Just change minimum to 3.0 and try again? I've no idea what else this could mess with.
 

gea

Well-Known Member
Dec 31, 2010
2,810
970
113
DE
Try something like
sudo mount -t cifs -o username=User,password=**PWD**,sec=ntlmssp,vers=2. 1 //192.168.xxx.xxx/share /mnt/mountname/
 

g0dM@n

New Member
Feb 12, 2022
21
0
1
It doesn't work. It gives me a parsing error I've tried that command even with vers=1.0 and it doesn't work. I have to put it in this format:
//192.168.xx.xxx/shares/xxxxxx /media/xxxxxx/ cifs vers=1.0,credentials=/home/username/.plexcreds,iocharset=utf8,sec=ntlm 0 0

The above works like a champ. I just don't understand why I'm stuck with SMB 1.0. The above line works perfectly, but if I change it to 2.0, 2.1 or 3.0 they all don't work. This is what I get if I try anything but 1.0:
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

you mentioned max protocol, but I would have thought min_protocol is what I should adjust to force clients to only use higher versions... I guess that still may not help as Ubuntu doesn't seem to work on higher versions. I do have the latest version of Ubuntu desktop (20.04.3 LTS) on the one that's giving me a problem.

Could it be something I did wrong on the napp-it side?
I checked from a Windows 10 machine and it shows that it does connect via 3.1.1.
 
Last edited:

gea

Well-Known Member
Dec 31, 2010
2,810
970
113
DE
On OmniOS side you can only set minver and maxver for the SMB serverside protocol.