Mellanox ConnectX-2 Firmware

Blue)(Fusion

Active Member
Mar 1, 2017
130
47
28
Chicago
I'm running a few of the eBay CX2 cards. Most are showing as "HP_0F60000010" once I got mstflint to build on Void Linux.

What do I do at this point to update these cards to this firmware version - also why isn't this version available from Mellanox anymore?

I suppose it might be easiest to install the OFED software on a LiveUSB image?
 

TeleFragger

Member
Oct 26, 2016
152
20
18
49
I'm running a few of the eBay CX2 cards. Most are showing as "HP_0F60000010" once I got mstflint to build on Void Linux.

What do I do at this point to update these cards to this firmware version - also why isn't this version available from Mellanox anymore?

I suppose it might be easiest to install the OFED software on a LiveUSB image?
well this version isn't available from mellanox as this card is so old and EOL.. thus they don't spend anytime on it.

I'm not sure how to do this in Linux but in Windows, I have to install Winmst 4.35 as anything newer installs a flint version that is just too new and wont work with these cards.

my ConnectX-1 cards are HP branded and I force fed them to Mellanox 2.9.1000 and they stopped working so I had to force them back to HP 2.8. Albeit, My current ConnectX-2 card is running 2.10 and I see little need to worry about going to anything higher than the 2.8 as I am getting 10gb speeds.

does the card work with the current FW?

guess what you could do is use iperf and see if your getting 10gb

this is my ConnectX-1 card on iperf...

[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 10.4 GBytes 8.97 Gbits/sec sender
[ 4] 0.00-10.00 sec 10.4 GBytes 8.96 Gbits/sec receiver
 

Blue)(Fusion

Active Member
Mar 1, 2017
130
47
28
Chicago
I get plenty of performance with iperf3, the full 10Gbps TPC in both directions. I want to enable RoCE, however, which I understand the "hidden" firmware version has.

I'm very CPU-limited when trying to push these 10G ports, capping at about 4Gbps when transferring via rsync, scp, or Gluster. Gluster has RDMA capability which sounds promising.
 

Mistb0rn

New Member
May 17, 2019
1
0
1
So I'm trying to follow all the directions here and downloaded the FW files from the GDrive but something is missing in my Win10 Pro which fails to make the BIN file. Can anyone create the BIN file from the GDrive files for the MNPA19_A1-A2?
I get the following error in Powershell. Haven't been able to find out what that is.

PS C:\Program Files\Mellanox\WinMFT> .\mlxburn.exe -fw .\FW\fw-ConnectX2-debug.mlx -conf .\FW\MNPA19_A1-A2.ini -wrimage firmware-image.bin

-I- Generating image ...

-E- Image generation failed: -E- mic is not installed on this machine

child process exited abnormally
 

colinhd8

New Member
Jul 21, 2019
1
1
3
Yep,
I passed age 60, my memory is fading. So I write a lot of notes for myself to read later.
Otherwise, I would have to spend at least an hour to performing the same experiment again.

Version 2.9.8350 is the right one to flash,
I remembered that I got the ~ $20 MNPH29C-XTR cards to work with RDMA in a WS2016 cluster, what a joy to see that happened.
Hi @Marsh, car you share the steps how to enable rdma in ws2016?
I have done the follow steps:
1.flash the firmware to 2.10.0720
2.install windows server 2019
3.install latest winof driver from mellonax
4.follow the steps:Configure RDMA over Converged Ethernet (RoCE) / PFC on Windows Server 2019,
but i can't complete the step of Enable QoS on adapters: the command of Get-NetAdapterQos return nothing, and may be due to that, i still can't get rdma work.
BTW, the result of Get-NetAdapterRDMA shows that PFC and ETS are N/A, just like this(which posted by TeleFragger, thanks):


does it mean that this nic doesn't support pfc?(seems that pfc is required by roce)

Thanks.

=================2019/07/30=================
Finally they are working now. The key is that roce should be set to 1, see:https://community.mellanox.com/s/article/howto-configure-roce-in-windows-environment--global-pause-x

But before execute the command of Set-MlnxDriverCoreSetting, may be you should execute the follow commands:
Set-ExecutionPolicy -ExecutionPolicy Unrestricted -Scope Process
or you will get the error:
Get-MlnxDriverCoreSetting : The term 'Get-MlnxDriverCoreSetting' is not recognized as the name of a cmdlet
 
Last edited:
  • Like
Reactions: TeleFragger

nikey22

New Member
Feb 19, 2018
14
0
1
50
does the core firmware file: fw-ConnectX2-rel.mlx, contain the boot ROM that comes with these cards.
I've already dumped the .ini config information from the device, and will be joining it to the .mlx file to make the .bin, but was just curious about the ROM issue.
Thanks.
 

nikey22

New Member
Feb 19, 2018
14
0
1
50
@Mistb0rn
for me, I was getting this message after trying to burn the .mlx file with the .ini file:

.\mlxburn -fw fw-ConnectX2-rel.mlx -conf test.ini -wrimage test.bin

-I- Generating image ...
-E- File: C:/ConnectX2/test.ini, Line: 1 - Invalid syntax
-E- Image generation failed: child process exited abnormally


I noticed when I did my .ini dump, I used powershell and it was always 6kb in size; when I saw everyone else's was 3kb. The two files seemed exactly identical to me in content. So, I solved it by dumping the config file in an admin-MS-DOS prompt instead of powershell. It was finally 3kb in size and sure enough the mlxburn command was able to "fuse" the two files together into a .bin:

PS C:\ConnectX2> .\mlxburn.exe -fw .\fw-ConnectX2-rel.mlx -conf .\test.ini -wrimage test.bin
-I- Generating image ...
-I- Image generation completed successfully.
 

kendrick

New Member
Dec 23, 2012
17
3
3
Does the 2.9 firmware support sr-iov? or is that in 2.10? and does rdma and sr-iov work properly on the cx2 in linux?
 
Last edited:

Bun-Bun

New Member
Nov 25, 2019
1
0
1
Just came to share my results. Following adam_kf with my ebay purchased MNPH29C-XTR I did the following

1) download the HP firmware image as suggested by i386 (Drivers & Software - HPE Support Center.)
2) start the install and copy the folder containing "fw-ConnectX2-rel.mlx" from my %temp% folder
3) Run the following commands to a) create a fw image and b) flash the controller:

.\mlxburn.exe -fw .\fw-ConnectX2-rel.mlx -conf .\MNPH29C-XTR_A2-A4.ini -wrimage firmware-image.bin
.\mstflint.exe -d mt26448_pci_cr0 -i .\firmware-image.bin b

and it worked! Rebooted card shows up as RDMA enabled right away in 2k12R2.

Haven't done any testing yet, but so far so good.
 

sourpickel

New Member
Nov 26, 2019
1
0
1
So I've been running this card in my windows servers for over a year now and had some speed issues. May have tuned them out but now I went and put one in my desktop. I noticed my iperf could do 6.7Gbps without trying and could rarely hit 9.64. So i thought it was fine. But noticed online speed tests were giving me about 300mbit less than it should. So after some fiddeling I noticed Receive Side Scaling was enabled and disabled it. Instantly my tests were back to where they should be. IPERF is still hitting a wall and randomly goes from 6-9Gbps. Usually it runs around 6Gbps. Is RSS not enabled on the CFW we make and do I need to enable it somehow? What other settings could cause IPERF to not hit 9Gbps more consistently?
 

dan2804

New Member
Mar 23, 2020
2
0
1
I know this is an old thread now, but I was hoping someone could help me. I have the MHRH2A-XSR (MT26418) with the 2.10.720 firmware running on windows 10. Windows seems to like it when it is running in IB mode, but as soon as I set it to ETH mode, I get a code 10 device cannot start on the network adapters. I have tried several driver versions and multiple firmware's, but am unable to get this issue to go away. Do I have a dead card?