LSI Megaraid 9361-8i not detected on cold boot

Discussion in 'RAID Controllers and Host Bus Adapters' started by unknown0, Mar 4, 2016.

  1. unknown0

    unknown0 New Member

    Joined:
    Mar 4, 2016
    Messages:
    4
    Likes Received:
    0
    Hello,

    This is my setting:
    ===============
    Supermicro X10-SRA, Xeon E5-2620v3
    2x 32G DDR4 Samsung/supermicro certified
    3rd party Radeon R270 display, pci-e 3.0 (oprom only)
    Plextor SSD card PCI-e gen2 x2 (UEFI/oprom)
    LSI Megaraid 9361-8i (UEFI/oprom) + Cachevault and battery pack
    Disk on the raid card: 1x HGST 4G SAS HD and another Corsair 256G SSD
    On the onboard SATA side: 3T tohsiba desktop HDD 3T and 2x WD Red 2T

    The problem:
    ===============
    After I power off the server and disconnect the power to the PSU.
    If it is more than six hours, on the next cold boot:
    the LSI RAID card would not be detected.

    Workaround:
    ===============
    Power on the server for more than 5 minutes, then either one of below is workaround:
    a) Physically do server power off and power on; or
    b) Enter MB BIOS and load default setting; or
    c) Boot to UEFI built-in shell, type reset

    For b) and c), the server should be doing a reset reboot (different from warm boot).
    I noticed that the server would had a stopping sound, cooling fans should be stopped.
    And after about one seconds, it startup. Cooling fan start spinning and having the sound of hard disk spinning.

    Then the RAID card would be detected in POST without physically power off and then power on the server.

    What had been done:
    ===============
    I had contacted Avago/Broadcom. They only tell me that it is a mother board compatibility issue.
    Also I had tried the suggested setting: setting PCI-e 2.0, using UEFI instead of Oprom, changing PCI-e slots, disabling fast boot.

    I had contacted Supermicro. They are not able to duplicate the issue. Because they told me they did not had Cachevault and battery pack in the LAB....

    For the firmware of the LSI raid card and Supermicro MB, the firmware are upgraded to the latest one
    MR 6.10 and version 2.0 but the problem still persist.

    I had tried to remove the CV battery pack connection to the CV. After six hours, the raid card is detected on the next cold boot.

    Any ideas are welcome.

    Edit: I don't had any problem with the MB in the past three months.
    The LSI raid card is newly added on two weeks ago and had problem.
     
    #1
  2. poto

    poto Active Member

    Joined:
    May 18, 2013
    Messages:
    147
    Likes Received:
    44
    If possible, try raid card in different server motherboard and see if detected. If detected, probably is compatibility/bios setting issue, since it sounds like other pcie cards are working in motherboard. If not detected, consider re-flashing firmware and retrying. If still no luck, return or replace, depending on warranty status.
     
    #2
  3. pricklypunter

    pricklypunter Well-Known Member

    Joined:
    Nov 10, 2015
    Messages:
    1,362
    Likes Received:
    373
    Strip the board down to only essential components, perhaps even boot from a pen drive or livecd. I suspect it's either a timing issue or interrupts etc getting tangled before the bios has loaded. Once you get it reliably booting, add your other components back one at a time :)
     
    #3
  4. unknown0

    unknown0 New Member

    Joined:
    Mar 4, 2016
    Messages:
    4
    Likes Received:
    0
    The firmware is the most updated one.
    Currently I only had an old Gigabyte MATX motherboard around. I may test it when I had time.

    _____________________________________________________________________________________________________

    I had done this test. I only left MB+CPU+RAM+Display card (I also changed to use an older display card (PCI-E 2.0), it is less powerful and it should consume less power) and still no luck.
     
    #4
  5. Layla

    Layla New Member

    Joined:
    Jun 21, 2016
    Messages:
    20
    Likes Received:
    4
    #5
  6. Woodsbuggy3

    Woodsbuggy3 New Member

    Joined:
    Oct 29, 2018
    Messages:
    1
    Likes Received:
    0
    Thread seems dead but having a very similar situation. Wondering if there ever was a resolution??
     
    #6
Similar Threads: Megaraid 9361-8i
Forum Title Date
RAID Controllers and Host Bus Adapters MEGARAID SAS 9271-4I with cachevault Oct 26, 2018
RAID Controllers and Host Bus Adapters LSI MegaRAID SAS 9280-16i4e still useful? Jul 28, 2018
RAID Controllers and Host Bus Adapters X8DT6-F and second HBA MegaRaid 9240-4i ( CrossFlashing Help needed) Jul 7, 2018
RAID Controllers and Host Bus Adapters MegaRAID - how do I reimport a lost VD+CacheCade array? Feb 25, 2018
RAID Controllers and Host Bus Adapters MegaRAID M5015 - How to use non IBM drives? Feb 9, 2018

Share This Page