Looking to downgrade to netatalk 3.0.3 on napp-it / OmniOS

madison437

New Member
May 3, 2013
10
0
0
Hi,

The following is mentioned on the napp-it website:

"25.05.2013 Update to netatalk 3.0.4 via wget -O - www.napp-it.org/afp | perl (thanks to Rick for updating)
(OmniOS is currently on 3.0.3), Version 3.0.3 keeps available via updatescript afp303"

I want to downgrade to netatalk 3.0.3. I can theoretically go back to a previous boot environment, that has it, but there are several boot environments in-between 3.0.3 and 3.0.4 netatalk... i.e. other changes I've done.

There may be timestamping issues with 64-bit builds of netatalk 3.0.4, and I might be having an issue with this, so I'd like to downgrade.

If I needed to upgrade, I know that:
wget -O - www.napp-it.org/afp303 | perl

will do it. I did a "pkg uninstall netatalk", and that seemed to uninstall things, but when I ran the above command for afp303 installation, I still wound up with afp 3.0.4.

Any ideas?

Thanks,

-- madison437
 

gea

Well-Known Member
Dec 31, 2010
2,479
835
113
DE
Hi,

The following is mentioned on the napp-it website:

"25.05.2013 Update to netatalk 3.0.4 via wget -O - www.napp-it.org/afp | perl (thanks to Rick for updating)
(OmniOS is currently on 3.0.3), Version 3.0.3 keeps available via updatescript afp303"

I want to downgrade to netatalk 3.0.3. I can theoretically go back to a previous boot environment, that has it, but there are several boot environments in-between 3.0.3 and 3.0.4 netatalk... i.e. other changes I've done.

There may be timestamping issues with 64-bit builds of netatalk 3.0.4, and I might be having an issue with this, so I'd like to downgrade.

If I needed to upgrade, I know that:
wget -O - www.napp-it.org/afp303 | perl

will do it. I did a "pkg uninstall netatalk", and that seemed to uninstall things, but when I ran the above command for afp303 installation, I still wound up with afp 3.0.4.

Any ideas?

Thanks,

-- madison437
The repo at university Ulm (they maintain the OmniOS netatalk package) is only available for newest netatalk.
You may need to compile old versions yourself
 

madison437

New Member
May 3, 2013
10
0
0
Thanks, Gea, it appears that the 3.0.3 package available at Ulm (when I have a moment to try it), might do the trick:
Advanced Package Search

If I get a chance to downgrade it, I'll report back.

Best,

-- madison437