Inter-VLAN routing pegs Atom CPU to 100% in 100G Celestica Seastone DX010 L3 switch

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

DavidWJohnston

Active Member
Sep 30, 2020
242
191
43
Hi everyone, I'm wondering if any fellow homelab architects can shed some light on this. I can also help others with their DX010 configs.

I have the 32x100G DX010 switch configured with VLANs in separate VRFs, with static routes for each VLAN pair that I want to talk, and default routes pointing to my pfSense box in each VLAN. So VLAN-to-VLAN routes via the L3 switch, and everything else routes via the pfSense.

Everything "works" in a sense, but inter-VLAN performance is garbage (200Mbps) because it appears routing is happening on the little Atom CPU instead of on the ASIC.

The default routes in each VRF pass traffic at full speed to the pfSense. Port-to-port same-VLAN traffic is also full speed.

The problem is the Atom CPU is doing all the heavy lifting, instead of being done on the ASIC. My understanding is the SAI sync process pushes static routes into the ASIC to be processed there. The docs are a bit hard to read but I believe this VRF-to-VRF route is called "Route Leaking" and should be supported: Sonic VRF Support

I've tried a lot of things - I'm considering moving to EVPN-VXLAN overlay networks in the event my current strategy won't work.

Primarily I am running iperf3 between VLANs 1000 (10.41.0.0/24) and 1001 (10.41.1.0/24). pfSense interfaces are on 10.41.x.2. Switch interfaces are 10.41.x.1.

Code:
$ show ip int
Interface    Master        IPv4 address/mask    Admin/Oper    BGP Neighbor    Neighbor IP
-----------  ------------  -------------------  ------------  --------------  -------------
Loopback0                  10.1.0.1/32          up/up         N/A             N/A
Vlan1000     Vrf_Vlan1000  10.41.0.1/24         up/up         N/A             N/A
Vlan1001     Vrf_Vlan1001  10.41.1.1/24         up/up         N/A             N/A
Vlan1002     Vrf_Vlan1002  10.41.2.1/24         up/up         N/A             N/A
Vlan1008     Vrf_Vlan1008  10.41.8.1/24         up/up         N/A             N/A
docker0                    240.127.1.1/24       up/down       N/A             N/A
eth0                       192.168.2.47/24      up/up         N/A             N/A
lo                         127.0.0.1/16         up/up         N/A             N/A
Here is my routing table:

Code:
$ show ip route vrf all
:
Codes: K - kernel route, C - connected, S - static, R - RIP,
       O - OSPF, I - IS-IS, B - BGP, E - EIGRP, N - NHRP,
       T - Table, v - VNC, V - VNC-Direct, A - Babel, F - PBR,
       f - OpenFabric,
       > - selected route, * - FIB route, q - queued, r - rejected, b - backup
       t - trapped, o - offload failure

VRF Vrf_Vlan1000:
S>* 0.0.0.0/0 [1/0] via 10.41.0.2, Vlan1000, weight 1, 00:27:55
C>* 10.41.0.0/24 is directly connected, Vlan1000, 00:27:55
S>* 10.41.1.0/24 [1/0] is directly connected, Vlan1001 (vrf Vrf_Vlan1001), weight 1, 00:27:49

VRF Vrf_Vlan1001:
S>* 0.0.0.0/0 [1/0] via 10.41.1.2, Vlan1001, weight 1, 00:27:55
S>* 10.41.0.0/24 [1/0] is directly connected, Vlan1000 (vrf Vrf_Vlan1000), weight 1, 00:27:50
C>* 10.41.1.0/24 is directly connected, Vlan1001, 00:27:55
S>* 10.41.2.0/24 [1/0] is directly connected, Vlan1002 (vrf Vrf_Vlan1002), weight 1, 00:27:49

VRF Vrf_Vlan1002:
S>* 0.0.0.0/0 [1/0] via 10.41.2.2, Vlan1002, weight 1, 00:27:55
S>* 10.41.1.0/24 [1/0] is directly connected, Vlan1001 (vrf Vrf_Vlan1001), weight 1, 00:27:49
C>* 10.41.2.0/24 is directly connected, Vlan1002, 00:27:55

VRF Vrf_Vlan1008:
S>* 0.0.0.0/0 [1/0] via 10.41.8.2, Vlan1008, weight 1, 00:27:55
C>* 10.41.8.0/24 is directly connected, Vlan1008, 00:27:55

VRF default:
K>* 0.0.0.0/0 [0/0] via 192.168.2.1, eth0, 00:28:14
C>* 10.1.0.1/32 is directly connected, Loopback0, 00:28:05
C>* 192.168.2.0/24 is directly connected, eth0, 00:28:14
Here is the output of show running config from vtysh:
Code:
# show running-config
Building configuration...

Current configuration:
!
frr version 8.2.2
frr defaults traditional
hostname sonic
log syslog informational
log facility local4
agentx
no service integrated-vtysh-config
!
password zebra
enable password zebra
!
vrf Vrf_Vlan1002
 ip route 0.0.0.0/0 10.41.2.2 tag 1
 ip route 10.41.1.0/24 Vlan1001 tag 1 nexthop-vrf Vrf_Vlan1001
exit-vrf
!
vrf Vrf_Vlan1008
 ip route 0.0.0.0/0 10.41.8.2 tag 1
exit-vrf
!
vrf Vrf_Vlan1000
 ip route 0.0.0.0/0 10.41.0.2 tag 1
 ip route 10.41.1.0/24 Vlan1001 tag 1 nexthop-vrf Vrf_Vlan1001
exit-vrf
!
vrf Vrf_Vlan1001
 ip route 0.0.0.0/0 10.41.1.2 tag 1
 ip route 10.41.0.0/24 Vlan1000 tag 1 nexthop-vrf Vrf_Vlan1000
 ip route 10.41.2.0/24 Vlan1002 tag 1 nexthop-vrf Vrf_Vlan1002
exit-vrf
!
router bgp 65100
 bgp router-id 10.1.0.1
 bgp log-neighbor-changes
 no bgp ebgp-requires-policy
 no bgp default ipv4-unicast
 bgp bestpath as-path multipath-relax
 !
 address-family ipv4 unicast
  network 10.1.0.1/32
  network 10.41.0.0/24
  network 10.41.1.0/24
  network 10.41.2.0/24
  network 10.41.8.0/24
  maximum-paths 64
 exit-address-family
 !
 address-family ipv6 unicast
  maximum-paths 64
 exit-address-family
exit
!
router bgp 65100 vrf Vrf_Vlan1001
 !
 address-family ipv4 unicast
  redistribute static route-map STATIC_ROUTE_FILTER
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute static route-map STATIC_ROUTE_FILTER
 exit-address-family
exit
!
router bgp 65100 vrf Vrf_Vlan1008
 !
 address-family ipv4 unicast
  redistribute static route-map STATIC_ROUTE_FILTER
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute static route-map STATIC_ROUTE_FILTER
 exit-address-family
exit
!
router bgp 65100 vrf Vrf_Vlan1002
 !
 address-family ipv4 unicast
  redistribute static route-map STATIC_ROUTE_FILTER
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute static route-map STATIC_ROUTE_FILTER
 exit-address-family
exit
!
router bgp 65100 vrf Vrf_Vlan1000
 !
 address-family ipv4 unicast
  redistribute static route-map STATIC_ROUTE_FILTER
 exit-address-family
 !
 address-family ipv6 unicast
  redistribute static route-map STATIC_ROUTE_FILTER
 exit-address-family
exit
!
ip prefix-list PL_LoopbackV4 seq 5 permit 10.1.0.1/32
ip prefix-list LOCAL_VLAN_IPV4_PREFIX seq 5 permit 10.41.0.0/24
ip prefix-list LOCAL_VLAN_IPV4_PREFIX seq 10 permit 10.41.1.0/24
ip prefix-list LOCAL_VLAN_IPV4_PREFIX seq 15 permit 10.41.2.0/24
ip prefix-list LOCAL_VLAN_IPV4_PREFIX seq 20 permit 10.41.8.0/24
!
route-map STATIC_ROUTE_FILTER permit 10
 match tag 1
exit
!
route-map RM_SET_SRC permit 10
 set src 10.1.0.1
exit
!
ip nht resolve-via-default
!
ip protocol bgp route-map RM_SET_SRC
!
end
During iperf 3 tests, htop reveals excessive CPU usage, so the forwarding is being done on the little Atom CPU instead of in the ASIC:
1673318861630.png

Core 1 is completely maxed out. Another hint is I can see the traffic with tcpdump - Whereas ASIC traffic never hits the switch management kernel so it's not capturable.

The tcpdump output also has some interesting features:
Code:
03:39:09.259406 Ethernet116 In  IP10 (invalid)
03:39:09.259406 Bridge In  IP10 (invalid)
03:39:09.259406 Vlan1001 In  IP 10.41.1.10.19726 > 10.41.0.10.5201: Flags [S], seq 3015961303, win 65535, options [mss 8960,nop,wscale 2,nop,nop,sackOK], length 0
03:39:09.259468 Vlan1000 Out IP 10.41.1.10.19726 > 10.41.0.10.5201: Flags [S], seq 3015961303, win 65535, options [mss 8960,nop,wscale 2,nop,nop,sackOK], length 0
03:39:09.259472 Bridge Out IP13 (invalid)
03:39:09.259669 Ethernet0 In  IP2 (invalid)
03:39:09.259669 Bridge In  IP2 (invalid)
03:39:09.259669 Vlan1000 In  IP 10.41.0.10.5201 > 10.41.1.10.19726: Flags [S.], seq 943057750, ack 3015961304, win 64240, options [mss 1460,nop,nop,sackOK,nop,wscale 7], length 0
03:39:09.259698 Vlan1001 Out IP 10.41.0.10.5201 > 10.41.1.10.19726: Flags [S.], seq 943057750, ack 3015961304, win 64240, options [mss 1460,nop,nop,sackOK,nop,wscale 7], length 0
03:39:09.259700 Bridge Out IP13 (invalid)
03:39:09.259705 Ethernet116 Out IP 10.41.0.10.5201 > 10.41.1.10.19726: Flags [S.], seq 943057750, ack 3015961304, win 64240, options [mss 1460,nop,nop,sackOK,nop,wscale 7], length 0
The PCAP that is collected is very strange. This might be normal because it's intra-switch translation garbage that normally isn't seen ?
1673323059326.png

If anyone's still reading, here's some config info!
Code:
$ show version

SONiC Software Version: SONiC.202205.199801-44b661f63
Distribution: Debian 11.6
Kernel: 5.10.0-18-2-amd64
Build commit: 44b661f63
Build date: Sat Jan  7 16:23:15 UTC 2023
Built by: AzDevOps@vmss-soni0009PZ

Platform: x86_64-cel_seastone-r0
HwSKU: Seastone-DX010
ASIC: broadcom
ASIC Count: 1
Serial Number: N/A
Model Number: N/A
Hardware Revision: N/A
Uptime: 03:59:00 up 46 min,  1 user,  load average: 1.74, 1.15, 0.96
Date: Tue 10 Jan 2023 03:59:00

Docker images:
REPOSITORY                    TAG                       IMAGE ID       SIZE
docker-gbsyncd-broncos        202205.199801-44b661f63   6110b84ec470   531MB
docker-gbsyncd-broncos        latest                    6110b84ec470   531MB
docker-gbsyncd-credo          202205.199801-44b661f63   57d06616af73   502MB
docker-gbsyncd-credo          latest                    57d06616af73   502MB
docker-syncd-brcm             202205.199801-44b661f63   00f9dfd0bdec   826MB
docker-syncd-brcm             latest                    00f9dfd0bdec   826MB
docker-orchagent              202205.199801-44b661f63   67ae7ab2cd4a   518MB
docker-orchagent              latest                    67ae7ab2cd4a   518MB
docker-fpm-frr                202205.199801-44b661f63   a76f306ec716   529MB
docker-fpm-frr                latest                    a76f306ec716   529MB
docker-teamd                  202205.199801-44b661f63   7d7259936a30   499MB
docker-teamd                  latest                    7d7259936a30   499MB
docker-macsec                 latest                    026b42cec03b   501MB
docker-dhcp-relay             latest                    a5cb46198f68   492MB
docker-snmp                   202205.199801-44b661f63   fa6125846918   528MB
docker-snmp                   latest                    fa6125846918   528MB
docker-sonic-telemetry        202205.199801-44b661f63   e0e06be78e59   563MB
docker-sonic-telemetry        latest                    e0e06be78e59   563MB
docker-router-advertiser      202205.199801-44b661f63   7e903058416f   483MB
docker-router-advertiser      latest                    7e903058416f   483MB
docker-platform-monitor       202205.199801-44b661f63   4409a78cca7f   607MB
docker-platform-monitor       latest                    4409a78cca7f   607MB
docker-mux                    202205.199801-44b661f63   a9e9cf5ffb6b   532MB
docker-mux                    latest                    a9e9cf5ffb6b   532MB
docker-lldp                   202205.199801-44b661f63   b4e34f717ae4   525MB
docker-lldp                   latest                    b4e34f717ae4   525MB
docker-database               202205.199801-44b661f63   ac860b5ac1e7   483MB
docker-database               latest                    ac860b5ac1e7   483MB
docker-nat                    202205.199801-44b661f63   656d123f875a   471MB
docker-nat                    latest                    656d123f875a   471MB
docker-sflow                  202205.199801-44b661f63   ad4cb90cc15c   469MB
docker-sflow                  latest                    ad4cb90cc15c   469MB
docker-sonic-mgmt-framework   202205.199801-44b661f63   14ab878c6ea7   598MB
docker-sonic-mgmt-framework   latest                    14ab878c6ea7   598MB
Interfaces
Code:
$ show interfaces status
  Interface            Lanes    Speed    MTU    FEC    Alias    Vlan    Oper    Admin             Type    Asym PFC
-----------  ---------------  -------  -----  -----  -------  ------  ------  -------  ---------------  ----------
  Ethernet0      65,66,67,68     100G   9100     rs     Eth1   trunk      up       up  QSFP28 or later         N/A
  Ethernet4      69,70,71,72     100G   9100     rs     Eth2   trunk      up       up  QSFP28 or later         N/A
  Ethernet8      73,74,75,76     100G   9100     rs     Eth3   trunk    down       up              N/A         N/A
 Ethernet12      77,78,79,80     100G   9100     rs     Eth4   trunk    down       up              N/A         N/A
 Ethernet16               33      10G   9100     rs   Eth5/1   trunk      up       up   SFP/SFP+/SFP28         N/A
 Ethernet17               34      10G   9100     rs   Eth5/2  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet18               35      10G   9100     rs   Eth5/3  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet19               36      10G   9100     rs   Eth5/4  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet20               37      10G   9100     rs   Eth6/1   trunk      up       up   SFP/SFP+/SFP28         N/A
 Ethernet21               38      10G   9100     rs   Eth6/2  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet22               39      10G   9100     rs   Eth6/3  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet23               40      10G   9100     rs   Eth6/4  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet24               41       1G   9100     rs   Eth7/1   trunk      up       up   SFP/SFP+/SFP28         N/A
 Ethernet25               42      10G   9100     rs   Eth7/2  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet26               43      10G   9100     rs   Eth7/3  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet27               44      10G   9100     rs   Eth7/4  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet28               45      10G   9100     rs   Eth8/1   trunk      up       up   SFP/SFP+/SFP28         N/A
 Ethernet29               46      10G   9100     rs   Eth8/2  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet30               47      10G   9100     rs   Eth8/3  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet31               48      10G   9100     rs   Eth8/4  routed    down       up   SFP/SFP+/SFP28         N/A
 Ethernet32               49      25G   9100     fc   Eth9/1   trunk    down       up  QSFP28 or later         N/A
 Ethernet33               50      25G   9100     fc   Eth9/2  routed    down       up  QSFP28 or later         N/A
 Ethernet34               51      25G   9100     fc   Eth9/3  routed    down       up  QSFP28 or later         N/A
 Ethernet35               52      25G   9100     fc   Eth9/4  routed    down       up  QSFP28 or later         N/A
 Ethernet36            53,54      50G   9100     rs  Eth10/1   trunk      up       up   QSFP+ or later         N/A
 Ethernet38            55,56      50G   9100     rs  Eth10/2   trunk      up       up   QSFP+ or later         N/A
 Ethernet40      57,58,59,60     100G   9100     rs    Eth11  routed    down       up              N/A         N/A
 Ethernet44      61,62,63,64     100G   9100     rs    Eth12  routed    down       up              N/A         N/A
 Ethernet48      81,82,83,84     100G   9100     rs    Eth13  routed    down       up              N/A         N/A
 Ethernet52      85,86,87,88     100G   9100     rs    Eth14  routed    down       up  QSFP28 or later         N/A
 Ethernet56      89,90,91,92     100G   9100     rs    Eth15  routed    down       up              N/A         N/A
 Ethernet60      93,94,95,96     100G   9100     rs    Eth16  routed    down       up              N/A         N/A
 Ethernet64     97,98,99,100     100G   9100     rs    Eth17  routed    down       up              N/A         N/A
 Ethernet68  101,102,103,104     100G   9100     rs    Eth18  routed    down       up              N/A         N/A
 Ethernet72  105,106,107,108     100G   9100     rs    Eth19  routed    down       up              N/A         N/A
 Ethernet76  109,110,111,112     100G   9100     rs    Eth20  routed    down       up              N/A         N/A
 Ethernet80          1,2,3,4     100G   9100     rs    Eth21  routed    down       up  QSFP28 or later         N/A
 Ethernet84          5,6,7,8     100G   9100     rs    Eth22  routed    down       up              N/A         N/A
 Ethernet88       9,10,11,12     100G   9100     rs    Eth23  routed    down       up              N/A         N/A
 Ethernet92      13,14,15,16     100G   9100     rs    Eth24  routed    down       up              N/A         N/A
 Ethernet96      17,18,19,20     100G   9100     rs    Eth25  routed    down       up              N/A         N/A
Ethernet100      21,22,23,24     100G   9100     rs    Eth26  routed    down       up              N/A         N/A
Ethernet104      25,26,27,28     100G   9100     rs    Eth27  routed    down       up              N/A         N/A
Ethernet108      29,30,31,32     100G   9100     rs    Eth28  routed    down       up              N/A         N/A
Ethernet112              113      10G   9100     rs  Eth29/1   trunk      up       up   SFP/SFP+/SFP28         N/A
Ethernet113              114      10G   9100     rs  Eth29/2  routed    down       up   SFP/SFP+/SFP28         N/A
Ethernet114              115      10G   9100     rs  Eth29/3  routed    down       up   SFP/SFP+/SFP28         N/A
Ethernet115              116      10G   9100     rs  Eth29/4  routed    down       up   SFP/SFP+/SFP28         N/A
Ethernet116              117      10G   9100     rs  Eth30/1   trunk      up       up   SFP/SFP+/SFP28         N/A
Ethernet117              118      10G   9100     rs  Eth30/2  routed    down       up   SFP/SFP+/SFP28         N/A
Ethernet118              119      10G   9100     rs  Eth30/3  routed    down       up   SFP/SFP+/SFP28         N/A
Ethernet119              120      10G   9100     rs  Eth30/4  routed    down       up   SFP/SFP+/SFP28         N/A
Ethernet120              121      10G   9100     rs  Eth31/1  routed    down       up              N/A         N/A
Ethernet121              122      10G   9100     rs  Eth31/2  routed    down       up              N/A         N/A
Ethernet122              123      10G   9100     rs  Eth31/3  routed    down       up              N/A         N/A
Ethernet123              124      10G   9100     rs  Eth31/4  routed    down       up              N/A         N/A
Ethernet124              125      10G   9100     rs  Eth32/1  routed    down       up              N/A         N/A
Ethernet125              126      10G   9100     rs  Eth32/2  routed    down       up              N/A         N/A
Ethernet126              127      10G   9100     rs  Eth32/3  routed    down       up              N/A         N/A
Ethernet127              128      10G   9100     rs  Eth32/4  routed    down       up              N/A         N/A
/etc/sonic/config_db.json
JSON:
~$ cat /etc/sonic/config_db.json
{
    "AUTO_TECHSUPPORT": {
        "GLOBAL": {
            "available_mem_threshold": "10.0",
            "max_core_limit": "5.0",
            "max_techsupport_limit": "10.0",
            "min_available_mem": "200",
            "rate_limit_interval": "180",
            "since": "2 days ago",
            "state": "enabled"
        }
    },
    "AUTO_TECHSUPPORT_FEATURE": {
        "bgp": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "database": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "dhcp_relay": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "lldp": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "macsec": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "mgmt-framework": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "mux": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "nat": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "pmon": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "radv": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "sflow": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "snmp": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "swss": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "syncd": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "teamd": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        },
        "telemetry": {
            "available_mem_threshold": "10.0",
            "rate_limit_interval": "600",
            "state": "enabled"
        }
    },
    "BGP_DEVICE_GLOBAL": {
        "STATE": {
            "tsa_enabled": "false"
        }
    },
    "BREAKOUT_CFG": {
        "Ethernet0": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet4": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet8": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet12": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet16": {
            "brkout_mode": "4x25G[10G]"
        },
        "Ethernet20": {
            "brkout_mode": "4x25G[10G]"
        },
        "Ethernet24": {
            "brkout_mode": "4x25G[10G]"
        },
        "Ethernet28": {
            "brkout_mode": "4x25G[10G]"
        },
        "Ethernet32": {
            "brkout_mode": "4x25G[10G]"
        },
        "Ethernet36": {
            "brkout_mode": "2x50G"
        },
        "Ethernet40": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet44": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet48": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet52": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet56": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet60": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet64": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet68": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet72": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet76": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet80": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet84": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet88": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet92": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet96": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet100": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet104": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet108": {
            "brkout_mode": "1x100G[40G]"
        },
        "Ethernet112": {
            "brkout_mode": "4x25G[10G]"
        },
        "Ethernet116": {
            "brkout_mode": "4x25G[10G]"
        },
        "Ethernet120": {
            "brkout_mode": "4x25G[10G]"
        },
        "Ethernet124": {
            "brkout_mode": "4x25G[10G]"
        }
    },
    "CONSOLE_SWITCH": {
        "console_mgmt": {
            "enabled": "no"
        }
    },
    "CRM": {
        "Config": {
            "acl_counter_high_threshold": "85",
            "acl_counter_low_threshold": "70",
            "acl_counter_threshold_type": "percentage",
            "acl_entry_high_threshold": "85",
            "acl_entry_low_threshold": "70",
            "acl_entry_threshold_type": "percentage",
            "acl_group_high_threshold": "85",
            "acl_group_low_threshold": "70",
            "acl_group_threshold_type": "percentage",
            "acl_table_high_threshold": "85",
            "acl_table_low_threshold": "70",
            "acl_table_threshold_type": "percentage",
            "dnat_entry_high_threshold": "85",
            "dnat_entry_low_threshold": "70",
            "dnat_entry_threshold_type": "percentage",
            "fdb_entry_high_threshold": "85",
            "fdb_entry_low_threshold": "70",
            "fdb_entry_threshold_type": "percentage",
            "ipmc_entry_high_threshold": "85",
            "ipmc_entry_low_threshold": "70",
            "ipmc_entry_threshold_type": "percentage",
            "ipv4_neighbor_high_threshold": "85",
            "ipv4_neighbor_low_threshold": "70",
            "ipv4_neighbor_threshold_type": "percentage",
            "ipv4_nexthop_high_threshold": "85",
            "ipv4_nexthop_low_threshold": "70",
            "ipv4_nexthop_threshold_type": "percentage",
            "ipv4_route_high_threshold": "85",
            "ipv4_route_low_threshold": "70",
            "ipv4_route_threshold_type": "percentage",
            "ipv6_neighbor_high_threshold": "85",
            "ipv6_neighbor_low_threshold": "70",
            "ipv6_neighbor_threshold_type": "percentage",
            "ipv6_nexthop_high_threshold": "85",
            "ipv6_nexthop_low_threshold": "70",
            "ipv6_nexthop_threshold_type": "percentage",
            "ipv6_route_high_threshold": "85",
            "ipv6_route_low_threshold": "70",
            "ipv6_route_threshold_type": "percentage",
            "mpls_inseg_high_threshold": "85",
            "mpls_inseg_low_threshold": "70",
            "mpls_inseg_threshold_type": "percentage",
            "mpls_nexthop_high_threshold": "85",
            "mpls_nexthop_low_threshold": "70",
            "mpls_nexthop_threshold_type": "percentage",
            "nexthop_group_high_threshold": "85",
            "nexthop_group_low_threshold": "70",
            "nexthop_group_member_high_threshold": "85",
            "nexthop_group_member_low_threshold": "70",
            "nexthop_group_member_threshold_type": "percentage",
            "nexthop_group_threshold_type": "percentage",
            "polling_interval": "300",
            "snat_entry_high_threshold": "85",
            "snat_entry_low_threshold": "70",
            "snat_entry_threshold_type": "percentage"
        }
    },
    "DEVICE_METADATA": {
        "localhost": {
            "bgp_asn": "65100",
            "buffer_model": "traditional",
            "default_bgp_status": "up",
            "default_pfcwd_status": "disable",
            "hostname": "sonic",
            "hwsku": "Seastone-DX010",
            "mac": "00:e0:ec:bb:d2:79",
            "platform": "x86_64-cel_seastone-r0",
            "synchronous_mode": "enable",
            "type": "LeafRouter"
        }
    },
    "FEATURE": {
        "bgp": {
            "auto_restart": "enabled",
            "check_up_status": "false",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "database": {
            "auto_restart": "always_enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "always_enabled"
        },
        "dhcp_relay": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "set_owner": "local",
            "state": "disabled"
        },
        "lldp": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "True",
            "has_timer": "True",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "macsec": {
            "auto_restart": "enabled",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "set_owner": "local",
            "state": "disabled"
        },
        "mgmt-framework": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "True",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "mux": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "always_disabled"
        },
        "nat": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "disabled"
        },
        "pmon": {
            "auto_restart": "enabled",
            "check_up_status": "false",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "radv": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "sflow": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "disabled"
        },
        "snmp": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "True",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "swss": {
            "auto_restart": "enabled",
            "check_up_status": "false",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "syncd": {
            "auto_restart": "enabled",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "teamd": {
            "auto_restart": "enabled",
            "has_global_scope": "False",
            "has_per_asic_scope": "True",
            "has_timer": "False",
            "high_mem_alert": "disabled",
            "state": "enabled"
        },
        "telemetry": {
            "auto_restart": "enabled",
            "has_global_scope": "True",
            "has_per_asic_scope": "False",
            "has_timer": "True",
            "high_mem_alert": "disabled",
            "state": "enabled"
        }
    },
    "FLEX_COUNTER_TABLE": {
        "ACL": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "disable",
            "POLL_INTERVAL": "10000"
        },
        "BUFFER_POOL_WATERMARK": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "enable"
        },
        "PFCWD": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "enable"
        },
        "PG_DROP": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "enable"
        },
        "PG_WATERMARK": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "enable"
        },
        "PORT": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "enable"
        },
        "PORT_BUFFER_DROP": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "enable"
        },
        "QUEUE": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "enable"
        },
        "QUEUE_WATERMARK": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "enable"
        },
        "RIF": {
            "FLEX_COUNTER_DELAY_STATUS": "false",
            "FLEX_COUNTER_STATUS": "enable"
        }
    },
    "KDUMP": {
        "config": {
            "enabled": "false",
            "memory": "0M-2G:256M,2G-4G:320M,4G-8G:384M,8G-:448M",
            "num_dumps": "3"
        }
    },
    "LOOPBACK_INTERFACE": {
        "Loopback0": {},
        "Loopback0|10.1.0.1/32": {}
    },
    "PASSW_HARDENING": {
        "POLICIES": {
            "digits_class": "true",
            "expiration": "180",
            "expiration_warning": "15",
            "history_cnt": "10",
            "len_min": "8",
            "lower_class": "true",
            "reject_user_passw_match": "true",
            "special_class": "true",
            "state": "disabled",
            "upper_class": "true"
        }
    },
    "PORT": {
        "Ethernet0": {
            "admin_status": "up",
            "alias": "Eth1",
            "fec": "rs",
            "index": "1",
            "lanes": "65,66,67,68",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet4": {
            "admin_status": "up",
            "alias": "Eth2",
            "fec": "rs",
            "index": "2",
            "lanes": "69,70,71,72",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet8": {
            "admin_status": "up",
            "alias": "Eth3",
            "fec": "rs",
            "index": "3",
            "lanes": "73,74,75,76",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet12": {
            "admin_status": "up",
            "alias": "Eth4",
            "fec": "rs",
            "index": "4",
            "lanes": "77,78,79,80",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet16": {
            "admin_status": "up",
            "alias": "Eth5/1",
            "fec": "rs",
            "index": "5",
            "lanes": "33",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet17": {
            "admin_status": "up",
            "alias": "Eth5/2",
            "fec": "rs",
            "index": "5",
            "lanes": "34",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet18": {
            "admin_status": "up",
            "alias": "Eth5/3",
            "fec": "rs",
            "index": "5",
            "lanes": "35",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet19": {
            "admin_status": "up",
            "alias": "Eth5/4",
            "fec": "rs",
            "index": "5",
            "lanes": "36",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet20": {
            "admin_status": "up",
            "alias": "Eth6/1",
            "autoneg": "off",
            "fec": "rs",
            "index": "6",
            "lanes": "37",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet21": {
            "admin_status": "up",
            "alias": "Eth6/2",
            "autoneg": "off",
            "fec": "rs",
            "index": "6",
            "lanes": "38",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet22": {
            "admin_status": "up",
            "alias": "Eth6/3",
            "autoneg": "off",
            "fec": "rs",
            "index": "6",
            "lanes": "39",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet23": {
            "admin_status": "up",
            "alias": "Eth6/4",
            "autoneg": "off",
            "fec": "rs",
            "index": "6",
            "lanes": "40",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet24": {
            "admin_status": "up",
            "alias": "Eth7/1",
            "fec": "rs",
            "index": "7",
            "lanes": "41",
            "mtu": "9100",
            "speed": "1000"
        },
        "Ethernet25": {
            "admin_status": "up",
            "alias": "Eth7/2",
            "fec": "rs",
            "index": "7",
            "lanes": "42",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet26": {
            "admin_status": "up",
            "alias": "Eth7/3",
            "fec": "rs",
            "index": "7",
            "lanes": "43",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet27": {
            "admin_status": "up",
            "alias": "Eth7/4",
            "fec": "rs",
            "index": "7",
            "lanes": "44",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet28": {
            "admin_status": "up",
            "alias": "Eth8/1",
            "fec": "rs",
            "index": "8",
            "lanes": "45",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet29": {
            "admin_status": "up",
            "alias": "Eth8/2",
            "fec": "rs",
            "index": "8",
            "lanes": "46",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet30": {
            "admin_status": "up",
            "alias": "Eth8/3",
            "fec": "rs",
            "index": "8",
            "lanes": "47",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet31": {
            "admin_status": "up",
            "alias": "Eth8/4",
            "fec": "rs",
            "index": "8",
            "lanes": "48",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet32": {
            "admin_status": "up",
            "alias": "Eth9/1",
            "fec": "fc",
            "index": "9",
            "lanes": "49",
            "speed": "25000"
        },
        "Ethernet33": {
            "admin_status": "up",
            "alias": "Eth9/2",
            "fec": "fc",
            "index": "9",
            "lanes": "50",
            "speed": "25000"
        },
        "Ethernet34": {
            "admin_status": "up",
            "alias": "Eth9/3",
            "fec": "fc",
            "index": "9",
            "lanes": "51",
            "speed": "25000"
        },
        "Ethernet35": {
            "admin_status": "up",
            "alias": "Eth9/4",
            "fec": "fc",
            "index": "9",
            "lanes": "52",
            "speed": "25000"
        },
        "Ethernet36": {
            "admin_status": "up",
            "alias": "Eth10/1",
            "fec": "rs",
            "index": "10",
            "lanes": "53,54",
            "speed": "50000"
        },
        "Ethernet38": {
            "admin_status": "up",
            "alias": "Eth10/2",
            "fec": "rs",
            "index": "10",
            "lanes": "55,56",
            "speed": "50000"
        },
        "Ethernet40": {
            "admin_status": "up",
            "alias": "Eth11",
            "fec": "rs",
            "index": "11",
            "lanes": "57,58,59,60",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet44": {
            "admin_status": "up",
            "alias": "Eth12",
            "fec": "rs",
            "index": "12",
            "lanes": "61,62,63,64",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet48": {
            "admin_status": "up",
            "alias": "Eth13",
            "fec": "rs",
            "index": "13",
            "lanes": "81,82,83,84",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet52": {
            "admin_status": "up",
            "alias": "Eth14",
            "fec": "rs",
            "index": "14",
            "lanes": "85,86,87,88",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet56": {
            "admin_status": "up",
            "alias": "Eth15",
            "fec": "rs",
            "index": "15",
            "lanes": "89,90,91,92",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet60": {
            "admin_status": "up",
            "alias": "Eth16",
            "fec": "rs",
            "index": "16",
            "lanes": "93,94,95,96",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet64": {
            "admin_status": "up",
            "alias": "Eth17",
            "fec": "rs",
            "index": "17",
            "lanes": "97,98,99,100",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet68": {
            "admin_status": "up",
            "alias": "Eth18",
            "fec": "rs",
            "index": "18",
            "lanes": "101,102,103,104",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet72": {
            "admin_status": "up",
            "alias": "Eth19",
            "fec": "rs",
            "index": "19",
            "lanes": "105,106,107,108",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet76": {
            "admin_status": "up",
            "alias": "Eth20",
            "fec": "rs",
            "index": "20",
            "lanes": "109,110,111,112",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet80": {
            "admin_status": "up",
            "alias": "Eth21",
            "fec": "rs",
            "index": "21",
            "lanes": "1,2,3,4",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet84": {
            "admin_status": "up",
            "alias": "Eth22",
            "fec": "rs",
            "index": "22",
            "lanes": "5,6,7,8",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet88": {
            "admin_status": "up",
            "alias": "Eth23",
            "fec": "rs",
            "index": "23",
            "lanes": "9,10,11,12",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet92": {
            "admin_status": "up",
            "alias": "Eth24",
            "fec": "rs",
            "index": "24",
            "lanes": "13,14,15,16",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet96": {
            "admin_status": "up",
            "alias": "Eth25",
            "fec": "rs",
            "index": "25",
            "lanes": "17,18,19,20",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet100": {
            "admin_status": "up",
            "alias": "Eth26",
            "fec": "rs",
            "index": "26",
            "lanes": "21,22,23,24",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet104": {
            "admin_status": "up",
            "alias": "Eth27",
            "fec": "rs",
            "index": "27",
            "lanes": "25,26,27,28",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet108": {
            "admin_status": "up",
            "alias": "Eth28",
            "fec": "rs",
            "index": "28",
            "lanes": "29,30,31,32",
            "mtu": "9100",
            "speed": "100000"
        },
        "Ethernet112": {
            "admin_status": "up",
            "alias": "Eth29/1",
            "fec": "rs",
            "index": "29",
            "lanes": "113",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet113": {
            "admin_status": "up",
            "alias": "Eth29/2",
            "fec": "rs",
            "index": "29",
            "lanes": "114",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet114": {
            "admin_status": "up",
            "alias": "Eth29/3",
            "fec": "rs",
            "index": "29",
            "lanes": "115",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet115": {
            "admin_status": "up",
            "alias": "Eth29/4",
            "fec": "rs",
            "index": "29",
            "lanes": "116",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet116": {
            "admin_status": "up",
            "alias": "Eth30/1",
            "fec": "rs",
            "index": "30",
            "lanes": "117",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet117": {
            "admin_status": "up",
            "alias": "Eth30/2",
            "fec": "rs",
            "index": "30",
            "lanes": "118",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet118": {
            "admin_status": "up",
            "alias": "Eth30/3",
            "fec": "rs",
            "index": "30",
            "lanes": "119",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet119": {
            "admin_status": "up",
            "alias": "Eth30/4",
            "fec": "rs",
            "index": "30",
            "lanes": "120",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet120": {
            "admin_status": "up",
            "alias": "Eth31/1",
            "fec": "rs",
            "index": "31",
            "lanes": "121",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet121": {
            "admin_status": "up",
            "alias": "Eth31/2",
            "fec": "rs",
            "index": "31",
            "lanes": "122",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet122": {
            "admin_status": "up",
            "alias": "Eth31/3",
            "fec": "rs",
            "index": "31",
            "lanes": "123",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet123": {
            "admin_status": "up",
            "alias": "Eth31/4",
            "fec": "rs",
            "index": "31",
            "lanes": "124",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet124": {
            "admin_status": "up",
            "alias": "Eth32/1",
            "fec": "rs",
            "index": "32",
            "lanes": "125",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet125": {
            "admin_status": "up",
            "alias": "Eth32/2",
            "fec": "rs",
            "index": "32",
            "lanes": "126",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet126": {
            "admin_status": "up",
            "alias": "Eth32/3",
            "fec": "rs",
            "index": "32",
            "lanes": "127",
            "mtu": "9100",
            "speed": "10000"
        },
        "Ethernet127": {
            "admin_status": "up",
            "alias": "Eth32/4",
            "fec": "rs",
            "index": "32",
            "lanes": "128",
            "mtu": "9100",
            "speed": "10000"
        }
    },
    "RESTAPI": {
        "certs": {
            "ca_crt": "/etc/sonic/credentials/AME_ROOT_CERTIFICATE.pem",
            "client_crt_cname": "client.restapi.sonic.gbl",
            "server_crt": "/etc/sonic/credentials/restapiserver.crt",
            "server_key": "/etc/sonic/credentials/restapiserver.key"
        },
        "config": {
            "allow_insecure": "false",
            "client_auth": "true",
            "log_level": "info"
        }
    },
    "SNMP": {
        "LOCATION": {
            "Location": "public"
        }
    },
    "SNMP_COMMUNITY": {
        "public": {
            "TYPE": "RO"
        }
    },
    "STATIC_ROUTE": {
        "Vrf_Vlan1000|0.0.0.0/0": {
            "blackhole": "false",
            "distance": "0",
            "ifname": "",
            "nexthop": "10.41.0.2",
            "nexthop-vrf": "Vrf_Vlan1000"
        },
        "Vrf_Vlan1000|10.41.1.0/24": {
            "blackhole": "false",
            "distance": "0",
            "ifname": "Vlan1001",
            "nexthop-vrf": "Vrf_Vlan1001"
        },
        "Vrf_Vlan1001|0.0.0.0/0": {
            "blackhole": "false",
            "distance": "0",
            "ifname": "",
            "nexthop": "10.41.1.2",
            "nexthop-vrf": "Vrf_Vlan1001"
        },
        "Vrf_Vlan1001|10.41.0.0/24": {
            "blackhole": "false",
            "distance": "0",
            "ifname": "Vlan1000",
            "nexthop-vrf": "Vrf_Vlan1000"
        },
        "Vrf_Vlan1001|10.41.2.0/24": {
            "blackhole": "false",
            "distance": "0",
            "ifname": "Vlan1002",
            "nexthop-vrf": "Vrf_Vlan1002"
        },
        "Vrf_Vlan1002|0.0.0.0/0": {
            "blackhole": "false",
            "distance": "0",
            "ifname": "",
            "nexthop": "10.41.2.2",
            "nexthop-vrf": "Vrf_Vlan1002"
        },
        "Vrf_Vlan1002|10.41.1.0/24": {
            "blackhole": "false",
            "distance": "0",
            "ifname": "Vlan1001",
            "nexthop-vrf": "Vrf_Vlan1001"
        },
        "Vrf_Vlan1008|0.0.0.0/0": {
            "blackhole": "false",
            "distance": "0",
            "ifname": "",
            "nexthop": "10.41.8.2",
            "nexthop-vrf": "Vrf_Vlan1008"
        }
    },
    "TELEMETRY": {
        "certs": {
            "ca_crt": "/etc/sonic/telemetry/dsmsroot.cer",
            "server_crt": "/etc/sonic/telemetry/streamingtelemetryserver.cer",
            "server_key": "/etc/sonic/telemetry/streamingtelemetryserver.key"
        },
        "gnmi": {
            "client_auth": "true",
            "log_level": "2",
            "port": "50051"
        }
    },
    "VERSIONS": {
        "DATABASE": {
            "VERSION": "version_3_0_5"
        }
    },
    "VLAN": {
        "Vlan102": {
            "vlanid": "102"
        },
        "Vlan107": {
            "vlanid": "107"
        },
        "Vlan1000": {
            "vlanid": "1000"
        },
        "Vlan1001": {
            "vlanid": "1001"
        },
        "Vlan1002": {
            "vlanid": "1002"
        },
        "Vlan1008": {
            "vlanid": "1008"
        }
    },
    "VLAN_INTERFACE": {
        "Vlan102": {
            "vrf_name": "Vrf_Vlan102"
        },
        "Vlan107": {
            "vrf_name": "Vrf_Vlan107"
        },
        "Vlan1000": {
            "vrf_name": "Vrf_Vlan1000"
        },
        "Vlan1000|10.41.0.1/24": {},
        "Vlan1001": {
            "vrf_name": "Vrf_Vlan1001"
        },
        "Vlan1001|10.41.1.1/24": {},
        "Vlan1002": {
            "vrf_name": "Vrf_Vlan1002"
        },
        "Vlan1002|10.41.2.1/24": {},
        "Vlan1008": {
            "vrf_name": "Vrf_Vlan1008"
        },
        "Vlan1008|10.41.8.1/24": {}
    },
    "VLAN_MEMBER": {
        "Vlan102|Ethernet0": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet4": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet8": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet12": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet16": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet20": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet24": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet28": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet32": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet36": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet38": {
            "tagging_mode": "tagged"
        },
        "Vlan102|Ethernet112": {
            "tagging_mode": "untagged"
        },
        "Vlan107|Ethernet0": {
            "tagging_mode": "tagged"
        },
        "Vlan107|Ethernet4": {
            "tagging_mode": "tagged"
        },
        "Vlan107|Ethernet8": {
            "tagging_mode": "tagged"
        },
        "Vlan107|Ethernet12": {
            "tagging_mode": "tagged"
        },
        "Vlan107|Ethernet16": {
            "tagging_mode": "tagged"
        },
        "Vlan107|Ethernet20": {
            "tagging_mode": "tagged"
        },
        "Vlan107|Ethernet24": {
            "tagging_mode": "tagged"
        },
        "Vlan107|Ethernet28": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet0": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet4": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet8": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet12": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet16": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet20": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet24": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet28": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet32": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet36": {
            "tagging_mode": "tagged"
        },
        "Vlan1000|Ethernet38": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet0": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet4": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet8": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet12": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet16": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet20": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet24": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet28": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet32": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet36": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet38": {
            "tagging_mode": "tagged"
        },
        "Vlan1001|Ethernet116": {
            "tagging_mode": "untagged"
        },
        "Vlan1002|Ethernet0": {
            "tagging_mode": "tagged"
        },
        "Vlan1002|Ethernet4": {
            "tagging_mode": "tagged"
        },
        "Vlan1002|Ethernet8": {
            "tagging_mode": "tagged"
        },
        "Vlan1002|Ethernet12": {
            "tagging_mode": "tagged"
        },
        "Vlan1002|Ethernet16": {
            "tagging_mode": "tagged"
        },
        "Vlan1002|Ethernet20": {
            "tagging_mode": "tagged"
        },
        "Vlan1002|Ethernet24": {
            "tagging_mode": "tagged"
        },
        "Vlan1002|Ethernet28": {
            "tagging_mode": "tagged"
        },
        "Vlan1002|Ethernet32": {
            "tagging_mode": "tagged"
        },
        "Vlan1002|Ethernet36": {
            "tagging_mode": "tagged"
        },
        "Vlan1002|Ethernet38": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet0": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet4": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet8": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet12": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet16": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet20": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet24": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet28": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet32": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet36": {
            "tagging_mode": "tagged"
        },
        "Vlan1008|Ethernet38": {
            "tagging_mode": "tagged"
        }
    },
    "VRF": {
        "Vrf_Vlan102": {},
        "Vrf_Vlan107": {},
        "Vrf_Vlan1000": {},
        "Vrf_Vlan1001": {},
        "Vrf_Vlan1002": {},
        "Vrf_Vlan1008": {}
    }
}
 

Attachments

chicken-of-the-cave

New Member
Mar 13, 2020
18
8
3
Try a different version of SONiC, like an older stream/branch (2021 for example).
Your CPU never be pegged ever when it comes to frame/packet forwarding, and it's a lack of utilizing the Broadcom Tomahawk ASIC. Sounds like bug with the SONiC version that affects the DX010 switch.

Go here for the different SONiC version streams/branches: Pipelines
For broadcom (which the DX010 is part of), you can see different branches there: master, 202205, 202111, etc. Click on Artifacts, and find the .bin file (i.e.: sonic-broadcom.bin ) and use that file to PXE boot.
 

chicken-of-the-cave

New Member
Mar 13, 2020
18
8
3
I also noticed this on the documentation as well:

  1. SAI VRF support
SAI right now does not seem to have VRF concept, it does have VR.

Hence in this implementation release we use VR object as VRF object.

Here are the new flags we propose to add in the SAI interface:

/*
* @brief if it is global vrf
*
* @type bool
* @flags CREATE_AND_SET
* @default true
*/
SAI_VIRTUAL_ROUTER_ATTR_GLOBAL

/*
* @brief continue to do global fib lookup while current vrf fib lookup
* missed
*
* @type bool
* @flags CREATE_AND_SET
* @default false
*/
SAI_VIRTUAL_ROUTER_ATTR_FALLBACK