Intel Xeon-D 1541, sr-iov on 10gbe still fails

EluRex

Active Member
Apr 28, 2015
213
74
28
Los Angeles, CA
My Xeon-D 1541 arrived but the onboard 10gbe x552/x557 SR-IOV still not able to turn on.

PVE 4.1 installed
2016-03-24_10-33-02.jpg

Bios 1.0C....will try to test latest 1.1R later
2016-03-24_10-36-06.jpg

Bios Shows 1541 cpu
2016-03-24_10-36-20.jpg

Bios shows sr-iov is enabled and m.2 slot now is pcie 3.0 x4?! means NVMe SSD?!
2016-03-24_10-37-57.jpg

sr-iov failed on x552/x557.
2016-03-24_10-56-09.jpg

on the otherhand, the i350 sr-iov can be enable with breeze. What I have do wrong? or is Intel mess up again on 1541 again!

Also is the new 1541 m2 changed from M2.sata to M2.pcie 3.0 x4? Because from the bios screen shot as if it is using m2.pcie3.0 x4
 
Last edited:

hjfr

Member
Nov 21, 2013
76
20
8
France
I think, if not present, you need to add "intel_iommu=on" on your kernel boot parameters

After, you can verify that it's ok:
dmesg | egrep -i "IOMM"
...DMAR: IOMMU enabled...

lspci -v
06:00.1 Ethernet controller: Intel Corporation I350 Gigabit Network Connection (rev 01)
Capabilities: [160] Single Root I/O Virtualization (SR-IOV)

And activate a number of virtual card (4 in my example with hardware id 06:00.1):
echo 4 > /sys/bus/pci/devices/0000\:06\:00.1/sriov_numvfs

lspci
07:10.1 Ethernet controller: Intel Corporation I350 Ethernet Controller Virtual Function (rev 01)
07:10.5 Ethernet controller: Intel Corporation I350 Ethernet Controller Virtual Function (rev 01)
07:11.1 Ethernet controller: Intel Corporation I350 Ethernet Controller Virtual Function (rev 01)
07:11.5 Ethernet controller: Intel Corporation I350 Ethernet Controller Virtual Function (rev 01)
 
  • Like
Reactions: Patriot

EluRex

Active Member
Apr 28, 2015
213
74
28
Los Angeles, CA
intel_iommu=on is for KVM passthrough, and it does not affect sr-iov function of ixgbe driver at all.

Also currently i350 has no problem turn on sr-iov and it is the 10gbe card pci id 00.06.00.1 the Intel X552/X557 Ethernet Card

After changing the OS from PVE 4.1 to Ubuntu 15.10. I am able to turn on SR-IOV. so this is a Proxmox VE 4 issue. Not CPU/BIOS/Motherboard issue

Ubuntu 15.10 SR-IOV turn on
sr-iov1.png

Ubuntu 15.10 Kernel Info
sr-iov3.pngsr-iov2.png
 
  • Like
Reactions: BennyE_HH