IBM 46M0997 - Possible dud?

Discussion in 'RAID Controllers and Host Bus Adapters' started by Lost-Benji, Feb 28, 2018.

  1. Lost-Benji

    Lost-Benji Member

    Joined:
    Jan 21, 2013
    Messages:
    368
    Likes Received:
    17
    Hello all,
    I recently purchased a IBM 46M0997 expander and for the life of me, cannot get the Muppet to detect any drives (SAS or SATA) on the BP1, 2, 3 & 4 ports. Used both LSI HBA and Adaptec HW RAID card, same result, they know the expander is there (detected) but nothing after it.

    Any ideas please?
     
    #1
  2. pricklypunter

    pricklypunter Well-Known Member

    Joined:
    Nov 10, 2015
    Messages:
    1,460
    Likes Received:
    414
    I thought some of those cards were locked to IBM servers, maybe I'm wrong. Have you tried a firmware update on the expander? Might be worth a shot :)
     
    #2
  3. Lost-Benji

    Lost-Benji Member

    Joined:
    Jan 21, 2013
    Messages:
    368
    Likes Received:
    17
    Thanks PP,
    I did look at the firmware side but was seeing plenty of results of people who found newer firmware's were more trouble than worth.
    I too have seen vendor locked gear (I have a rather costly HP P822 that I cant use as it wont allow POST), seems strange that I can see the expander on the HBA/RAID host cards but just no drives.
     
    #3
  4. Terry Kennedy

    Terry Kennedy Well-Known Member

    Joined:
    Jun 25, 2015
    Messages:
    992
    Likes Received:
    459
    How are you cabling the expander to the drives/backplane? Are drives detected if you plug the cable currently in one of the expander outputs directly into your host adapter?
     
    #4
  5. Lost-Benji

    Lost-Benji Member

    Joined:
    Jan 21, 2013
    Messages:
    368
    Likes Received:
    17
    Hello Terry,
    The Expander is setup for dual-link back to HBA, so two SFF-8087 cables from either the twin-ports of a LSI HBA or an Adaptec HW RAID card. Drivers were then direct connect cables (SFF-8087 to SATA style fan-out) or SFF-8087 to SFF-8087 cables to backplane, (I have both styles of SM 836 chassis's). No drives detected on HBA/RAID cards, just the the presence of the expander when it's IBM details detected.
    Both the HBA and the RAID card detect the drives and run them just fine solo, just not enough ports hence the expander.
     
    #5
Similar Threads: 46M0997 Possible
Forum Title Date
RAID Controllers and Host Bus Adapters IBM 46M0997 Expander - Problems Sep 19, 2018
RAID Controllers and Host Bus Adapters Dell PERC H700 JBOD or passthru possible? Dec 27, 2018
RAID Controllers and Host Bus Adapters Crossflashing LSI 9271-8i to Dell Perc H710P possible? Aug 22, 2018
RAID Controllers and Host Bus Adapters Something I thought was not possible... Aug 18, 2017
RAID Controllers and Host Bus Adapters Perc H700 (LSI SAS 2108) possible to support Raid-1 and passthrough ? Feb 16, 2017

Share This Page