I can't use IPMIView ...

Yellow monkey

New Member
Jun 29, 2017
5
0
1
40
Hello all

I have a strange situation now.

I use IPMIView-2.9.8 on Redhat5.4 or 5.8.
I can login to target servers's ipmi via IPMIView on above OS.

But I can't login to same server on Redhat 6.7.
Then "break" message is showed.

I use copied same IPMIView files, and target server is same.
So condition is same regarding IPMIView and target ipmi except for OS version.

IPMIView depends on OS version ?

Maybe everyone seggest to me updating IPMIView or ipmi firmware.
I know I can login if I update them.

But I have to investigate about this problem because this is our client's inquiry.

Please give me ideas.

Thanks.

********************************************************************
Redhat 5.4 target server ipmi
M/B: Supermicro X10DRT-PIBF ---------------- X8DTU-LN4F+ login OK
IPMIView-2.9.8

Redhat 5.8 target server ipmi
M/B: Supermicro X10DRT-PIBF---------------- X8DTU-LN4F+ login OK
IPMIView-2.9.8

Redhat 6.7 target server ipmi
M/B: Supermicro X10DRT-PIBF---------------- X8DTU-LN4F+ login NG!!
IPMIView-2.9.8
 

Attachments

Blinky 42

Active Member
Aug 6, 2015
559
200
43
44
PA, USA
Are you using the dedicated IPMI port on the target system or sharing it with the system eth0?

That break usually happens when it can't login to the system (the password changed) or IPMIView can't access the IP for the IPMI interface on the target system. Can you ping the IPMI IP from a console on the same computer running IPMIView in all 3 variations above?
 

Yellow monkey

New Member
Jun 29, 2017
5
0
1
40
Thank you for reply.

I using Dedicated port.

Also I can login to ipmi of target server via firefox or ipmitool, user and passwor is both ADMIN.
Of course ping is reachable on all 3 OS.

But I can't login to target when redhat 6.7.
I think this is depending on library of IPMIView-2.9.8.
Maybe some library are incompatible to Redhat 6.x.
 

Blinky 42

Active Member
Aug 6, 2015
559
200
43
44
PA, USA
You are changing the RedHat version on the server running IPMIView, or on the target that you are trying to log into with IPMIView?

If you are changing the version on the side that is running ipmiview then yes it is some library version issue, you probably need to add some -compat* rpm's to get different versions on the box. I am able to run IPMIView on Centos 6.* and have it log into a whole slew of old and new supermicro motherboards (from x7 through x10 series) there have been issues with the target has the HTML5 iKVM in place instead of the old java nightmare, but I don't need to use IPMIView then anyway.
 

Yellow monkey

New Member
Jun 29, 2017
5
0
1
40
Blinky 42

Sorry for late reply.

Yes, I'm changeing OS version running IPMIView, targer server ipmi remain the same.
And as I told, I use same IPMIView files on each OS.

********************************************************************
Redhat 5.4
M/B: Supermicro X10DRT-PIBF ---------------- X8DTU-LN4F+ (target server ipmi) login_OK!!
IPMIView-2.9.8

Redhat 6.7
M/B: Supermicro X10DRT-PIBF---------------- X8DTU-LN4F+ (target server ipmi) login NG!!
IPMIView-2.9.8
********************************************************************

I don't know well about compat* rpm.
But I will try !
I will let you know after that.

Thanks!
 

Yellow monkey

New Member
Jun 29, 2017
5
0
1
40
Hello

I installed compat rpm files included Redhat6.7 iso.
But it didn't work

avahi-compat-howl-0.6.25-15.el6.i686.rpm
avahi-compat-howl-0.6.25-15.el6.x86_64.rpm
avahi-compat-howl-devel-0.6.25-15.el6.i686.rpm
avahi-compat-howl-devel-0.6.25-15.el6.x86_64.rpm
avahi-compat-libdns_sd-0.6.25-15.el6.i686.rpm
avahi-compat-libdns_sd-0.6.25-15.el6.x86_64.rpm
avahi-compat-libdns_sd-devel-0.6.25-15.el6.i686.rpm
avahi-compat-libdns_sd-devel-0.6.25-15.el6.x86_64.rpm
bitmap-fonts-compat-0.3-15.el6.noarch.rpm
bluez-compat-4.66-1.el6.x86_64.rpm
compat-dapl-1.2.19-2.el6.x86_64.rpm
compat-dapl-devel-1.2.19-2.el6.x86_64.rpm
compat-dapl-static-1.2.19-2.el6.x86_64.rpm
compat-dapl-utils-1.2.19-2.el6.x86_64.rpm
compat-db42-4.2.52-15.el6.i686.rpm
compat-db42-4.2.52-15.el6.x86_64.rpm
compat-db43-4.3.29-15.el6.i686.rpm
compat-db43-4.3.29-15.el6.x86_64.rpm
compat-db-4.6.21-15.el6.i686.rpm
compat-db-4.6.21-15.el6.x86_64.rpm
compat-expat1-1.95.8-8.el6.i686.rpm
compat-expat1-1.95.8-8.el6.x86_64.rpm
compat-glibc-2.5-46.2.x86_64.rpm
compat-glibc-headers-2.5-46.2.x86_64.rpm
compat-libcap1-1.10-1.i686.rpm
compat-libcap1-1.10-1.x86_64.rpm
compat-libgfortran-41-4.1.2-39.el6.i686.rpm
compat-libgfortran-41-4.1.2-39.el6.x86_64.rpm
compat-libtermcap-2.0.8-49.el6.i686.rpm
compat-libtermcap-2.0.8-49.el6.x86_64.rpm
compat-openmpi-1.4.3-1.2.el6.x86_64.rpm
compat-readline5-5.2-17.1.el6.i686.rpm
compat-readline5-5.2-17.1.el6.x86_64.rpm
compat-readline5-devel-5.2-17.1.el6.i686.rpm
compat-readline5-devel-5.2-17.1.el6.x86_64.rpm
compat-readline5-static-5.2-17.1.el6.x86_64.rpm
culmus-fonts-compat-0.103-7.el6.noarch.rpm
geronimo-specs-compat-1.0-3.5.M2.el6.noarch.rpm
lpg-java-compat-1.1.0-4.1.el6.noarch.rpm
nss_compat_ossl-0.9.6-1.el6.i686.rpm
nss_compat_ossl-0.9.6-1.el6.x86_64.rpm
nss_compat_ossl-devel-0.9.6-1.el6.i686.rpm
nss_compat_ossl-devel-0.9.6-1.el6.x86_64.rpm
pulseaudio-esound-compat-0.9.21-21.el6.x86_64.rpm
rarian-compat-0.8.1-5.1.el6.x86_64.rpm
xz-lzma-compat-4.999.9-0.5.beta.20091007git.el6.x86_64.rpm
 

techtoys

Active Member
Feb 25, 2016
177
47
28
54
I had a similar issue.
IPMI View 2.14.0
BMC Firmware 3.17 on X9DRD-7LN4F
could login through browser

upgraded firmware to 3.37 and IPMI View now works.