Hyper-V Client - Integrated Services - Update Required

Lobby

New Member
Feb 27, 2020
3
0
1
Hey Guys, Can't figure this one out.

I have 2016 Hyper-V Server Core running, fully updated. My VM is now showing that an Update is Required for Integrated Services. The VM is running Windows Server 2012 R2. The Network adapter for the VM shows Degraded (Integrated Services Update Required), so no internet on the VM.

If I start the VM, and click Action - Insert Integration Services Setup Disk I get an error "Failed to add device 'Virtual CD/DVD Disk" vmguest.iso not found. I have read that vmguest.iso is no longer in 2016 Hyper-V Server. How do I get this working again? All services appear to be running on both the host and guest.

At a complete loss.

Thanks.
 

j_h_o

Active Member
Apr 21, 2015
593
144
43
California, US
I'd probably give it a legacy NIC, get it on the network, and let the VM guest download the necessary drivers from Windows Update.

Did you just do a fresh install of 2012 R2 on this 2016 guest? Or did it migrate from somewhere else?
 
Last edited:

Lobby

New Member
Feb 27, 2020
3
0
1
It is a Gen 2 VM. I didn't think you could add Legacy adapters to Gen 2. It is not a fresh install. It has been installed for a while and working. There must have been an update on the Core server that created this.
 

Lobby

New Member
Feb 27, 2020
3
0
1
SOLVED: Legacy driver - could not be installed. The VM is a Windows Server 2012 R2 so I downloaded WSUS offline updates and transferred and applied the updates to the VM. Once complete the VM had its internet connectivity back and the Integration services was able to be updated through windows update.